This discussion is archived
2 Replies Latest reply: Dec 18, 2009 7:44 AM by 807567 RSS

SunMC 4 on RedHat Linux 5.1 update 1

807567 Newbie
Currently Being Moderated
Hello,

I have some troubles concerning the configuration of an agent on a server running Red Hat 5.1 U1.
In fact, I can install the agent but I can't setup it.


You must perform setup before using Sun Management Center 4.0.
Do you want to run setup now (y|n|q) y

----------------------------------------------------------------------------
This script will help you to setup Sun Management Center 4.0.
----------------------------------------------------------------------------

Could not find xput executable: /opt/SUNWsymon/base/sbin/xput
Could not find xput executable: /opt/SUNWsymon/base/sbin/xput

Install logfile is : /var/opt/SUNWsymon/install/install_SRVNST09.090624143638.6368
End of Installation
Exiting Sun Management Center 4.0 installation.


As the error says, the xput binary and many others are missing in the base folder. It is the same for lib folder.
I tried on another server with the same configuration and I have the same result.

I tried to copy the missing files from a Solaris server but it does not work. I can't execute the binary (rights are good).
So I guess the files are not copied because not compatible.

As far as I saw, the file to download is the same for Linux and Solaris. The file includes packages for both of them.

So do you know where is the problem on this server?
Do you have any idea?

Thank you for you support.