11 Replies Latest reply on Feb 8, 2010 10:47 PM by 807567

    [smpatch + lps] valid contract but missing entitlement permissions


      My Local Patch Server is registered with a valid contract but when i run the smpatch command :
      smpatch download -x idlist=smpatch_migration_methpr
      I get this error message :
      Error: One or more of the updates specified do not have entitlement permissions.
      And it is right, the files +/var/sadm/spool/patchsvr/%2Fentitlement%2F+ on LPS and
      +/var/sadm/spool/cache/entitlement/https%3A%2F%2Fgetupdates1.sun.com%2F%2Fentitlement_client+ on the clients contain only :
      Why can't i access to all of the patches available ?
      When I download from the Sunsolve website, there are no restrictions.

      Edited by: zobelier on 26 nov. 2009 12:57
        • 1. Re: [smpatch + lps] valid contract but missing entitlement permissions
          I'm having the exact same problem here. I've tried the usual re-register the server routine with no success. I wanted to check and see if anyone is aware of a quick fix before I open a case? Just to note, my SunSolve profile denotes these entitlements for my account:


          However I'm seeing the same problem as above, where the entitlement I receive only has Public.

          Edited by: cbcrawfo on Dec 3, 2009 12:28 PM
          • 2. Re: [smpatch + lps] valid contract but missing entitlement permissions
            This is probably as a result of some ongoing issues with the back-end server. Please raise a support case referencing this thread.
            • 3. Re: [smpatch + lps] valid contract but missing entitlement permissions
              Opened a call that solved the problem.
              • 4. Re: [smpatch + lps] valid contract but missing entitlement permissions
                What can I do, please, if I have only a software contract, but no entitlement to open a support case ?
                Is there somewhere where I can get more information about these "ongoing issues with the back-end server" ?
                • 5. Re: [smpatch + lps] valid contract but missing entitlement permissions
                  There are a number of of places you can use to monitor changes and issues with Sun Update Connection.

                  Sun Update Connection-System/Hosted, Patch Manager & PatchPro Support FAQ & Announcements

                  Sun Update Connection-System / Hosted, Patch Manager & PatchPro Forum

                  Sun Developer Network Public Bug Database

                  The Sun Update Connection do monitor posts to this forum and although priority is given to support cases, the can and do engage with issues through the forum. Although there were some entitlement problems late last year, there are currently no major issues with the back-end for Sun Update Connection.
                  • 6. Re: [smpatch + lps] valid contract but missing entitlement permissions
                    Many thanks for your extremely prompt answer :-)
                    Unfortunately, I have only just checked back to read it, but the last paragraph is the most valuable one -
                    I had done many searches but could not find anything to say the problems with the back-end server had been fixed.
                    Your reply has given me some concrete information, and I now know I have something I must fix.
                    (I had stopped attempting to update the computer in question last September as I had assumed those problems were the cause of the failures (yellow triangles) I was experiencing and had just been trying again to run the update manager on it again in January.)
                    Thanks again.
                    • 7. Re: [smpatch + lps] valid contract but missing entitlement permissions
                      I can check over the configuration if you upload the output of the attached script to supportfiles /cores directory and post the filename here. Feel free to insert your contract number into the output file as it is a secure location..
                      • 8. Re: [smpatch + lps] valid contract but missing entitlement permissions
                        Hi again (another extremely prompt response - much better than e-mailing / phoning support when we did have a contract to do that !!! {-;)
                        Sorry - I did see your reply on the other forum page, and downloaded that suc.sh (I already had one from almost exactly a year ago) but have not got around to running that yet, as am attending to some cfengine problems on a lab full of macs at the moment .....
                        I had run suc.sh on both my sunblade (which is quite happily running the update manager - even if it does mean I have to use the gnmoey window manager instead of my favourite CDE) and the other sunblade (which is an older one). I did this so I could compare the output from that for both, as well as comparing the patch revision levels for both, and could see little difference. The older machine did not have the cacao stuff installed, so I did that. (Sill can't upgrade) However, my machine doesn't actually seem to be using cacao. I also compared the output from svcs. As a result of that I installed some packages, and turned on some daemons (I'm hoping I did not shoot myself in the foot after the last upgrade by turning off some of the networking daemons in a fit of paranoia), but still no luck. I was making a change, running smpatch analyze (while holding my breath in anticipation) and then making another change. Then I ran out of time and had to go home or I would have been walking.)
                        I've just downloaded your attached script and am running it, and will post the filename when I have transferred the output to my machine and uploaded it.
                        Thanks again !
                        • 9. Re: [smpatch + lps] valid contract but missing entitlement permissions
                          Hi there - the file is /cores/frege-080210-suc-out.Z
                          And I'd just like to apologize in advance because I haven't done any more work on the differences between my computer and the older on since Friday night - I may well have missed spotting some difference. Also, I have not done any manual patching of the older machine yet, except to put the cacao stuff on.
                          • 10. Re: [smpatch + lps] valid contract but missing entitlement permissions
                            Thanks for your update. Please do the following:

                            # smpatch unset patchpro.proxy.host
                            # smpatch unset patchpro.proxy.passwd
                            # smpatch unset patchpro.proxy.user
                            # find /var/sadm/spool/cache -type f -exec rm {} \;

                            Also, you are down rev on your java version. Please upgrade your java to Java 6 Update 14

                            or as a temporary workaround you can edit the following files to prevent
                            Java from using anything other than JDK 5:


                            Change the syntax:

                            java -version:1.5+

                            java -version:1.5*

                            This should ensure that the version of Java used is 1.5 and hopefully
                            allow both smpatch and updatemanager to work
                            • 11. Re: [smpatch + lps] valid contract but missing entitlement permissions
                              Ohhhhh ! RED face :-(
                              (I should have been able to work that out for myself.)
                              I just assumed smpatch was not working at all, so had not tried smpatch get, but I did have those variables in the output from previous runs of suc.sh on both machines to compare.
                              (I think maybe I should also not try to just "fit" this sort of thing into my schedule late on a Friday night after a busy week (we are short staffed and stressed at the moment - two car crashes and a mountain bike crash have reduced task accomplishment somewhat) especially when my contact lenses are glugged up and I can't see the screen properly (hard to tell the difference between "*" and "+")
                              So, MORE red face :-(
                              I knew about the java versioning problem and thought I had changed it
                              I must apologize for bothering you - but I am most grateful for your help.

                              BTW - what I did (just in case it helps anyone else) ....
                              mv /var/sadm/spool/cache /var/sadm/spool/cache-update-feb09
                              (I can't bear to delete anything until I know a change has worked)
                              smpatch unset patchpro.proxy.host
                              smpatch unset patchpro.proxy.port
                              smpatch unset patchpro.proxy.user
                              smpatch analyze
                              Failure: Cannot connect to retrieve detectors.jar: Unconnected sockets not implemented
                              smpatch unset patchpro.proxy.passwd
                              smpatch analyze
                              Failure: Cannot connect to retrieve current2.zip: Unconnected sockets not implemented
                              # changed -version:1.5+ to -version:1.5* in /usr/sbin/pprosvc and /usr/bin/updatemanager
                              smpatch analyze
                              142292-01 SunOS 5.10: Place Holder patch

                              Yay - it works !

                              Thank you for the very prompt help. I did get your response last night - I read it just after 1:00am but thought I should leave working on it until the morning - or at least, later in the morning after a sleep.

                              Thank you, thank you, thank you :-)