13 Replies Latest reply: Feb 5, 2010 2:30 AM by 807567 RSS

    Update connection issues update?

    795491
      Is there any word on whether the current update problems (blank exclamation point) are going to be resolved for those without support contracts? (clean install on Sun Microsystems machines)

      I am beginning to get a little worried about keeping up to date on critical security patches.
        • 1. Re: Update connection issues update?
          807567
          As the issue affects contract holders as well as non contract holders, once the fix is finalised all customers encountering this issue will see the fix.

          Our engineers are working towards that fix as quickly as possible.

          If you are not able to login to http://sunsolve.sun.com then it is possible that your account has locked out. Please use the password reset option to try to unblock the account and if that fails, you can always send an email to sunsolve@sun.com (from the registered email account) requesting the account be reset.
          • 2. Re: Update connection issues update?
            795491
            Two of my machines (ultra 20m2 and the blade1000) are now able to update. I made no changes on those machines so something good must have happened on your end. My x2200m2 is still having problems but that is the machine I tried re-registering. I am in the process of troubleshooting that now.
            • 3. Re: Update connection issues update?
              795491
              Well, some good news and some bad. I was able to do the sconadm -a -r bit and get a positive registration using my old kjard_us account.

              bad news is I still get the exclamation point error in update connection. My other systems were getting that too but last night it stopped and I was able to update the systems.

              # smpatch analyze
              Failure: Response code was 500
              • 4. Re: Update connection issues update?
                807567
                Wow, very strange stuff today...

                I just installed 05/09 on my 280r and my blade1000 at the same time this morning. I get to the registration screen on the 280r, put in my kjard_us bit and voila, done, happy, registered and fully patched.

                Roughly an hour later my blade1000 is ready, I try to register, and it tells me that my kjard_us account does not exist. No registration, no patching. So I try that account I made a couple weeks ago when I tried to fix this the first time, it takes it. But when I try to patch I get the exclamation point of death again.

                I try to log into sun forums to post about it and kjard_us does not exist. Either does the 'other' account I made a couple weeks ago and was just accepted by my blade1000 during registration.

                I made another new account! (that is what I am posting with now)

                I sconadm that into my two cranky machines and I am still stuck with the exclamation point of death.

                Are there some directories I should try clearing before running update manager after updating the registration?
                Is there some way to get the gui wizard back? Does that do more or better than sconadm?
                • 5. Re: Update connection issues update?
                  807567
                  Oh and one last bit,

                  all of these accounts are under the same name so if some admin type would like to look at them you can track back from this account.
                  • 6. Re: Update connection issues update?
                    807567
                    You should be able to run the GUI registration wizard after running the following commands:

                    # cacaoadm stop
                    # /usr/lib/cc-ccr/bin/eraseCCRRepository
                    # rm /var/scn/persistence/SCN*
                    # cacaoadm start

                    The GUI registration performs basically the same function as sconadm, there are some differences in the process, however either method of registration is fine.

                    Can you run smpatch analyze on any of the systems that have the exclamation point?

                    Regarding you account issues, you should contact sunsolve@sun.com directly to look into it.
                    • 7. Re: Update connection issues update?
                      807567
                      What a mess... I had to make another account to post again. All three of the earlier accounts say they do not exist when I try to log into the forums but when I try to create an account it says that all three already exist (if I try to use one of the old email addresses). Same if I do the username retrieval.

                      Here is what happens with smpatch analyze

                      Ultra20m2 sol10 05/09 everything works fine all of a sudden, was able to patch it 10 minutes ago.
                      Blade1000 sol10 05/09 smpatch analyze gives current2.zip error
                      280r sol10 05/09 smpatch analyze gives current2.zip error
                      x2200m2 sol10 05/09 smpatch analyze gives Failure: Response code was 500

                      Is there some way to see which name I have the ultra20m2 registered under? It is very curious it is working all of sudden.
                      • 8. Re: Update connection issues update?
                        807567
                        You can the name under which the ultra20m2 registered by running the suc script or checking your registration.profile file. The issue about patch errors is being fixed
                        • 9. Re: Update connection issues update?
                          807567
                          Thanks. I will see what I can do about the accounts.
                          • 10. Re: Update connection issues update?
                            807567
                            I've noticed that there are a number of questions about this same issue...although some speak to the inability to download detectors.jar or current2.zip instead of the exclamation point issue found with the GUI. I've also noticed that there really hasn't been a definitive answer.

                            I, too, am experiencing the same issue, regardless of which account I use to register. Successful sconadm registration and no ability to use smpatch <command> are the symptoms, although smpatch works on other machines that had been earlier registered with the same accounts. BTW, this was a clean install of Solaris 10 x86 with the Recommended patch cluster applied.

                            I have followed the instructions below, i.e. turning off the cacao stuff and cleaning things up, but to no avail. I have run the suc.sh script and compared the results with that posted by others in the forum. There is no difference. I do not have Java6 installed, although I did make the changes to the two patching utility files mentioned, /usr/sbin/pprosvc and /bin/updatemanager, but that didn't work either. (* to a +)

                            I am able to connect using a browser to the urls for current2.zip and detectors.jar in the error logs, and I can, with the same credentials used to register, download those files.

                            Any other ideas?

                            Tom Frerichs
                            • 11. Re: Update connection issues update?
                              807567
                              We're currently expecting a fix to be pushed out on the 29th of this month. It's currently in testing in the lab and everything so far looks fine.
                              • 12. Re: Update connection issues update?
                                807567
                                May I ask, please - did this fix get pushed out, and if so, did it fix the problems for kjard and tom_frerichs ?
                                (And do you have to be able to run smpatch to get a fix ? }-:)
                                Because I am still having a problem with one sunblade system (Solaris-10 upgrade from Solaris-9 and wasn't being kept very up-to-date patchwise whereas another sunblade with a clean install of Solaris-10 and constant updates works fine)
                                • 13. Re: Update connection issues update?
                                  807567
                                  This fix was pushed into the back-end late last year therefore this should not be a problem. We cannot speak for kjard and tom_frerichs although I would hope that they are not encountering any issues after the fix as they have not posted in this thread for some time.

                                  With respect to your problem with the Solaris 10 upgrade, it is probably due to the upgrade that you are experiencing the issue. Although every opportunity is taken to keep installation media up to date, depending on the release, your patch/pkg level may not be in line with back-end upgrades to the hosting service. Please run the attached script on your problematic host and post the output. Please upload the output to us using the supportfiles service:

                                  https://supportuploads.sun.com/upload ### under destination /cores.

                                  Please rename the file with a unique identifier for example, your forum name, and post in the thread when you have uploaded it. Hopefully we can resolve this for you relatively quickly, but please bear in mind my answer to your other question today regarding our response.