1 Reply Latest reply on Apr 3, 2009 1:52 PM by 807567

    install_cluster not very discreet about relocated (alternate) roots with -R

      I was trying to patch a sol10u6 alternate boot environment the other day, with my
      currently loaded OS being OpenSolaris (snv_110 with sol10u6 LU packages).

      First, I quickly failed the LiveUpgrade method as recommended in Recommended
      Patch Cluster README, i.e.

      # luupgrade -n sol10u6 -s /export/distr/10_x86_Recommended -t `cat patch_order`

      This failed on the first package yielding an error (I believe it was SUNWgzipS or
      something like that - which we don't have installed).

      Second, I tried running install_cluster -R /.alt.sol10u6, but this also failed due to
      the currently running OS not being like the one I'm trying to patch.

      Do I misunderstand something about applying patches to alternate roots of offline
      system images? Or do the patch tools' authors? ;)

      In the end, just in case somebody needs to do this after all, here's how I solved
      the quest: I booted sol10u6 failsafe mode. The "normal" mode couldn't mount its
      ZFS root after "luupgrade" from OpenSolaris to sol10u6 (in short, DON'T!), so I
      went into trying patching in the first place.

      In the Failsafe mode I mounted all the filesystem hierarchy of sol10u6 alternate
      BE under /a, and mounted the unpacked patch cluster dataset (/export/distr).

      While running "install_cluster -R /a" I still ran into problems with it tryng to access
      hardcoded paths like /var/sadm (which are on the read-only failsafe root FS).

      I edited the script and replaced all references to /var, making them /a/var (more
      cleanly they should take the value of -R parameter), and successfully applied
      the patch cluster.

      One "bootadm update-archive -R /a", and I was on my way on rebooting the
      updated OS.

      PS: the resulting mix of osol drivers and sol10 binaries still failed to boot, but
      that's another story I finally fixed by cloning another server's FS.

      The morale of my story is, IMHO, install_cluster should not use hardcoded
      paths like /var/sadm, but it should rather prepend the alternate root path value
      (if provided) to them.

      //Jim Klimov