1 Reply Latest reply: Aug 3, 2009 6:20 PM by alan.pae RSS

    Updating Solaris 10 /var/sadm/install/contents file  (pkgchk error)

    807567
      Hi All,

      I have updated around 1000 files of an existing package.Then I gave "pkgchk" command and I got pkgchk errors against all the 1000 updated files. I think it is because registry file */var/sadm/install/contents* is not updated with the latest change,

      I tried to update the /var/sadm/install/contents file by calling installf command on all the file names I have modified. It solved my problem but it took around 8 minutes to complete the process.

      The two approaches which I have used are

      1) find direcory_name>temp
      for line in `cat temp`;do
      installf pkg_name $line
      done
      installf -f pkg_name

      2) find <directory_name> | xargs -i {} installf <pkgname> {}
      installf -f pkg_name

      The above 2 approaches took around 8 minutes to complete.

      Is there any way to fix the registry quickly, so that no pkgchk errors should come?
      If not,is there any way to update */var/sadm/install/contents* file with in 2 minutes?

      Please, can anyone help me to solve this problem. Thanks in advance.