4 Replies Latest reply on Jul 17, 2012 9:07 PM by 950124

    NSS Initialization Failed

      I recently installed a fresh copy of Sun Webserver 6.1 on Red Hat Enterprise Linux 5.5. After successfully completing the install, I tried to start the administrative server and got the following errors in the log:

      info ( 2979): CORE1116: Sun ONE Web Server 6.1SP11 B03/25/2009 14:56
      failure ( 2980): CORE1227: NSS initialization failed: unknown error -8038: Certificate database: /opt/SUNWwbsvr/alias/https-admserv-hostname-cert8.db
      failure ( 2980): CORE3174: NSS initialization failed

      Does anyone have any ideas about what might be the problem? I noticed that the /opt/SunWwbsvr/alias folder was empty. Is that normal? I then tried copying the contents of the alias folder from another server to the machine with the empty alias folder. The problem persisted.

      Any ideas would be appreciated.

      Note: Upgrading to WebServer 7 is not currently an option due to some ancient webapps.
        • 1. Re: NSS Initialization Failed
          I'd guess that there are dependencies that WS has on the OS that are no longer valid in RHES 5.5. If you can't upgrade to a newer version of WS then your next option would be rolling back to RHEL 4.x OR doing the heavy lifting to port your apps to work in a more modern web container.

          (I'd advise that your best option is heavy lifting and porting rather than trying to get ancient Server, Java, and OS to play well in the modern world.)
          • 2. Re: NSS Initialization Failed
            You will need to downgrade your NSS libraries and all its associated libraries to an ancient version that was used in 6.1. Note that this probably will break everything else on RH 5.5 which relies on the latest versions of those libraries so you probably be better off doing what jmccabe suggested.
            • 3. Re: NSS Initialization Failed
              This is because of some changes in the certificate DB. Can you let us know if you have done any changes in the server certs that could have changed the cert.db.
              • 4. iPlanet 6.1 webserver Admin console Trust Store username and password reset
                Dear All,

                I am having the same issue as well. The admin we had before has left and has not passed on the iPlanet 6.1 webserver Admin console username and password and the Trust Store username and password as well.
                How do we reset the Trust Store password and launch the console?

                [root@webserver01]# ./startconsole
                Sun ONE Web Server 6.1SP14 B03/27/2011 00:31
                Please enter password for "internal" token:
                Password incorrect. Please try again.
                Please enter password for "internal" token:
                Password incorrect. Please try again.
                Please enter password for "internal" token:
                failure: CORE1227: NSS initialization failed: SEC_ERROR_BAD_PASSWORD: The security password entered is incorrect: Certificate database: /opt/iplanet/server/alias/https-admserv-webserver01-cert8.db
                failure: CORE3174: NSS initialization failed

                Any help is greatly appreciated.