0 Replies Latest reply: Mar 30, 2010 6:26 AM by 807573 RSS

    Unable to Deploy SRM5.3 on Application Server (BEA Weblogic 10.0)

    807573
      Hi,
      I m trying to deploy Sun Role Manager 5.3 on BEA WLS 10.0 for Windows Platform(OS: Windows 2000 Server ).
      Using MySQL Database Server.
      For this deployment I have followed the link: http://wikis.sun.com/display/Srm503Docs/Installationand+Upgrade+Guide+(Printable)+

      Under system environment I have set:
      JAVA1.5.0_15
      RBACX_HOME
      RM_LIB

      Under rbacx_staging/*<span style="border-collapse: separate;font-style: normal;font-variant: normal;font-weight: normal;letter-spacing: normal;line-height: normal;orphans: 2;text-indent: 0px;text-transform: none;white-space: normal;widows: 2;word-spacing: 0px" class="Apple-style-span">{font:'Times New Roman'}{size:medium}{color:#000000}<span style="line-height: 24px;text-align: left" class="Apple-style-span">{font:Helvetica,Arial,sans-serif}{size:17px}WEB-INF/lib <span class="Apple-converted-space">{color}{size}I have provided below jar:*
      jasper-jdt.jar
      mysql-connector-java5-1-7bin.jar(already present)


      In deployment at last step I have followed:
      <span style="border-collapse: separate;font-style: normal;font-variant: normal;font-weight: normal;letter-spacing: normal;line-height: normal;orphans: 2;text-indent: 0px;text-transform: none;white-space: normal;widows: 2;word-spacing: 0px" class="Apple-style-span">{font:'Times New Roman'}{size:medium}{color:#000000}<span style="line-height: 24px;text-align: left" class="Apple-style-span">{font:Helvetica,Arial,sans-serif}{size:17px}
      <li style="margin: 0px; padding: 0px; font-size: inherit; line-height: 13pt">Ensure that the deployment is named<span class="Apple-converted-space"> rbacx.(as Web service name)</li>
      <li style="margin: 0px; padding: 0px; font-size: inherit; line-height: 13pt">Under Security, select DDOnly: Use Only Roles And Policies That Are Defined In This Deployment.</li>
      <li style="margin: 0px; padding: 0px; font-size: inherit; line-height: 13pt">Under Source Accessibility, select Use The Defaults Defined By The Deployment's Targets.</li>{color}{size}
      During deployment there no a single error but as I click on rbacx under deplloyment there is nothing to show under WebService
      <img src="file:///C:/DOCUME%7E1/NEERAJ%7E1/LOCALS%7E1/Temp/moz-screenshot.jpg" alt="" />It looks like as:

      *{color:#ff0000}Name: State: Type: Deployment Order:*
      *{color}*
      {color:#0000ff}rbacx prepared <span class="bea-portal-theme-wlsworkspace">Web Application 100{color}
      {color:#0000ff} Web Services
      Non to display{color}

      As there is non under WebServices so may be thats the reason that I cant able to start SRM.
      Once it start then after some time it automatically shows failed status.

      Please let me know if there is something wrong during configuration or deployment of SRM.
      Thanx in advance!!!

      <img src="file:///C:/DOCUME%7E1/NEERAJ%7E1/LOCALS%7E1/Temp/moz-screenshot-1.jpg" alt="" /><img src="file:///C:/DOCUME%7E1/NEERAJ%7E1/LOCALS%7E1/Temp/moz-screenshot-2.jpg" alt="" />