This discussion is archived
2 Replies Latest reply: Oct 29, 2003 8:06 PM by 807574 RSS

iPS30SP3 gateway proxy setup problem

807574 Newbie
Currently Being Moderated
Hi All,

I have a problem to setup the gateway proxy. I've follow the admin guide to setup the gateway proxy. I enable gateway proxy and use 10443 (default, I think) for the gateway proxy port. I restart the gateway and server, start the ipshttpd and connect to the gateway say gateway.test.com, it always return

Unable to fulfill your request
Server returned 502 Gateway Error: Session: Unable to connect to host: server.test.com

where server.test.com is my portal server name.

Do anyone have experience to setup gateway proxy?
  • 1. Re: iPS30SP3 gateway proxy setup problem
    807574 Newbie
    Currently Being Moderated
    Setting up the various types of gateway 'proxy' can be
    confusing ... you have option of a http type proxy for
    your connections or the internal iplanet proxy which is
    'secure'
    for the secure proxy you only need to do ...
    . reverse any changes you may have made to platform.conf on the gateway

    . from console -> manage gateway profile -> advanced
    HTTP Proxy Enabled checkbox crossed
    HTTP Proxy Port (pick a high one).


    once enabled, you should be able to manually start
    ipshttpd and see it listening on the allocated port.
    netstat -an | grep highport

    restart your gateway and it will forward requests to this.

    ditto if you want to use the netlet proxy.

    Mark
  • 2. Re: iPS30SP3 gateway proxy setup problem
    807574 Newbie
    Currently Being Moderated
    Hello,

    I've got the same problem in the setting which gw and portal in seperate machine.

    I fact, i had a testing machine which installed gw and portal server in the same machine. In this environment, there is no error for configuring Http Proxy. I use 8900 as the port num.

    In my prod env't, gw and portal is installed in seperate machines and gw has configured https (SSL) which listem to port 443. After I enabled HTTP proxy and set the port num as 8900, it always return gateway 502 error