1 Reply Latest reply: May 2, 2009 6:25 PM by 807574 RSS

    problem running any web applications in netbean

    807574
      I receive this error message whenever i wanted to run any web applications in my netbeans. The following messages usually come up and I want people to help me:

      init:
      deps-module-jar:
      deps-ear-jar:
      deps-jar:
      library-inclusion-in-archive:
      library-inclusion-in-manifest:
      compile:
      compile-jsps:
      The Sun Java System Application Server could not start.
      More information about the cause is in the Server log file.
      Possible reasons include:
      - IDE timeout: refresh the server node to see if it's running now.
      - Port conflicts. (use netstat -a to detect possible port numbers already used by the operating system.)
      - Incorrect server configuration (domain.xml to be corrected manually)
      - Corrupted Deployed Applications preventing the server to start.(This can be seen in the server.log file. In this case, domain.xml needs to be modified).
      - Invalid installation location.
      C:\usr\JavaProjects\LtlProjects\nbproject\build-impl.xml:568: Deployment error:
      The Sun Java System Application Server could not start.
      More information about the cause is in the Server log file.
      Possible reasons include:
      - IDE timeout: refresh the server node to see if it's running now.
      - Port conflicts. (use netstat -a to detect possible port numbers already used by the operating system.)
      - Incorrect server configuration (domain.xml to be corrected manually)
      - Corrupted Deployed Applications preventing the server to start.(This can be seen in the server.log file. In this case, domain.xml needs to be modified).
      - Invalid installation location.
      See the server log for details.
      BUILD FAILED (total time: 1 minute 1 second)
        • 1. Re: problem running any web applications in netbean
          807574

          Netbeans is unable to deal with alias host name "localhost". But it isn't the only local server.

          Search for *::1 localhost* in your host file.
          I have Windows OS so host file is in this folder
          C:\Windows\System32\drivers\etc\hosts

          add *127.0.0.1 localhost* to the hosts file above the existing entry

          Should look like this:

          127.0.0.1 localhost
          ::1 localhost

          Stop server and close netbeans (if not already done).
          Restart and test. Server startup should be quicker.