0 Replies Latest reply: Apr 22, 2009 9:35 AM by 807574 RSS

    Messaging server wont start with upgrade of DSEE from 5.2 to 6.x

    807574
      Hi all,
      I'm doing the single host install of JES 4 on a Solaris zone (SPARC) and ESX VM (x86) in order to test the upgrade procedure from JES4 to JES5.
      SunOS jes5 5.10 Generic_118855-36 i86pc i386 i86pc

      When I do the DSEE upgrade from 5.2 to 6.0 or 6.3 I have the following problems:
      a) If I do an automatic migration (dsmig) without the -N for o=netscaperooteverything seems to run fine but when I try to bring up the messaging server I get the following error:
      root@jes5 SUNWdsee#/opt/SUNWmsgsr/sbin/start-msg
      [22/Apr/2009:10:13:03 -0400] jes5 [10885]: General Error: func=_configdrv_pset_fetch;error=could not access server's configuration in ldap: func=psetRealCreate; error=Entry does not exist
      NO configmsg_init error
      [22/Apr/2009:10:13:03 -0400] jes5 [10887]: General Error: func=_configdrv_pset_fetch;error=could not access server's configuration in ldap: func=psetRealCreate; error=Entry does not exist
      ERROR: Could not initialize config system

      b) If I do an automatic migration with -N the migration goes fine until I get to 'dsmig migrate-data -N -v'. Once that process runs and it tries to start the DS I get the error below and the DS does not start up.

      ##[22/Apr/2009:10:17:55 -0400] - DEBUG - conn=-1 op=-1 msgId=-1 - libdb: /var/opt/SUNWdsee/slapd2/db/NetscapeRoot/NetscapeRoot_id2entry.db3: unexpected file type or format
      ##[22/Apr/2009:10:17:55 -0400] - WARNING<20498> - Backend Database - conn=-1 op=-1 msgId=-1 - dbp->open("NetscapeRoot_id2entry.db3") failed Invalid argument (22)
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start database plugin ldbm database
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<5126> - Resource Limit - conn=-1 op=-1 msgId=-1 - nsLookThroughLimit: parameter error (slapi_reslimit_register() already registered)
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<20748> - Backend Database - conn=-1 op=-1 msgId=-1 - start: Resource limit registration failed
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start database plugin ldbm database
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4139> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Error: Failed to resolve plugin dependencies
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start preoperation plugin 7-bit check
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start accesscontrol plugin ACL Plugin
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start preoperation plugin ACL preoperation
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start postoperation plugin Class of Service
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start object plugin gle
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start database plugin ldbm database
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start postoperation plugin MemberOf Plugin
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start object plugin Multimaster Replication Plugin
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start postoperation plugin referential integrity postoperation
      ##[22/Apr/2009:10:17:55 -0400] - ERROR<4138> - plugin_dependency_startall - conn=-1 op=-1 msgId=-1 - Configuration error Failed to start postoperation plugin Roles Plugin
      Operation "migrate-data" failed.

      c) Finally I have tried various manual migration scenarios with little or no luck. The furthest that I have gotten is to have both DSEE 6.x and the messaging server start up but not being able to imap or pop into users accounts. Can anyone who has either successfully or not done a similar migration please chime in. This has baffled me for about a month now.

      Edited by: emanners@fsu.edu on Apr 22, 2009 7:35 AM