This discussion is archived
2 Replies Latest reply: Aug 21, 2009 8:41 AM by 807578 RSS

Serous display issues with JDS in S10 update 7

807578 Newbie
Currently Being Moderated
I've just jumpstarted an instructional lab with 26 Suns (common jumpstart profile) running the 05/09 release. And JDS is acting extremely flaky for both new and existing accounts. Symptoms include:

gnome-terminal starts up un-themed (e.g. simple square window), no accelerator keys (shift-ctrl-T, etc) ... and generally, no settings at all.

The main panel is floating near the top left corner, and has NO contents.

Alt-TAB does not switch between minimized applications.

This occurs across multiple user accounts, new (e.g. no contents at /home) and existing (e.g. have been using JDS for two years or more).

OK, so you can manually "fix" some of this stuff, but with a couple of hundred users that really isn't an option.

Suggestions? Is this a known bug??

(metacity --replace is not the answer)                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
  • 1. Re: Serous display issues with JDS in S10 update 7
    807578 Newbie
    Currently Being Moderated
    Closer to underestanding the problem.

    When I log on to one of these machines with a "virgin" user account, select "Launch / Preferences / Desktop Preferences / Display / Themes", I get back a pop-up saying (roughly) "I can't do that because
    either you don't have metacity installed or gconf is mis-configured".

    SUNWgnome-wm is installed and metacity is running. All of the GNOME2 stuff is installed.
  • 2. Re: Serous display issues with JDS in S10 update 7
    807578 Newbie
    Currently Being Moderated
    Certainly doesn't sound like any of the more common login issues I've heard of -- I'm not really familiar with jumpstart installs, but it certainly sounds like not everything has been installed that ought to have been.

    Logging into a failsafe terminal and running 'gnome-session' from there may give more clues...