1 Reply Latest reply: Nov 1, 2006 7:34 AM by 807581 RSS

    Iplanet 6.0 web-apps.xml config issue..!

      I would like to know the reason for marking webapps_enable="off" or "on" in server.xml.

      The issue I'm facing is when I say :
      <VARS docroot="/usr/sample-app/web" webapps_file="web-apps.xml" webapps_enable="on"/>

      and my web-apps.xml file looks like this:
      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE vs PUBLIC "-//Sun Microsystems, Inc.; iPlanet//DTD Virtual Server Web Applications 6.0//EN"

      <session-manager class="com.iplanet.server.http.session.IWSSessionManager">
      <parameter-encoding enc="UTF8"/>

      If I make webapps_enable="on" and add a new URI as :
      <web-app uri="/sampleapp" dir="/usr/sample-app/sampleapp" enable="true"/>

      I'm getting the following error message when I start my web server;
      vs(https-somapp.xyz.COM)SAX parser error: The content of element type "vs" must match "(auth-native?,class-loader?,jsp-servlet?,parameter-encoding?,response-buffer?,response-cookie?,config-param*,role-mapping?,session-manager?,session-tracking?,session-cookie?,tempdir?,form-login-session?,web-app*)". in file:web-apps.xml at line number 22.

      Kindly assist me as I'm a newbie to Iplanet configurations.
      Thanks in advance
        • 1. Re: Iplanet 6.0 web-apps.xml config issue..!

          In server.xml, the VS tag needs to also include the id of the virtual server, i.e.
          <vs> is wrong, it should be something like:
          <VS id="server.iplanet.com" connections="group1" mime="mime1"

          Please see the following doc for more detail on the VS element:

          By the way, this is the wrong forum to post questions on webserver to, you should use the following forum in future:

          Hope this helps