This discussion is archived
6 Replies Latest reply: Oct 4, 2006 9:32 PM by 807581 RSS

iplanet application server 6.5 on windows xp

807581 Newbie
Currently Being Moderated
I'm trying to install iplanet application server 6.5 on windows xp. but for some reason it just hangs at the end of the install. Leaving my no choice but to quit the instalation. Has anyone sucessfully install 6.5 on xp? and could anyone help? would be appreciated.
Thanks in advance...
  • 1. Re: iplanet application server 6.5 on windows xp
    807581 Newbie
    Currently Being Moderated
    Hi,
    I believe iAS 6.5 is tested to work with Windows 2000 Professional and Server. Please check the following site for iAS 6.5 Certification.
    However I would like to help you. Please ensure the following before you install next time.
    1. A static ip address which is other than 127.0.0.1
    2. Valid Host and Domain name
    3. Sufficient disk space

    Please let me know the outcome.

    Thanks & Regards
    Ganesh .R
    Developer Technical Support
    Sun Microsystems
    http://www.sun.com/developers/support
  • 2. Re: iplanet application server 6.5 on windows xp
    807581 Newbie
    Currently Being Moderated
    I had the same problem while installing IAS 6.5 on Windows XP Home. The installation hangs up.

    I have enough memoy( ~40 GB) and static IP address. A valid host and domain name.

    Then I tried 6.0 SP2, I am running into same problem.

    Does anyone what could be the problem.

  • 3. Re: iplanet application server 6.5 on windows xp
    807581 Newbie
    Currently Being Moderated
    iPlanet Application Server 6.5 has not been tested and certified by iPlanet
    engineering to work with Windows XP.

    Please refer the below URL for more documentation
    http://docs.sun.com/source/816-5788-10/prep.htm#43385

    Thanks
  • 4. Re: iplanet application server 6.5 on windows xp
    807581 Newbie
    Currently Being Moderated
    I have just tried installing on my pc and it gives me the same problem, but I have seen my friend using iPlanet on XP and it works fine, It seems that it nearly takes an hr in that hanged-up state to actually work fine.. but in my case it really din't work.

    please let me know if any 1 is aware of this problem and has some kinda solution
  • 5. Re: iplanet application server 6.5 on windows xp
    807581 Newbie
    Currently Being Moderated
    All,

    I've got a similar problem as I am having to support a live
    legacy application that is runing under ias 6.5 SP1. When
    attempting to install ias 6.5 SP1 under Windows XP Pro SP2 the install apears to work however the final progress bar just hangs.

    Has anyone solved the problem of runing ias 6.5 under Win XP ? Migrating to JSAS 8.1 is currently not an option.

    Is there a complete installation of ias 6.5 SPx Update 7 from Sun that allows me to do a complete the installation? Is there a registry hack I could use to fool ias 6.5?

    Regards

    Daniel
  • 6. Re: iplanet application server 6.5 on windows xp
    807581 Newbie
    Currently Being Moderated
    I've just spent a day or two mucking around with getting the iPlanet 6.5 Application Server install running with IIS on XP, and have got as far as having the "fortune" application running. I also encountered the "hanging installation" problem on my 5th or 6th reinstallation. Here is my checklist of things to do:

    1. As has been pointed out earlier, you must have a static IP address assigned to the machine you are installing on.

    2. You should set up IIS before installing iPlanet - during the install you'll be prompted to set up the Web Connector for IIS.

    3. If you find that the install hangs at the end (seems to be in the middle of building the Start Menu shortcuts), then deinstall from the Control Panel | Add Remove Software and run the install in Windows 2000 compatibility mode - this article lays out how to start applications in compatibility mode:
    http://www.microsoft.com/windowsxp/using/games/expert/durham_og.mspx

    4. You need to switch IIS to run in-process as per these instructions:
    http://docs.sun.com/source/816-5788-11/app1.html#14411
    see the section "Registering the Plug-in on IIS 5.0 running on Windows 2000".
    Note that in XP the tab is called "Directory" rather than "Virtual Directory" and ensure that you grant Execute Permission to both Scripts and Executables (default is just Scripts I think)

    5. You need to grant security permissions to the registry key
    \\local machine\\software\\iplanet\\Appserver\\6.0\\CCS0\\HTTPAPI
    as per the post by Vaidyanathan Iyer :
    http://swforum.sun.com/jive/thread.jspa?threadID=20660&tstart=90

    Regards