This discussion is archived
2 Replies Latest reply: Nov 1, 2010 6:26 AM by PVM RSS

Oracle ECM 11g --- UCM server startup issue

PVM Newbie
Currently Being Moderated
Hi All,

I have installed Oracle ECM 11g on RHEL4. Installation steps i followed are:

1. Installed 11R2 DB
2. Created schema using RCU
3. Installed WLS
4. Installed ECM 11g
5. Created WL Domain

I started Administration Server. When i tried to start the managed server (./startManagedWebLogic.sh UCM_server1 <admin_url>) , its giving error

Caused By: intradoc.common.ServiceException: !apSystemTimeZoneNotDefined,Asia/Kolkata
at intradoc.shared.LocaleLoader.loadLocaleConfig(LocaleLoader.java:119)
at intradoc.server.IdcSystemConfig.configLocalization(IdcSystemConfig.java:759)
at intradoc.admin.IdcAdminSystemLoader.init(IdcAdminSystemLoader.java:70)
at intradoc.admin.IdcAdminManager.init(IdcAdminManager.java:98)
at intradoc.idcwls.IdcServletRequestUtils.initializeServer(IdcServletRequestUtils.java:614)
at intradoc.idcwls.IdcServletRequestUtils.initializeServer(IdcServletRequestUtils.java:451)
at intradoc.idcwls.IdcIntegrateWrapper.initializeServer(IdcIntegrateWrapper.java:102)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

I added SystemTimeZone=Asia/Kolkata entry in config.cfg. I tried again. But same error.

Then i thought to change the parameter using SystemProperties applet. But in ucm/cs/bin , there is no executable like SystemProperties etc except 2 files autoinstall.cfg  intradoc.cfg.

Can you please help me on this? ..... I just confused why these executable are not present in the directory.

Thanks,
Manikandan
  • 1. Re: Oracle ECM 11g --- UCM server startup issue
    Srinath Menon Guru
    Currently Being Moderated
    Hi


    This is a known issue with UCM 11g where in the TZ entries for some zones have been omitted . And the reason why you don't see the Applets are that they are created only once the UCM managed server starts up .

    So in order to get around this issue go to config.cfg and change the entry for SystemTimeZone from Asia/Kolkata to UK . Save the config file , start managed server and then you will get it up and running .

    Once it is up and running then go to System Properties applet and change the TZ to SriLanka/Colombo (not sure exactly the term used) which is the closest to India TZ and save it .

    Hope this helps .

    Also you want to upgrade the UCM instance once it is up and running as I believe that this issue is fixed in the patchset .

    The patch version is 9725318. The steps for applying the patch are :

    1. Make sure ORACLE_HOME is set to the [ecmhome] directory.
    2. Get the patch zip.Unzip said patch into a temporary directory.
    3. Change into the patch directory.
    4. It contains a top level directory, make sure you change into that as well.
    5. Run OPatch apply: [ecmhome]/OPatch/opatch apply

    There are a significant number of updates in the patch, particularly for URM .


    Thanks
    Srinath
  • 2. Re: Oracle ECM 11g --- UCM server startup issue
    PVM Newbie
    Currently Being Moderated
    Hi Srinath,

    Thanks for the replay. This is very helpful information.

    Before reading your thread, i did this way,
    i just add entries in config.cfg.

    SystemLocale=English-US
    SystemTimeZone=America/New_York

    UCM server Successfully started after this. Any way i will do whatever you suggested.

    Thanks,
    Manikandan

    Edited by: Manikandan on Nov 1, 2010 6:26 AM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points