0 Replies Latest reply on Nov 4, 2010 7:00 AM by 810398

    Increasing memory allocation size causes program crash


      I needed to increase the memory allocation pool size because I was having trouble with cpu load when I set the -Xmx argument to 800m. After a few days, cpu load goes up to 60% and then program crashes.

      I tried to set this argument to -Xmx1400m (same result for -Xmx1000m) then I got the following error after a few minutes later:


      # A fatal error has been detected by the Java RTS Runtime Environment:
      # Internal Error (sharedRuntime.cpp:621), pid=10131, tid=266
      # Error: exception happened outside interpreter, nmethods and vtable stubs (1)
      # Java VM: Java Real-Time System HotSpot(TM) Client VM (1.5.0_20-b19 mixed mode)
      # If you would like to submit a bug report, please visit:
      # http://java.sun.com/webapps/bugreport/crash.jsp

      --------------- T H R E A D ---------------

      Current thread (0x08589878): JavaThread "RealtimeThread-5" [_thread_in_Java, id=266]

      Stack: [0x3f59b000,0x3f69b000), sp=0x3f699c30, free space=1019KB
      Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
      V [libjvm.so+0x47c51e]
      V [libjvm.so+0x47d53b]
      V [libjvm.so+0x21a166]
      V [libjvm.so+0x4083c5]
      V [libjvm.so+0x134900]
      V [libjvm.so+0x133e93]
      C [libc.so.1+0xa75df]
      C [libc.so.1+0x9d2a0]
      C [libc.so.1+0x9d3ca]
      C 0xffffffff
      J java.util.ArrayList.remove(I)Ljava/lang/Object;
      J optisplit.YKesimConf.sortOpti()V
      J optisplit.YKesimConf.genOptiList()V
      J emg.opti.interfaces.OptiListGenerator.calcOptiList(Z)V
      J emg.opti.core.Opti.generateOptiList()V
      j emg.opti.core.Opti.ruleCheck(D)Z+55
      j emg.opti.core.Opti.cut(D)V+101
      J emg.opti.core.Opti.monitorConfirmed()V
      J emg.opti.core.Opti.process()V
      J emg.opti.core.OptiCore.cycle()V
      J emg.opti.core.OptiCore$1.process()V
      J emg.controller.thread.HardRealTime$5.run()V
      v ~StubRoutines::call_stub
      V [libjvm.so+0xaef83]
      V [libjvm.so+0xaed5f]
      V [libjvm.so+0xaed3f]
      V [libjvm.so+0xbb08b]
      V [libjvm.so+0xbafc2]
      V [libjvm.so+0x3ea87c]
      V [libjvm.so+0x3e26fd]
      V [libjvm.so+0xbadd7]
      V [libjvm.so+0x387d5e]
      C [libc.so.1+0xa71d0]
      C [libc.so.1+0xa74c0]

      --------------- P R O C E S S ---------------

      Java Threads: ( => current thread )
      0x085e22a8 JavaThread "RMI TCP Connection(118)-" daemon [_thread_in_native, id=357]
      0x087a4648 JavaThread "RMI TCP Connection(117)-" daemon [_thread_in_native, id=356]
      0x08796bc0 JavaThread "RMI TCP Connection(116)-" daemon [_thread_in_native, id=355]
      0x087e2110 JavaThread "RMI TCP Connection(115)-" daemon [_thread_in_native, id=354]
      0x087914a8 JavaThread "RMI TCP Connection(114)-" daemon [_thread_in_native, id=353]
      0x0848a260 JavaThread "RMI TCP Connection(112)-" daemon [_thread_in_native, id=351]
      0x0847f460 JavaThread "RMI TCP Connection(111)-" daemon [_thread_in_native, id=350]
      0x087e7e10 JavaThread "RMI TCP Connection(110)-" daemon [_thread_in_native, id=349]
      0x0859ebb8 JavaThread "RMI RenewClean-[]" daemon [_thread_blocked, id=285]
      0x08074c28 JavaThread "DestroyJavaVM" [_thread_blocked, id=1]
      0x085b42f0 JavaThread "RMI TCP Accept-5500" daemon [_thread_in_native, id=277]
      0x085b4ad8 JavaThread "Thread-97" [_thread_blocked, id=276]
      0x085963e0 JavaThread "RealtimeThread-8" [_thread_blocked, id=275]
      0x08595788 JavaThread "Thread-76" [_thread_blocked, id=274]


      0x0822f450 JavaThread [_thread_blocked, id=18]
      0x0822ebe0 JavaThread [_thread_blocked, id=17]
      0x081cfc30 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=15]
      0x081bd0a0 JavaThread "CompilerThread0" daemon [_thread_blocked, id=14]
      0x081b75a0 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=13]
      0x081b6ae8 JavaThread "Surrogate Locker Thread (CMS)" daemon [_thread_blocked, id=12]
      0x081ad190 JavaThread "Finalizer" daemon [_thread_blocked, id=11]
      0x081ac128 JavaThread "Reference Handler" daemon [_thread_blocked, id=10]

      Other Threads:
      0x081a9598 VMThread [id=9]
      0x08075918 WatcherThread [id=16]

      VM state:not at safepoint (normal execution)

      VM Mutex/Monitor currently owned by a thread: None

      RTHeapGen total 1843200K, used 1152878K [0x45c00000, 0xb6400000, 0xb6400000)
      RT heap space 1843200K, 62% used [0x45c00000, 0xb6400000)
      rtsj-mark-sweep perm gen total 65536K, used 14553K [0xb6400000, 0xba400000, 0xba400000)
      the RTSJPermSpace RTSJPermSpace 65536K, 22% used [ 0xb6400000, 0xb6400200 0xb6400080 0xb7236580 0xb72365e0, 0xba400000]
      RTSJ gen total 67584K, used 2276K [0xba400000, 0xbe600000, 0xbe600000)
      ImmortalSpace ImmortalSpace 32768K, 6% used [ 0xba400000, 0xba400200 0xba400018 0x00000000 0xba639118, 0xbc400000]
      ImmortalPhysicalReserved 0xbc400000-0xbc500000
      ScopedPhysicalReserved 0xbc500000-0xbc600000
      ScopedFree list start:
      33554432: bytes (32768:KB) 0xbc600000-0xbe600000 in chunk 0x081646e8 (p=0x00000000 n=0x00000000 cs=2048)
      ScopedFree list end: 32768KB (plus 0 bytes)

      Dynamic libraries:
      0x08050000      /opt/SUNWrtjv/bin/java
      0xc4bb0000      /lib/libthread.so.1
      0xc4b80000      /lib/libdl.so.1
      0xc4a50000      /lib/libc.so.1
      0xc4400000      /opt/SUNWrtjv/jre/lib/i386/server/libjvm.so
      0xc4a30000      /lib/libsocket.so.1
      0xc4ba0000      /usr/lib/libsched.so.1
      0xc4a10000      /lib/libm.so.1
      0xc49e0000      /usr/lib/libCrun.so.1
      0xc49c0000      /lib/librt.so.1
      0xc43d0000      /lib/libelf.so.1
      0xc43b0000      /lib/libctf.so.1
      0xc4310000      /lib/libnsl.so.1
      0xc42f0000      /lib/libaio.so.1
      0xc42d0000      /lib/libmd.so.1
      0xc4270000      /lib/libm.so.2
      0xc4240000      /lib/libscf.so.1
      0xc4220000      /lib/libdoor.so.1
      0xc4200000      /lib/libuutil.so.1
      0xc41e0000      /lib/libgen.so.1
      0xc41c0000      /lib/libmp.so.2
      0xc41a0000      /opt/SUNWrtjv/jre/lib/i386/native_threads/libhpi.so
      0xc4130000      /usr/lib/libz.so
      0xc4110000      /opt/SUNWrtjv/jre/lib/i386/libverify.so
      0xc40e0000      /opt/SUNWrtjv/jre/lib/i386/libjava.so
      0xc40b0000      /opt/SUNWrtjv/jre/lib/i386/libzip.so
      0xc09a0000      /opt/SUNWrtjv/jre/lib/i386/librtsj.so
      0x454a0000      /opt/SUNWrtjv/jre/lib/i386/libj2pkcs11.so
      0x45470000      /usr/lib/libpkcs11.so
      0x45450000      /usr/lib/libcryptoutil.so.1
      0x45400000      /usr/lib/security/pkcs11_softtoken_extra.so
      0x453e0000      /opt/SUNWrtjv/jre/lib/i386/libnet.so
      0x45060000      /opt/SUNWrtjv/jre/lib/i386/librmi.so
      0x43620000      /prj/Hilscher_CIF/dist/Debug/Sun-Solaris-x86/libHilscher_CIF.so
      0x3fa70000      /opt/SUNWrtjv/jre/lib/i386/libawt.so
      0x3f9b0000      /opt/SUNWrtjv/jre/lib/i386/libmlib_image.so
      0x3f990000      /opt/SUNWrtjv/jre/lib/i386/headless/libmawt.so
      0x3f910000      /opt/SUNWrtjv/jre/lib/i386/libfontmanager.so
      0x3f800000      /opt/SUNWrtjv/jre/lib/i386/libnio.so
      0x3f7e0000      /usr/lib/libsendfile.so.1

      VM Arguments:
      jvm_args: -Xmx1800m -Dsun.java.launcher=SUN_STANDARD
      java_command: emg.opti.core.OptiServer c -1 -1 -1 sim
      Launcher Type: generic

      Environment Variables:

      Signal Handlers:
      SIGSEGV: [libjvm.so+0x47db78], sa_mask[0]=0xffbffeff, sa_flags=0x00000004
      SIGBUS: [libjvm.so+0x47db78], sa_mask[0]=0xffbffeff, sa_flags=0x00000004
      SIGFPE: [libjvm.so+0x133e28], sa_mask[0]=0xffbffeff, sa_flags=0x0000000c
      SIGPIPE: [libjvm.so+0x133e28], sa_mask[0]=0xffbffeff, sa_flags=0x0000000c
      SIGILL: [libjvm.so+0x133e28], sa_mask[0]=0xffbffeff, sa_flags=0x0000000c
      SIGUSR1: SIG_DFL, sa_mask[0]=0x00000000, sa_flags=0x00000000
      SIGUSR2: SIG_DFL, sa_mask[0]=0x00000000, sa_flags=0x00000000
      SIGHUP: [libjvm.so+0x388fec], sa_mask[0]=0xffbffeff, sa_flags=0x00000004
      SIGINT: [libjvm.so+0x388fec], sa_mask[0]=0xffbffeff, sa_flags=0x00000004
      SIGQUIT: [libjvm.so+0x388fec], sa_mask[0]=0xffbffeff, sa_flags=0x00000004
      SIGTERM: [libjvm.so+0x388fec], sa_mask[0]=0xffbffeff, sa_flags=0x00000004

      --------------- S Y S T E M ---------------

      OS: Solaris 10 10/09 s10x_u8wos_08a X86
      Copyright 2009 Sun Microsystems, Inc. All Rights Reserved.
      Use is subject to license terms.
      Assembled 16 September 2009

      uname:SunOS 5.10 Generic_141445-09 i86pc (T2 libthread)
      rlimit: STACK 8480k, CORE infinity, NOFILE 65536, AS infinity
      load average:0.31 0.34 0.28

      CPU:total 4 (8 cores per cpu, 2 threads per core) family 6 model 26 stepping 5, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2

      Memory: 4k page, physical 6288992k(2963416k free)

      vm_info: Java Real-Time System HotSpot(TM) Client VM (1.5.0_20-b19) for solaris-x86, built on Sep 20 2009 17:39:27 by java_re with unknown Workshop:0x590

      time: Wed Nov 3 17:16:17 2010
      elapsed time: 151 seconds


      Can you help me why I'm getting this error and what might be the solution for this situation?