5 Replies Latest reply on Nov 18, 2010 8:42 PM by 816256

    CCA and Java

      Where would be an appropriate place to ask about a specific error with the Contact Center Anywhere client? Troubleshooting isn't the most intuitive thing for a novice to this suite of applications.
        • 1. Re: CCA and Java

          We can probably help here. What's the error you are getting? Please provide OS, browser version, CCA version ,etc. it might be helpful to post the contents of your cca.log also. It can be found under your documents and settings directory (for XP) or your Users directory for Win 7.


          • 2. Re: CCA and Java
            Firstly, thanks for replying.

            OS: Win XP SP3
            Browser Version: IE7 (7.0.5730.13IC)
            CCA Version: 8.0
            URL: https://service.contactondemand.com/CCA
            2010-11-19 09:52:28,093 ERROR com.taw.cca.client.app.common.controller.ApplicationController The ccaCache Cache is not alive.
            java.lang.IllegalStateException: The ccaCache Cache is not alive.
                 at net.sf.ehcache.Cache.checkStatus(Cache.java:1311)
                 at net.sf.ehcache.Cache.get(Cache.java:729)
                 at com.taw.cca.client.framework.communication.cacheimpl.EHCacheImpl.get(EHCacheImpl.java:59)
                 at com.taw.cca.client.framework.communication.CachedDataHandler.getRegionalizationLanguages(CachedDataHandler.java:1150)
                 at com.taw.cca.client.app.login.LogoutHandler$ResetLanguagesTask.performTask(LogoutHandler.java:182)
                 at com.taw.cca.client.app.common.controller.ApplicationController.handleLogoutInternal(ApplicationController.java:435)
                 at com.taw.cca.client.app.common.controller.ApplicationController.handleLoginInternal(ApplicationController.java:330)
                 at com.taw.cca.client.app.common.controller.ApplicationController.handleLogin(ApplicationController.java:237)
                 at com.taw.cca.client.app.common.controller.ApplicationController.init(ApplicationController.java:140)
                 at com.taw.cca.client.app.common.controller.ApplicationController.<init>(ApplicationController.java:59)
                 at com.taw.cca.client.app.common.controller.SwingApplicationRunnable.run(SwingApplicationRunnable.java:33)
                 at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
                 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
                 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                 at java.lang.reflect.Method.invoke(Unknown Source)
                 at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
                 at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
                 at org.eclipse.core.launcher.WebStartMain.basicRun(WebStartMain.java:80)
                 at org.eclipse.core.launcher.Main.run(Main.java:973)
                 at org.eclipse.core.launcher.WebStartMain.main(WebStartMain.java:61)
                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                 at java.lang.reflect.Method.invoke(Unknown Source)
                 at com.sun.javaws.Launcher.executeApplication(Unknown Source)
                 at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
                 at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
                 at com.sun.javaws.Launcher.run(Unknown Source)
                 at java.lang.Thread.run(Unknown Source)

            The exact error I receive when logging in is: "ERROR: User session timed out!"

            At first, I thought this might be a timeout due to a laggy connection, but now that I have the offending workstation on a secured connection, the exact same error occurs except much faster. I've tried every usual troubleshooting procedure from clearing the cache, uninstalling/reinstalling IE7, uninstalling/reinstalling Java and so on.
            • 3. Re: CCA and Java
              Thanks for the info. How far into the login process does it get before erroring?

              I seem to recall a bug a while back where if there was a space in the company alias or username it would throw this error, but I couldn't reproduce that today.

              Have you run the ping.jsp tests yet? https://service.contactondemand.com/CCA/SCOD/ops/ping.jsp This will tell you if there is a network issue occuring.

              You might also try adding https://service.contactondemand.com to your trusted sites in IE and setting the trusted sites security level to Low. This will help if there is an IR setting causing the problem.

              If these don't provide an answer, give the COD Support organization a call at 866-853-8521.

              • 4. Re: CCA and Java
                It is also possible that your PC time is far enough off from the servers to cause an issue. Please check to make sure your PC time is set properly.

                1 person found this helpful
                • 5. Re: CCA and Java
                  Turns out you hit the nail on the head. The time/date issue is something I would have never noticed because the time was correct while the date was a day ahead. This solved the problem.