1 Reply Latest reply on Dec 20, 2010 11:11 AM by 602320

    Error Null Pointer Exception while registering Custom Interceptor

    787543
      Hi All,

      I'm getting problem registering the custom interceptor in OCSG 5.0. Code is working fine in OCSG 4.1, please let me know if I''m missing something.
      weblogic.application.ModuleException
           at com.bea.wlcp.wlng.plugin.common.PluginModule.activate(PluginModule.java:141)
           at weblogic.application.internal.flow.ModuleListenerInvoker.activate(ModuleListenerInvoker.java:227)
           at weblogic.application.internal.flow.DeploymentCallbackFlow$2.next(DeploymentCallbackFlow.java:531)
           at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:41)
           at weblogic.application.internal.flow.DeploymentCallbackFlow.activate(DeploymentCallbackFlow.java:165)
           Truncated. see log file for complete stacktrace

      Caused By: java.lang.NullPointerException
           at com.bea.wlcp.wlng.interceptor.InterceptorFlow.register(InterceptorFlow.java:31)
           at com.bea.wlcp.wlng.interceptor.InterceptorManagerImpl.register(InterceptorManagerImpl.java:40)
           at com.kt.plugins.authentication.wam.AuthenticationPluginService.doActivated(AuthenticationPluginService.java:72)
           at com.bea.wlcp.wlng.plugin.common.PluginModule.activate(PluginModule.java:135)
           at weblogic.application.internal.flow.ModuleListenerInvoker.activate(ModuleListenerInvoker.java:227)
           Truncated. see log file for complete stacktrace