6 Replies Latest reply: Dec 15, 2011 1:39 AM by user2579984 RSS

    Portal 11g install hangs on creating a domain

    263960
      Hey all, i'm trying to install Portal 11g... The install runs fine but when it gets to the configuration screen it hangs on creating a domain. The last thing in the log file is:

      *** Creating a new AdminServer Object ...
      *** AdminServer port is 7001
      *** Starting the domain ...

      After a short period of time, the runInstaller screen hangs, the process goes to 100% cpu and I have to kill it. I've left it running over night once but still no progress.. Sometimes I will see the following after the clip above in the log file:

      *** Creating a new AdminServer Object ...
      *** AdminServer port is 7001
      *** Starting the domain ...

      java.lang.OutOfMemoryError: PermGen space
      java.lang.OutOfMemoryError: PermGen space
      java.lang.OutOfMemoryError: PermGen space
      java.lang.OutOfMemoryError: PermGen space


      Any thoughts? It appears to be setting the maxPermGenSpace size to 256 as part of the install.. Any idea how to change it?

      OS is OEL 5.3 64 bit.
      Database is 11g
      OID is 11g
      SSO is 10.1.4
      Weblogic 11g tried both 32bit and 64bit.
        • 1. Re: Portal 11g install hangs on creating a domain
          480918
          Hi,
          Did you get any answer on your query. Iam also facing the same situation.
          Regards
          mathew
          • 2. Re: Portal 11g install hangs on creating a domain
            Erik Janssen
            This issue has been reported a couple of times both with installation but also while starting a managed server

            Note 953141.1 - Fusion Middleware 11g Installation Fails with java.lang.OutOfMemoryError: PermGen space

            I noticed that you tried with both the 32 and 64 bits version of WLS. In your case it is important to use the proper versions for OEL 5.3 64 bit :

            * WLS Generic (since you are on 64 bits) : http://download.oracle.com/otn/nt/middleware/11g/wls1033_dev.zip
            * PFRD for x86-64 :

            11.1.1.2 :

            http://download.oracle.com/otn/linux/middleware/11g/ofm_pfrd_linux_11.1.1.2.0_64_disk1_1of1.zip
            http://download.oracle.com/otn/linux/middleware/11g/ofm_pfrd_linux_11.1.1.2.0_64_disk2_1of1.zip
            http://download.oracle.com/otn/linux/middleware/11g/ofm_pfrd_linux_11.1.1.2.0_64_disk3_1of1.zip
            http://download.oracle.com/otn/linux/middleware/11g/ofm_pfrd_linux_11.1.1.2.0_64_disk4_1of1.zip

            11.1.1.3 :

            http://download.oracle.com/otn/linux/middleware/11g/ofm_pfrd_linux_11.1.1.3.0_64_disk1_1of1.zip

            Install it in this way :

            1. Install WLS first according to the instructions in the PFRD installation guide
            2. Install PFRD 11.1.1.2 and choose Install Only. Don't configure the software yet
            3. Install PFRD 11.1.1.3 to patch the software to 11.1.1.3
            4. Run config.sh from the PFRD ORACLE_HOME to configure your software.

            Hope this helps,
            EJ
            • 3. Re: Portal 11g install hangs on creating a domain
              793366
              Hi Erik

              I would like to know if you successfully installed patch set 2 (ofm_prfd_11.1.1.3) on top of an instance of web logic server zip distribution 10.3.3 (wls1033_dev.zip) as you suggested in your steps.

              I have been experiencing problems with patchset 2 (32 bit for 32bit win XP) being installed on wls1033_dev prompting an:
              INST-07286: Specified Oracle Middleware home location does not have version 10.3.3 of Web Logic server.

              The 11.1.1.2 ofm installation does however recognize the wls zip distribution install.

              I have read the install documentation on patchset 2 and cannot find anything solid relating to the wls zip distribution.
              The lack of material on the net and OTN relating to my problem leads me to believe that somewhere its documented that this cannot be done OR
              I am doing something incredibly wrong.

              I will keep searching.

              Thanks

              Edited by: PhilB on Dec 20, 2010 12:43 AM
              • 4. Re: Portal 11g install hangs on creating a domain
                Erik Janssen
                Yes, I have done a couple of installs with WLS 10.1.3.3 and PFRD 11.1.1.3. But my platform is Linux, not 32 bit XP. Note that XP is not a supported platform for PFRD products (see http://www.oracle.com/technetwork/middleware/downloads/fmw-11gr1certmatrix.xls) - it is only supported for the Forms and Reports Builder tools, Discoverer Desktop and other tools.

                Thanks,
                EJ
                • 5. Re: Portal 11g install hangs on creating a domain
                  793366
                  Hi Erik

                  I needs of the business are that developers need to continue developing forms and reports using 11g on there current machines (1- 2 GB of memory).
                  I have been installing forms and reports builder using note 854117.1 and and for XP machines I have been following the guidelines here
                  http://download.oracle.com/docs/cd/E12839_01/relnotes.1111/e10132/intro.htm#sthref8

                  Its a pitty that the patch cannot be used on a dev distro.
                  wls1033_dev.zip is a lot smaller and much faster to start up than wls1033_oepe111150_win32.exe

                  Thanks for the response
                  Cheers
                  • 6. Re: Portal 11g install hangs on creating a domain
                    user2579984
                    In my case (the installaion was done on windows 2008 server) there were different ip addresses
                    in C:\Windows\System32\drivers\etc\host file and actual ip address of the computer,
                    due to the fact that it was DHCP one, i.e. from time to time after shutdowns and startups different ip addresses are assigned to computer.
                    So, the general advice is: try to get a fixed ip address from admins for your installation, especially taking into account that WLS_FORMS and
                    WLS_REPORTS servers are configured with ip addresses built into them.

                    Regards,
                    Alexei.