5 Replies Latest reply: Oct 9, 2013 6:18 AM by SaiSandeepT RSS

    Issue running when Oracle Forms 10g

    user483578
      Hello Experts,

      I have installed Oracle forms 10g (Developer Suite 10g) on my machine. But when runnig the forms, it doesn’t load the form, says ‘Applet loaded’ and stops executing.. In Console it gives the following error :
      Have tried installing on a fresh copy as well but it give the same/similar issue.. Wasted lot couple of days on this now
      Using IE 8 and tried on IE 7 as well.
      I am runnng this through Forms builder
      Can anyone help me on this...

      ---------------------------------------------------------------------------------------------------------------------------------------------------------------
      Oracle JInitiator: Version 1.3.1.22
      Using JRE version 1.3.1.22-internal Java HotSpot(TM) Client VM
      User home directory = C:\Documents and Settings\Administrator
      User has overriden browser's proxy settings.
      Proxy Configuration: Manual Configuration
      Proxy: proxy.dialog.dialoggsm.com:8080
      Proxy Overrides:
      JAR cache enabled
      Location: D:\DevSuiteHome_2\forms\java
      Maximum size: unlimited
      Compression level: 0
      ----------------------------------------------------
      c: clear console window
      f: finalize objects on finalization queue
      g: garbage collect
      h: display this help message
      l: dump classloader list
      m: print memory usage
      q: hide console
      s: dump system properties
      t: dump thread list
      x: clear classloader cache
      0-5: set trace level to <n>
      ----------------------------------------------------
      Downloading http://aaa-073-114.softcom.bigsoftcom.com:8889/forms/java/frmall_jinit.jar to JAR cache
      proxyHost=null
      proxyPort=0
      connectMode=HTTP, native.
      Forms Applet version is : 10.1.2.0

      ---------------------------------------------------------------------------------------------------------------------------------------------------------------
        • 1. Re: Issue running when Oracle Forms 10g
          CraigB
          Using IE 8 and tried on IE 7 as well.
          Oracle JInitiator: Version 1.3.1.22
          Oracle Jinitiator is not compatible with IE 7/8, you have to use the Sun JRE 1.6.0._16 or higher instead. Take a look at section *2.2 Oracle Forms Applications on Client Platforms* in the Oracle Application Server 10g (10.1.2) Certification Matrix.

          After installing the Sun JRE 1.6.0, you will need to modify the %DEVSUITE_HOME%\forms\server\formsweb.cfg to set the correct JRE version information. Make the following changes:
          # System parameter: base HTML file for use with JInitiator client
          #-- Original
          #baseHTMLjinitiator=basejini.htm  
          #-- New
          baseHTMLjinitiator=basejpi.htm   
          
          #-- Original
          #jpi_download_page=http://java.sun.com/products/archive/j2se/1.4.2_06/index.html  
          #-- New
          jpi_download_page=http://www.oracle.com/technetwork/java/javase/downloads/index.html  
          
          # Parameter related to the version of the Java Plugin
          # -- Original
          #jpi_classid=clsid:CAFEEFAC-0014-0002-0006-ABCDEFFEDCBA
          # -- New (this entry specifies update 16)
          jpi_classid=clsid:CAFEEFAC-0016-0000-0016-ABCDEFFEDCBA
          # OR, you can instruct OAS to use any version of Sun JRE 1.6.0
          jpi_classid=clsid:CAFEEFAC-0016-0000-FFFF-ABCDEFFEDCBA
          
          # Parameter related to the version of the Java Plugin
          # -- Original
          #jpi_codebase=http://java.sun.com/products/plugin/autodl/jinstall-1_4_2-windows-i586.cab#Version=1,4,2,06
          # -- New
          jpi_codebase=http://java.sun.com/update/1.6.0/jinstall-6-windows-i586.cab#Version=1,6,0,22
          
          # Parameter related to the version of the Java Plugin
          # -- Original 
          #jpi_mimetype=application/x-java-applet;jpi-version=1.4.2_06
          # -- New (Specifies update 16)
          jpi_mimetype=application/x-java-applet;jpi-version=1.6.0_16
          # -- OR use any version of 1.6.0
          jpi_mimetype=application/x-java-applet;jpi-version=1.6.0
          Craig B-)

          If someone's response is helpful or correct, please mark it accordingly.
          • 2. Re: Issue running when Oracle Forms 10g
            user1039023
            oracle 10g form is not displaying properly while using IE 7 ? any help would be appriciated
            • 3. Re: Issue running when Oracle Forms 10g
              CraigB
              Welcome to the Oracle Forums. Please take a few minutes to review the following:
              <ul>
              <li>Before posting on this forum please read
              <li>10 Commandments for the OTN Forums Member
              <li>Announcement: Forums Etiquette / Reward Points
              <li>How to ask questions the smart way
              </ul>
              Following these simple guidelines will ensure you have a positive experience in any forum; not just this one! ;-) Also, it is considered poor etiquette to ask a question on someone else’s thread. Please post your question in your own thread and reference this thread if your question is related.

              When you post your own thread, please give your exact Forms version (eg; 10.1.2.0.2 not 10G), how your Forms is deployed (running local from the Forms Builder or from an Application Server), the installed Java Runtime Environment (JRE) version and list the steps you have already tried to remedy the situation.

              It is always better to give too much information than not enough!

              Craig B-)

              If someone's response is helpful or correct, please mark it accordingly.
              • 4. Re: Issue running when Oracle Forms 10g
                945612

                Hi CraigB where can find this %DEVSUITE_HOME%?

                • 5. Re: Issue running when Oracle Forms 10g
                  SaiSandeepT

                  hi,945612

                   

                  %DEVSUITE_HOME%  is nothing but, where the forms folder available in your 10g installation drive.

                   

                  ex :

                  if i am installed 10g in my 'D:' drive, then " D:\Oracle\Middleware\as_1 " is  " %DEVSUITE_HOME% ".

                   

                   

                  thank u

                  Sai