0 Replies Latest reply: Dec 26, 2010 10:08 AM by 826660 RSS

    Can not boot ubuntu 7.10 Gutsy on OpenSPARC virtex5 FPGA

      Hi, im triyng to implement the OpenSPARC T1 on a ML509 board (Virtex 5 XUPV5-LX110T FPGA) with the ubuntu 7.10 Gutsy ram disk image that come included on the OpenSPARC EDK project. I have not change anything in the proyect after download it, just synthesize the .bit file and create the .elf with the EDK 10.1 SP3 on ubuntu 9.04 OS.
      In order to create the .ACE file, i used the following script:

      xmd -tcl genace.tcl -jprog -target mdm -board xupv5 -hw download.bit -elf executable.elf -start_address 0x8ff00000 -data 1c4t_obp_prom.bin 0x8ff00000 -data ramdisk.ubuntu-7.10-gutsy.gz 0x8af00000 -ace ubuntu.ace

      the xmd report says that the .ACE file was correctly made, but when I start the ubuntu.ace on my Virtex-5, nothing happens - no USART message, no bootloader.
      At first you can see the blinking SysACE STAT-LED. When it stops blinking, normally the bootloader shows up, but in this case nothing happens.
      Searching on the web i found a Sun`s page that use another start address for the .elf, so i tried the same srcipt to created the .ACE but this time replacing the 0x8ff00000 address with 05xff00000 and 0x8af00000 with 0x5af00000. this time the boot star up, boot after the first line an error appears:

      MBFW_INFO: Uncompressing ram_disk …..
      MBFW_ERROR: mbfw_gunzip() : inflate failed -3

      (That was the whole report in the hyperterminal)

      so i tried a mix, where it says 0×8ff00000 replace with 0×5ff00000 and leave the 0×8af00000 address just like that,again an error appears, but later:

      MBFW_INFO: Uncompressing ram_disk …..
      MBFW_INFO: Uncompressed ram_disk
      MBFW_INFO: Initializing OpenSPARC T1 DRAM from 0×80100000 to 0×8AF00000
      MBFW_INFO: Initialized OpenSPARC T1 DRAM
      MBFW_INFO: XIntc interrupt controller initialized.
      MBFW_INFO: Setting Temac operating speed to 100 Mbit/sec
      MBFW_INFO: Ethernet controller initialization completed.
      MBFW_INFO: Network controller initialized.
      MBFW_INFO: Microblaze firmware initialization completed.

      MBFW_INFO: Powering on OpenSPARC T1
      MBFW_ERROR: translate_addr(): Couldn`t find T1 to Microblaze mapping for physical address 0XFFBC125CC8

      i`ve been watching some sun`s forums that all mention the 0×8ff00000 & 0×8af00000 address with exactly the same script, but i realy don`t know why it doesn`t work with that.

      does someone knowhow to fix this, or why is this happening?