This discussion is archived
4 Replies Latest reply: Jan 7, 2011 1:54 AM by 824892 RSS

Error with exported Weblogic 10gR3 Ant script - Apt task

824892 Newbie
Currently Being Moderated
I have automatically generated Ant build scripts which I have exported from Weblogic 10gR3 in order to run an automated build on a remote machine. The machine I test on is running JRockit Java 1.6.0_05 and Ant 1.8.1. The project is developed in Workshop and relies heavily on Apache Beehive and NetUI.

The script falls over when it reaches an Apt task in the generated scripts, and complains that Apt requires Java 1.5 or above. Obviously the task isn't fully compatible with Java 1.6. I have tried to convert the <apt> tags to <javac> tags, as Java 1.6 can process annotations in the compiler, effectively removing the need for a separate Apt task. However, this causes problems later on in the build as new source files that are generated by the Apt task don't get generated when using javac. I've also tried converting the project code from Java 1.6 to 1.5, but even after a full rebuild of project structure, copying of code and recompiling with a 1.5 compiler I still get errors during the build complaining about bad class file version numbers.

Is there any accepted way of either getting the Apt task to play nicely with Java 1.6 or failing that a way to remove the Apt task and still get the same code-generation-from-annotations functionality using different tasks?

Thanks
Kev

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points