This discussion is archived
2 Replies Latest reply: Jan 3, 2011 1:11 PM by 70824 RSS

Run adapters without Repository?

Mike, UK Explorer
Currently Being Moderated
Hi,
Is it possible to run Interconnect Database adapters without the Repository being 'up'? I'm working on a site at the moment, where it appears that in all the test, dev environments the adapters run alongside the repository, as I would expect. In 'Live' however, the Repository has not been started, and 2 DB adapters on either side of the architecture are running happily processing 1000's of messages per day.

There is some confusion about how this could be the case, and because of changes of staff, some knowledge missing regarding the architecture. Could anyone shed any light on this type of setup?

Thanks,

Mike
  • 1. Re: Run adapters without Repository?
    Mike, UK Explorer
    Currently Being Moderated
    Hi,
    Could anyone help with this? Basically the question is....... is there a configuration option available where DB adapters can run without the Repository? My understanding was that the Repository had to be started first, then the adapters?

    Thanks,

    Mike
  • 2. Re: Run adapters without Repository?
    70824 Explorer
    Currently Being Moderated
    Too old, but for reference: the repository is read upon start of the adapters (at least, that is the default setting). After that, the repository, that hold routing information, is no longer needed.
    You might test that scenario:
    - start Rep
    - start adapter(s)
    - stop rep.

    My guess and understanding is the adapters will continue running - these have all the data needed nicely cached.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points