This discussion is archived
1 2 Previous Next 15 Replies Latest reply: Jan 27, 2011 4:51 AM by PhHein RSS

JDK1.5 B: Error 1723 during installation

843804 Newbie
Currently Being Moderated
I'm getting a very annoying error that keeps JDK1.5 Beta from installing on my maching (W2K, SP3, msi.dll Version 2.0.2600.2). After configuring the installation starts showing the progress bar and I get this error:

Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact you support personnel or package vendor or consider switching to .NET.

(I hope I remember the last part of the last sentence right ;-)

I've downloaded the installer twice to make sure it wasn't a problem with the transmission, but it didn't help.

Another very annoying thing is that the installer refuses to install if other JDKs (I don't know whether JDK1.4.2 or JDK1.5 Alpha caused that). Anyway I need to have some different JDKs on my machine since I must test products before my clients find bugs. Please leave it to MS to make annoying so called intelligent products. It's an SDK - we do know what we want to have installed and where!
  • 1. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    Short note: msiexec.exe is also version 2.0.2600.2
  • 2. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    Hi,
    I just happen to encounter that error, One thing that caused that error is that the installation was interrupted, meaning it hasn't finished installing. You might need to re-install java again. Try to uninstall the software by going to "Add/Remove Programs" and click Remove, If that didn't work out, try clicking "change" then just modify one part of the installation by deselecting a particular module. After that, it will modify your installation. Go Back to "Add/Remove Programs" and try to remove the program again by clicking "Remove", if it uninstalled, then try to re-install the software. Hope this helps.
  • 3. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    apparently, I get this error with windows 2000 sp3. Havent been able to figure out why .. its annoying. Uninstallation also doesnt help because it throws up the same error message.
  • 4. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    I'm getting a very annoying error that keeps JDK1.5
    Beta from installing on my maching (W2K, SP3, msi.dll
    Version 2.0.2600.2). After configuring the
    installation starts showing the progress bar and I get
    this error:

    Error 1723. There is a problem with this Windows
    Installer package. A DLL required for this install to
    complete could not be run. Contact you support
    personnel or package vendor or consider switching to
    .NET.

    (I hope I remember the last part of the last sentence
    right ;-)

    I've downloaded the installer twice to make sure it
    wasn't a problem with the transmission, but it didn't
    help.

    Another very annoying thing is that the installer
    refuses to install if other JDKs (I don't know whether
    JDK1.4.2 or JDK1.5 Alpha caused that). Anyway I need
    to have some different JDKs on my machine since I must
    test products before my clients find bugs. Please
    leave it to MS to make annoying so called intelligent
    products. It's an SDK - we do know what we want to
    have installed and where!
  • 5. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    Pop! I really would like to use it. It's too annoying that this installer does nothing more for me than the JRE installer (which works) that a plain zip file couldn't do .
  • 6. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    I have tried virtually every fix described for installation Error 1722. I have been working this problem for three days. Some fixes suggested were simple, some were very complicated. But all of them failed. If you are like me, and you have Windows XP and you continue to get error 1722 and 1723 with versions 1.4.x or 1.5 beta no matter how many fixes you try, then your best bet is to download and install Java 1.3.1 I'm sure the java developer guys are going to wince when they read this, but the fastest, easiest way to work around the Error 1722 problem is to download and install JRE 1.3.1 from this download page:

    http://java.sun.com/products/archive/j2se/1.3.1_10/index.html

    Good luck.
  • 7. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated

    If you cannot successfully uninstall the jre or jdk 1.4.2/1.5.0 through the add/remove programs utility, you can use a the Windows Installer Cleanup Utility to remove them. It is located at:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;240116

    After using this tool to remove the jre or jdk, you can then reinstall and it should work fine.
  • 8. Re: JDK1.5 B: Error 1722 during installation
    843804 Newbie
    Currently Being Moderated
    I am using the 1.5 install and the error still occurs, BUT it can be cured, at least on WinXP SP2: When error comes up, go to install dir, and unset read-only, click retry to dialogue box. It will install OK. Seems that the install sets read-only, then trys to carry on installing into the locked dir. What a badly written heap of junk and a total waste of 5 hours!
  • 9. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    I was wondering if you ever found the answer to this question. I am getting the same error message, the same message when I try to remove the program and a different error message when I try to modify a piece of the program as suggested earlier. Is there any hope?
  • 10. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    Installing the 1.5.1 version previously posted was the only thing that worked for me. And it DID allow me to install over the version already installed since I couldn'd remove the program. Thanks!
  • 11. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    Actually, that is the 1.3.1 version previously suggested.
  • 12. Re: JDK1.5 B: Error 1723 during installation
    843804 Newbie
    Currently Being Moderated
    Thank you.

    Your advice to go to Control Panel then click Java then click Change and change one item worked.
    Error 1723 did not come up when I tried to uninstall.

    Now I can re-install Java 6-18 correctly.

    WillB
  • 13. Re: JDK1.5 B: Error 1723 during installation
    834725 Newbie
    Currently Being Moderated
    Managed to install Java 1.3.1 successfully with no problem. But still get the 1723 error when I try to install a newer version. Funny thing is that in Control Panel there is an entry called java but it does not work. Next to it is an entry for java 1.3.1 which does. I think that the entry that does not work is a remnant from the previous version that was deleted but not properly and this artefact could be messing up new installs....??
  • 14. Re: JDK1.5 B: Error 1723 during installation
    834725 Newbie
    Currently Being Moderated
    If you cannot successfully uninstall the jre or jdk 1.4.2/1.5.0 through the add/remove programs utility, you can use a the Windows Installer Cleanup Utility to remove them. It is located at:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;240116

    After using this tool to remove the jre or jdk, you can then reinstall and it should work fine.


    THIS DID NOT WORK for me on Windows 7.

    Edited by: user11407489 on Jan 27, 2011 4:48 AM
1 2 Previous Next