1 2 3 Previous Next 40 Replies Latest reply: May 22, 2013 7:17 AM by 862756 Go to original post RSS
      • 30. Re: Unable to start the Weblogic 10 server
        Jay SenSharma MiddlewareMagic
        Hi Chandra,

        I think you should try this approach as well...Try Changing your Administrator password or May be username as well...Just for testing...Just see wether it works or not?

        It won't affect your existing Domain, means no side effect ... the Steps are very secure...u can take backup as well...

        Please follow the Link: http://jaysensharma.wordpress.com/2009/12/15/resetting-admin-username-password/


        Note: While following the Instructions mentioned in the above link...*Please SKIP the steps* mentioned in RED color, for you it is not applicable as your Current Password itself is not working so you cannot login to AdminConsole to perform those steps....Just follow the Steps mentioned in BLACK color.


        Thanks
        Jay SenSharma
        http://jaysensharma.wordpress.com/  (WebLogic Wonders Are here)

        Edited by: Jay SenSharma on Dec 21, 2009 1:53 PM
        • 31. Re: Unable to start the Weblogic 10 server
          752248
          Hi all,

          I'm also facing the same issue.
          I need to integrate OAM and weblogic server.
          I'm using OAM10.1.4.02 and weblogic server 9.2.3 version.
          After activating NetPonitRealm i'm not able to restart weblogic server.
          I removed boot.properties file from its location and tried to give the login credentials in command prompt itself.
          But still i'm facing the same issue.

          The error message in the AdminServer log file is as follows.

          ####<Apr 28, 2010 1:27:00 PM MDT> <Notice> <WebLogicServer> <> <> <main> <> <> <> <1272482820312> <BEA-000395> <Following extensions directory contents added to the end of the classpath:
          C:\bea\weblogic92\platform\lib\p13n\p13n-schemas.jar;C:\bea\weblogic92\platform\lib\p13n\p13n_common.jar;C:\bea\weblogic92\platform\lib\p13n\p13n_system.jar;C:\bea\weblogic92\platform\lib\wlp\netuix_common.jar;C:\bea\weblogic92\platform\lib\wlp\netuix_schemas.jar;C:\bea\weblogic92\platform\lib\wlp\netuix_system.jar;C:\bea\weblogic92\platform\lib\wlp\wsrp-common.jar>
          ####<Apr 28, 2010 1:27:00 PM MDT> <Info> <WebLogicServer> <> <> <main> <> <> <> <1272482820468> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) Client VM Version 1.5.0_12-b04 from Sun Microsystems Inc.>
          ####<Apr 28, 2010 1:27:00 PM MDT> <Info> <Management> <> <> <main> <> <> <> <1272482820906> <BEA-141107> <Version: WebLogic Server 9.2 MP3 Mon Mar 10 08:28:41 EDT 2008 1096261 >
          ####<Apr 28, 2010 1:27:02 PM MDT> <Info> <Security> <> <> <main> <> <> <> <1272482822500> <BEA-090065> <Getting boot identity from user.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <WebLogicServer> <> <> <main> <> <> <> <1272482826468> <BEA-000215> <Loaded License : C:\bea\license.bea>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Notice> <WebLogicServer> <> <> <main> <> <> <> <1272482826468> <BEA-000365> <Server state changed to STARTING>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <WorkManager> <> <> <main> <> <> <> <1272482826484> <BEA-002900> <Initializing self-tuning thread pool>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <WebLogicServer> <> <> <main> <> <> <> <1272482826515> <BEA-000214> <WebLogic Server "AdminServer" version:
          WebLogic Server 9.2 MP3 Mon Mar 10 08:28:41 EDT 2008 1096261 (c) 1995, 1996, 1997, 1998 WebLogic, Inc.
          (c) 1999, 2000, 2001 BEA Systems, Inc.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Diagnostics> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826609> <BEA-320001> <The ServerDebug service initialized successfully.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Store> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826640> <BEA-280050> <Persistent store "WLS_DIAGNOSTICS" opened: directory="C:\bea\user_projects\domains\base_domain\servers\AdminServer\data\store\diagnostics" writePolicy="Disabled" blockSize=512 directIO=false driver="wlfileio2">
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002622> <The protocol "t3" is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002622> <The protocol "t3s" is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002622> <The protocol "http" is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002622> <The protocol "https" is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002622> <The protocol "iiop" is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002622> <The protocol "iiops" is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002622> <The protocol "ldap" is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002622> <The protocol "ldaps" is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002622> <The protocol "admin" is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826703> <BEA-002624> <The administration protocol is "t3s" and is now configured.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <RJVM> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826718> <BEA-000570> <Network Configuration for Channel "AdminServer"
          Listen Address          :7001
          Public Address          N/A
          Http Enabled          true
          Tunneling Enabled     false
          Outbound Enabled     false
          Admin Traffic Enabled     true>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Debug> <RJVM> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826734> <BEA-000571> <Network Configuration Detail for Channel "AdminServer"
          Channel Weight          50
          Accept Backlog          50
          Login Timeout          5000ms
          Max Message Size     10000000
          Message Timeout     60s
          Idle Timeout          65s
          Tunneling Timeout     40s
          Tunneling Ping          45s>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Server> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826765> <BEA-002609> <Channel Service initialized.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Socket> <idm> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826765> <BEA-000406> <NTSocketMuxer was built on Jan 13 2005 17:47:03
          >
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Socket> <idm> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826812> <BEA-000436> <Allocating 2 reader threads.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <Socket> <idm> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826812> <BEA-000446> <Native IO Enabled.>
          ####<Apr 28, 2010 1:27:06 PM MDT> <Info> <IIOP> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482826843> <BEA-002014> <IIOP subsystem enabled.>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Info> <Security> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482827156> <BEA-090516> <The CredentialMapper provider has preexisting LDAP data.>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Info> <NetPointSecurityProviders> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482827187> <700068> <Using properties file /C:/bea/user_projects/domains/base_domain/NetPointProvidersConfig.properties>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Info> <Security> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482827203> <BEA-090663> <The DeployableRoleMapper "com.oblix.weblogic.security.providers.roles.OblixRoleMapperProviderImpl" implements the deprecated DeployableRoleProvider interface.>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Info> <Security> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482827218> <BEA-090662> <The DeployableAuthorizer "com.oblix.weblogic.security.providers.authorization.OblixAuthorizationProviderImpl" implements the deprecated DeployableAuthorizationProvider interface.>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Info> <Security> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482827281> <BEA-090093> <No pre-WLS 8.1 Keystore providers are configured for server AdminServer for security realm NetPointRealm.>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Notice> <Security> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482827281> <BEA-090082> <Security initializing using security realm NetPointRealm.>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Info> <NetPointSecurityProviders> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482827296> <700006> <OblixLoginModule called in normal mode.>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Info> <NetPointSecurityProviders> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482827296> <700034> <Authentication failed for user weblogic. No such user.>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Critical> <Security> <idm> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1272482827296> <BEA-090403> <Authentication for user weblogic denied>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Critical> <WebLogicServer> <idm> <AdminServer> <main> <<WLS Kernel>> <> <> <1272482827312> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
          weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
               at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(CommonSecurityServiceManagerDelegateImpl.java:947)
               at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(CommonSecurityServiceManagerDelegateImpl.java:1029)
               at weblogic.security.service.SecurityServiceManager.initialize(SecurityServiceManager.java:854)
               at weblogic.security.SecurityService.start(SecurityService.java:141)
               at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
               at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
               at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)
          >
          ####<Apr 28, 2010 1:27:07 PM MDT> <Notice> <WebLogicServer> <idm> <AdminServer> <main> <<WLS Kernel>> <> <> <1272482827328> <BEA-000365> <Server state changed to FAILED>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Error> <WebLogicServer> <idm> <AdminServer> <main> <<WLS Kernel>> <> <> <1272482827328> <BEA-000383> <A critical service failed. The server will shut itself down>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Notice> <WebLogicServer> <idm> <AdminServer> <main> <<WLS Kernel>> <> <> <1272482827328> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>
          ####<Apr 28, 2010 1:27:07 PM MDT> <Info> <WebLogicServer> <idm> <AdminServer> <main> <<WLS Kernel>> <> <> <1272482827343> <BEA-000236> <Stopping execute threads.>

          Could anyone please look in to the matter and please provide the information to resolve it.

          Thanks & Regards,
          Swathi.
          • 32. Re: Unable to start the Weblogic 10 server
            472241
            Could you please post your solution on this thread please?

            Re: Unable to start the Weblogic 10 server
            Posted: Dec 15, 2009 9:07 AM in response to: user6352751          
                           Reply
            I resolved my issue. DuH!
            Thank you though
            • 33. Re: Unable to start the Weblogic 10 server
              773053
              are u starting server with nohup ?


              If yes do the following

              1)set the boot.properties in the following location

              {domain-home)/servers/<admin-server>


              create "security" folder, under this folder create boot.properties file


              boot.properties
              ---------------------

              username=<username of console>
              password=<password of console>


              Save the file

              2) start the server with the script startWeblogic.sh


              Goto {domain-home}/bin

              # ./startWeblogic.sh


              3) Now server takes the username and password from the boot.properties file
              it wont ask the username and password


              Regards
              Ravichandra
              • 34. Re: Unable to start the Weblogic 10 server
                kiranreddy
                Hi,

                What's the exact solution for this ?

                Still i'm having issue , unable to start Admin-Server..

                "boot.properties" file contains correct information

                Can someone reply with correct solution..? thanks

                Thanks
                Kiran
                • 35. Re: Unable to start the Weblogic 10 server
                  PHCharbonneau
                  Hi Kiran,

                  You can try the following steps below and let me know if its helping:

                  1) Backup the WLS Domain
                  2) Rename/Delete $DOMAIN_DIR\security\DefaultAuthenticatorInit.ldift
                  3) Run the Java command:
                  java weblogic.security.utils.AdminAccount <new-admin-user-name> <new-admin-user-pwd> <$DOMAIN_DIR\security>
                  4) Delete the contents inside the file [boot.properties] under $DOMAIN_DIR\servers\<admin-server-name>\security.
                  5) Add the folllowing contents.
                  username=<new-admin-user-name>
                  password=<new-admin-user-pwd>
                  6) Rename/delete the folder: $DOMAIN_DIR\servers\<admin-server-name>\data\ldap
                  7) Restart the WLS server

                  Regards,
                  P-H
                  http://javaeesupportpatterns.blogspot.com/
                  • 36. Re: Unable to start the Weblogic 10 server
                    kiranreddy
                    Thank you PH for the steps..

                    Actually my friend tried different way , and it got resolved , something similar to you're step (6)

                    Fix :-
                    Rename/delete the directory “ldap” under /opt/weblogic/domains/cscgateway/servers/AdminServer/data/ and
                    start the Admin server ,so Admin-Server will create the new ldap directory.

                    Anyway thanks again for you're help , appreciated!

                    -Kiran

                    Edited by: Kiran Reddy T on Feb 9, 2011 8:15 PM
                    • 37. Re: Unable to start the Weblogic 10 server
                      793456
                      If you have copied the boot.properties file from other domain. It will not workout.
                      Create a boot.properties file and try to execute the startWeblogic.sh for two times though you get the error,
                      then it will encrypt automatically. Then hope it will get started.
                      • 38. Re: Unable to start the Weblogic 10 server
                        user741095
                        Hello All,
                        I did two installations on 2 different boxes and ran into the same issue . The best way to resolve this issue is as follows, please note this is required only the first time,

                        1. Start the node manager manually without using nohup. That console window will be locked. Leave it and start a second console window.
                        2. Start the Admin Server, again without using nohup or boot.properties file
                        3. Now start the Managed Server using the following command
                        startManagedWebLogic.sh "my_managed_server" "http://<administration_server_host_name>:7001"

                        This will prompt you for the weblogic userid and password. Enter the same and your managed server will be started.

                        Once started, you can control C to stop the managed server. In the other window do control-C and stop the Admin Server and Node Manager. You can now create the boot.properties file in the security directory under each server directory and start the AdminServer and Managed Server using nohup.

                        Hope this helps

                        Best Regards,
                        Abhimanyu
                        • 39. Re: Unable to start the Weblogic 10 server
                          997468
                          Hi,

                          If you have forgotten your admin password then follow below steps,

                          1. Execute setWLSEnv.sh and setDomainEnv.sh
                          2. Take a backup of $WLS_HOME/security directory.
                          3. Move to security directory and execute below to set a new password. Basically below command will write new DefaultAuthenticatorInit.ldift file.
                          *$ java weblogic.security.utils.AdminAccount weblogic newPassword .*
                          4. Rename *$WL_HOME/servers/<admin server>/data* to something like data_bkp_`date`. This will help during server start as weblogic will go and write new data directory with new security configurations.
                          5. Rename *$WL_HOME/servers/<admin server>/security/boot.properties* to something like boot.properties_bkp_`date`
                          Note: If you were not having boot.properties file created earlier, create it now with below syntax.

                          username=user
                          password=password

                          example,

                          username=weblogic
                          password=weblogic

                          6. Perform server startup using ./startWeblogic.sh

                          This has worked for me earlier...!

                          Thanks,
                          Ranjan
                          http://middlewaresupport.wordpress.com
                          • 40. Re: Unable to start the Weblogic 10 server
                            862756
                            the password should contain min of 8 chars That might causing the issue
                            1 2 3 Previous Next