3 Replies Latest reply: Feb 10, 2011 12:06 PM by VitorMARodrigues RSS

    invoke snmpv1trap

    VitorMARodrigues
      Hi,

      I´m runnig weblogic8.1 and trying to invoke the snmpv1trap as described in the oracle documentation (after setting the environment setWLSEnv.sh).
      After invoking the command "java snmpv1trap " the following error occurs:

      Exception in thread "main" java.lang.NoClassDefFoundError: snmpv1trap
      at gnu.gcj.runtime.FirstThread.run() (/usr/lib/libgcj.so.5.0.0)
      at JvThreadRun(java.lang.Thread) (/usr/lib/libgcj.so.5.0.0)
      at JvRunMain(java.lang.Class, byte const, int, byte const, boolean) (/usr/lib/libgcj.so.5.0.0)
      at __gcj_personality_v0 (/opt/tools/bea/weblogic_815/weblogic81/common/bin/java.version=1.4.2)
      at __libc_start_main (/lib/tls/libc-2.3.4.so)
      at JvRegisterClasses (/opt/tools/bea/weblogic_815/weblogic81/common/bin/java.version=1.4.2)

      How can i fix this?

      Any help appreciated
        • 1. Re: invoke snmpv1trap
          Faisal Khan
          It worked fine for me!

          C:\bea816\weblogic81\server\bin>setWLSEnv.cmd

          CLASSPATH=C:\bea816\JROCKI~1\lib\tools.jar;C:\bea816\WEBLOG~1\server\lib\weblogi
          c_sp.jar;C:\bea816\WEBLOG~1\server\lib\weblogic.jar;C:\bea816\JROCKI~1\lib\tools
          .jar;C:\bea816\WEBLOG~1\server\lib\weblogic_sp.jar;C:\bea816\WEBLOG~1\server\lib
          \weblogic.jar;

          PATH=C:\bea816\WEBLOG~1\server\bin;C:\bea816\JROCKI~1\jre\bin;C:\bea816\JROCKI~1
          \bin;C:\bea816\WEBLOG~1\server\bin;C:\bea816\JROCKI~1\jre\bin;C:\bea816\JROCKI~1
          \bin;E:\app\khanf\product\11.2.0\dbhome_1\bin;G:\app\khanf\product\11.2.0\dbhome
          _1\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System
          32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Com
          mon Files\Intel\WirelessCommon\;C:\Program Files\ThinkPad\Bluetooth Software\;C:
          \Program Files\Lenovo\Access Connections\;C:\bea103\jdk160_05\bin;C:\bea816\WEBL
          OG~1\server\bin\oci920_8;C:\bea816\WEBLOG~1\server\bin\oci920_8

          Your environment has been set.
          C:\bea816\weblogic81\server\bin>java snmpv1trap
          Usage: snmpv1trap [-d] [-c community] [-p port] host enterprise agent-addr gener
          ic-trap specific-trap timeticks [OID {INTEGER | STRING | GAUGE | TIMETICKS | OPA
          QUE | IPADDRESS | COUNTER} value] ...
          • 2. Re: invoke snmpv1trap
            VitorMARodrigues
            hi,

            in fact it appears an environment set message but i can´t run the command. so weird
            • 3. Re: invoke snmpv1trap
              VitorMARodrigues
              Got it.

              I was setting the environment invoking . setWLSEnv.sh in unix.
              I needed to delete the dot.

              After all i wasn´t following the documentation ;)

              Thanks