1 2 Previous Next 18 Replies Latest reply on Jan 12, 2012 12:07 PM by user11329799

    Getting errors when creating Virtual Box VM

      I've followed the instructions at this link:


      They're pretty simple-- download and install VirtualBox, then download 3 files. 2 of them are large, so I knit them together using a copy command.

      When I try to import the appliance in the file 'Oracle Developer Days.ovf', it runs for a while, then fails with:

      'Failed to import appliance C:\Documents and Settings\grstep\My Documents\VirtualBox VMs\Oracle Developer Days.ovf'
      Storage for the medium 'C:\Documents and Settings\grstep\My Documents\VirtualBox VMs\OTN_DD_ROOT.vmdk' is not created.

      Details contains this information when I expand it:

      Result Code: VBOX_E_INVALID_OBJECT_STATE (0x80BB0007)
      Component: Medium
      Interface: IMedium {9edda847-1279-4b0a-9af7-9d66251ccc18}

      The VirtualBox install seems to be OK, because I can load another appliance in it successfully.

      Thanks in advance for any help!

        • 1. Re: Getting errors when creating Virtual Box VM
          I have this exact same problem. Does anyone have any insight on what is wrong?
          • 2. Re: Getting errors when creating Virtual Box VM
            You mention 3 files, but you have to download 4 files (3 big and 1 small). Like me you certainly forgot to download file OTN_DD_ROOT.vmdk (step 2).
            • 3. Re: Getting errors when creating Virtual Box VM
              So, I have some more background on this extremely interesting issue.

              The destination directories for the virtual disks are specified as:

              C:\Documents and Settings\grstep\VirtualBox VMs\Oracle Developer Days

              I carefully created these directories. When VirtualBox fails with the message from my first post ... it removes the directory "Oracle Developer Days"!

              In response to the poster who suggested that i missed a file - I actually do have that one (I have the .ovf, OTN_DD_ORACLE.vmdk, and OTN_DD_ROOT.vmdk.


              • 4. Re: Getting errors when creating Virtual Box VM
                So, I was looking at the text of the .ovf file. (Is that allowed?) And I found:

                <Info>List of the virtual disks used in the package</Info>
                <Disk ovf:capacity="12884901888" ovf:diskId="vmdisk1" ovf:fileRef="file1" ovf:format="http://www.vmware.com/specifications/vmdk.html#sparse"/>
                <Disk ovf:capacity="12884901888" ovf:diskId="vmdisk2" ovf:fileRef="file2" ovf:format="http://www.vmware.com/specifications/vmdk.html#sparse"/>

                Am I missing something? It looks like the ovf:format parameter is going to vmware.com and pulling the format from there! And sure enough ... when I try that URL ... I get a "Page Not Found".

                I will dig into the working .ovf tomorrow and see whether I can fix this.

                • 5. Re: Getting errors when creating Virtual Box VM
                  Rob van Wijk
                  Exact same issue here.
                  • 6. Re: Getting errors when creating Virtual Box VM
                    Ok, so I'm going to update with what I have tried so far. I'm still getting the exact same errors.

                    I've compared the .ovf that is working (it's for Sage 4.3, not that it matters) to the .ovf provided with the Oracle package. The Sage .ovf contains several values like:


                    etc. They seem to be pulling their information over the internet, which I think is screwy, but it is working for the Sage .ovf so I assume this is not the problem with the .ovf from Oracle.

                    The file sizes specified by the File entries in the References section were wrong. I fixed those.

                    I fiddled with some of the syntax-- it looked like Oracle was using a newer version of the DTD than Sage, so I manually downgraded the syntax.

                    I modified the Network section to match that in the Sage .ovf

                    Next, I lowered the version of the "Envelope" that Oracle was calling out, by changing
                    <Envelope ovf:version="1.0" xml:lang="en-US" to <Envelope ovf:version="0.9" xml:lang="en-US"

                    All of these efforts were rewarded with the exact same error message I reported in my first post.

                    I found a whitepaper from vmware () that had this to say:

                    "If an OVF package is installed on a platform that does not offer the same hardware devices and/or categories of devices
                    that are required by the guest OS that is included in the appliance, non-trivial and non-obvious installation failures can
                    occur. The risk is not that the appliance will run incorrectly – more that it will fail to install and boot, and that the user
                    will not be able to debug the problem."

                    The gist of this section of the paper was to make the .ovf as generic as possible and to avoid specifying any hardware that wasn't necessary, and to ensure that the "virtual hardware specification is virtualization platform specific".

                    I'll keep looking -- there is almost nothing about this specific error, and I've already tried de-installing VirtualBox and re-installing it in a new directory.

                    Still waiting for someone to take this bull by the horns. :-)

                    • 7. Re: Getting errors when creating Virtual Box VM
                      So, the OTN_DD_ROOT.vmdk file was corrupted. (I actually typed something about changing the file size in the .ovf ... realized later that it could mean a problem with the file). So I downloaded the file again, the size checked out, and now my VM is happily running.
                      • 8. Re: Getting errors when creating Virtual Box VM
                        Rob van Wijk
                        Thanks Gary.

                        My OTN_DD_ROOT.vmdk was corrupted as well. And after a new download it works!

                        • 9. Re: Getting errors when creating Virtual Box VM
                          Toon Koppelaars
                          I had the same error, but was able to fix it by adjusting the filesizes mentioned in the ofv file: they didn't correspond with the actual filesizes.
                          • 10. Re: Getting errors when creating Virtual Box VM

                            Edited by: ora_aspirant on Feb 12, 2011 9:03 AM
                            • 11. Re: Getting errors when creating Virtual Box VM
                              Same problem here, the url are not available
                              could not figure out what changes need to be done. someone please give details.
                              • 12. Re: Getting errors when creating Virtual Box VM
                                i had the same problem.... when i tried to reassemble these two files, it was successful, but resulting file had only 1KB... (and those two has about 4GB and 1GB respectively)... so i tried it again and this time it had about 5GB... and then... it worked :)

                                p.s.: of course, i had to change disk size in .ovf file... thanks, Toon Koppelaars...


                                Edited by: 841340 on Mar 3, 2011 12:08 AM

                                Edited by: 841340 on Mar 3, 2011 12:09 AM
                                • 13. Re: Getting errors when creating Virtual Box VM
                                  I've wasted far too much time on trying to make this work. This is not a good advertisement for Oracle at all, which is a pity because in principle it is an excellent idea.
                                  • 14. Re: Getting errors when creating Virtual Box VM
                                    I too got the ...Invalid..box.. error. The cause of my problem as hinted in an earlier post was that the files were not merging correctly using "copy".

                                    Unfortunately, it is not clearly spelled out but you need to do a binary copy of the files to merge them into one. So, for the completely uninitiated, as follows:-
                                    1. open a DOS prompt (Start>Run>cmd)
                                    2. navigate to the folder where the files are stored using the CD (change directory) command eg. >cd C:\Temp
                                    3. to merge the 2 files into one, at the prompt > copy /B OTN_DD_ORACLE.vmdk.001+OTN_DD_ORACLE.vmdk.002 OTN_DD_ORACLE.vmdk
                                    This may take a while so be patient as they're big files but you'll be left with one file named "OTN_DD_ORACLE.vmdk". Time to retry the import.
                                    Hope that helps someone!
                                    Good luck.
                                    1 2 Previous Next