7 Replies Latest reply on Mar 12, 2011 9:35 PM by SlavaZayarny

    Cannot open dva console for database vault


      I'm running a Linux SLES10 server with EE databases on it.
      I also have a grid control environment (on windows).

      Now I created a demo database DBADVA with Database Vault enabled. During the dbca I entered the vault owner (DBV_OWN) and account manager (DBVACCTMGR) with their passwords.
      The users are created and open.

      The database is managed with the Grid Control, and NOT with the Database Control.

      When I try to open: https://hostname:1159/dva I get a "Firefox cannot connect to server on <hostname>:1159" message. (both 1158 and 1159)

      Following some instructions in the Oracle docs, I check $ORACLE_HOME/sysman/config/emd.properties to find the port number.
      Here I see:
      So no specific port is being supplied.

      I'm stuck here. How to open the dva?

      Moreover, the database is 'secure' it seems:

      SYS@DBADVA AS SYSDBA> create user JOHN identified by JOHN;
      create user JOHN identified by JOHN
      ERROR at line 1:
      ORA-01031: insufficient privileges

      So it seems Data Vault is active.

      Edited by: PaulAlsemgeest on Apr 22, 2010 11:07 AM
        • 1. Re: Cannot open dva console for database vault
          *1st Option*

          1.Start Database Control.
          For example:

          2. In the Home page, click Server to display the Server subpage.
          3. Under Security, select Database Vault.
          The Oracle Database Vault login page appears.
          4. Enter the following information:

          __*2nd option__
          if the above page also not appearing just write the IP address instead of hostname to access the page

          • 2. Re: Cannot open dva console for database vault
            1.st option does NOT work, I have grid control, and no database control.
            There is no datavault option under Server-Security on grid control.

            2.nd option does NOT work.
            The ip-based url to db control or dva does not work either.

            So.... any suggestions?
            • 3. Re: Cannot open dva console for database vault
              Did you register Oracle Database Vault with your database?
              if no then 1st register it with your database,

              and 2nd if your Grid control don't have server security that mean you don't have register database vault with your database yet so do it first then you are able to use it.

              and to register it you can follow these steps.
              1. Start Database Configuration Assistant.
              2. In the Welcome page, click Next.
              3. Select Configure Database Options, and then click Next.
              The Database page appears.
              4. Select Oracle Database Vault (and Oracle Label Security if it is not already
              installed), and then click Next.
              5. Specify the name and password for the Database Vault Owner account and DVACCTMGR
              6. Click Next.
              The Connection Mode page appears.
              7. Select either Dedicated Server Mode or Shared Server Mode (depending on the selection you made when you created this database), click Finish, and then click
              OK in the confirmation prompts.
              Database Configuration Assistant registers Oracle Database Vault, and then restarts the database instance.
              8. Exit Database Configuration Assistant.
              • 4. Re: Cannot open dva console for database vault
                Pat Huey-Oracle
                Hi Paul,

                If the Audit Vault installation was successful, it should have enabled DV and made DVA available to you. You can check to see if DV is enabled by logging in to AV database and entering the following command:

                SQL> SELECT * FROM V$OPTION WHERE PARAMETER = 'Oracle Database Vault';

                Remember that 'Oracle Database Vault' here is case-sensitive.

                But sometimes the DVA gods frown on us and we are forced to manually deploy it. You can find the instructions in the DV Admin Guide, in the section entitled "Manually Deploying Oracle Database Vault Administrator" in Ap. C:


                (This is the 11.2 version of the DV Admin Guide, but these steps should work for the version in Audit Vault.)

                I hope this helps,

                Edited by: user462144 on Apr 29, 2010 10:49 AM
                • 5. Re: Cannot open dva console for database vault

                  Did you get an answer on this. I am having your exact problem.
                  • 6. Re: Cannot open dva console for database vault
                    I didn't work on this issue anymore and it is not solved. Maybe I'll try it later.
                    • 7. Re: Cannot open dva console for database vault
                      If anyone is still pursuing solution to this issue, it IS possible to run DVA GUI on a target/host managed by Grid Control and not Database Control. Follow these instructions for "Deploying Database Vault Administrator to a Standalone OC4J Container" at this link:


                      Oracle® Database Vault Administrator's Guide 11g Release 2 (11.2), Appendix C.

                      Note that default URL with this approach will use port 8888, e.g. http://host.host.com:8888/dva

                      In my case of deploying it in a RedHat 5.1 64-bit Linux RAC environment it worked, albeit after having had to modify existing port 8888 and 23943 designations due to conflicts. While DVA GUI appears to work and should suffice for a development environment, I would still prefer scripts based on the DVSYS package APIs to manage and report in production. Hopefully, there will be better integration with Grid Control in the near future.

                      - Slava Zayarny

                      Edited by: SlavaZayarny on Mar 12, 2011 1:34 PM