5 Replies Latest reply on Jul 5, 2011 7:19 PM by gdarling - oracle

    OraOLEDB.Oracle provider is not registered

      I'm doing some local testing on a Windows 7 64-bit PC. I'm running Oracle 11g 64-bit locally. I'm trying to set up a connection to the Oracle database from a local ASP.NET application. When trying to make a connection to the database I get the error “The 'OraOLEDB.Oracle' provider is not registered on the local machine” (the application is blowing up at the line connection.Open() where I'm trying to connect using a connection string).

      I added IIS_IUSRS to the Oracle Home directory and granted read, write, and execute permissions. I also successfully registered the OraOLEDB11.dll file through the command line. Those are a couple of fixes that I've found so far but my problem still persists.

      I can connect to the Oracle database through SQL PLUS as well as SQL Developer. I've tried rebooting after making the changes that I've made so far. I've tried stopping and starting the database instance as well.

      Does anybody else have any other ideas that I can try?

      Thanks for any help!
        • 1. Re: OraOLEDB.Oracle provider is not registered
          I was facing the same problem ... I'm using Windows 7 64-bit and Oracle 11g client 64-bit and VS 2010. I changed the soliution platform to 32-bit in VS 2010 to make it work!!
          • 2. Re: OraOLEDB.Oracle provider is not registered
            I am in the same situation.My testing environment is .net framework2.0 web application and oracle10.2.0.4 64 bit on Windows Server 2008 R2 64 bit. I'm trying to figure it out and doing the same method like you, but the problem still exists.

            Do you find any solution for the problem?
            • 3. Re: OraOLEDB.Oracle provider is not registered
              gdarling - oracle
              The usual cause is that you have the wrong bits (32/64) of Oracle client software installed.

              Did you install 32 bit or 64 bit Oracle client software?

              Is you web app running as 32 bit or 64 bit? Open Task Manager, click the process tab, is there a *32 next to the name? If so, its 32 bit.

              IIS runs as 64 bit on a 64 bit box, the development webserver that comes with VS is 32 bit even on a 64 bit box.

              Hope it helps,
              • 4. Re: OraOLEDB.Oracle provider is not registered
                Thanks for your reply.
                I'm sure that the version of Oracle is 64bit.
                My web app version is 32 bit,so I execute "cscript C:\inetpub\adminscripts\adsutil.vbs SET w3svc/AppPools/Enable32bitAppOnWin64 1" to make it running as 32 bit.
                I have installed the "10204_vista_w2k8_x64_production_client.zip", "ODAC10203x64.zip", "ODAC112021Xcopy_x64.zip", "WinIA64_10205_client.zip" separately on same separate environment(Windows Server 2008 R2 64bit, Oracle 10g
                Some of them I have installed successfully, but there is not Ole Db Provider in Data Source Manager(ODBC).
                Some of them I have installing appearing something wrong.

                I just want to make my 32 bit web application which can connect to the Oracle 10g 64 bit on Windows Server 2008 R2 64bit.

                I feel a little hopeless now, but I'm still trying.
                • 5. Re: OraOLEDB.Oracle provider is not registered
                  gdarling - oracle

                  Supported versions on Win7 are 10205, 11201, and 11202.

                  To run a 32 bit app, you need 32 bit Oracle client software.

                  What I'd recommend is
                  a) remove everything you have installed at this point, as even if you get things working you have a big mess of an install
                  b) install ODAC (32 bit) which will give you the 32 bit oledb provider.

                  ODAC 11.2 Release 3 ( -      ODAC112021.zip

                  Note that you'll never seen an OLEDB provider in the ODBC administrator though.. you'll only see ODBC drivers.

                  Hope it helps,