3 Replies Latest reply on Apr 26, 2011 11:48 PM by Lokesh Rathi

    Partial Mapping Question

      I have a scenario wherein I have a loaded measure, however RS data for it comes at 4 dimensions only wherein there are 5 dimensions in cube so I opted for partial map. However UI gives me validation error message saying that partial mapping can not be used for loaded measures & should be used in case of derived measures. What could be a possible solution for this in order to load data.

      Anyway in XML i made a partial map i.e mapped only 4 dimensions (without setting partialMap="true") and published model. Model published without any error and there are no rs-Cube rejections still I do not see loaded value in scenario for 4 dimension intersections though data is there in RS. Strange thing is that there are no error files for record rejections. Any pointers in this regard. Should I opt for a derived measure like below instead of loaded measure.

        • 1. Re: Partial Mapping Question
          Regarding your query mentioned below, how to map a rowsource data for 4 dimensions only wherein there are 5 dimensions in cube. This can be achieved from the cube.xml file. You would first need to export out the cube definition.xml file and add the RowSourceMapping for all the 5 dimension.
          Over here, you can map the dimension to the membercolumn and namespace.
          Incase where there are no membercolum mapping, it can be mapped to the dimension itself.
          After doing this you need to import the cube back again and publish it. All this would need to be achieved using the isadmin commands.
          • 2. Re: Partial Mapping Question
            Partially mapped measures should always be used in a formula. I think IOP generates a warning if I recall. The reason being IOP cannot and doesnt want to load in all the wild card members for the missing dimension.

            Partially mapped RS are expensive.

            Your other choices are to load at a fixed (say root) member in the missing dimension and then do a rolldown.

            You can also think of using "lookup" function.
            • 3. Re: Partial Mapping Question
              Lokesh Rathi

              I have a similar issue. I also tried to map one RS with the cube which is having 3 dimensions A- Bom B- Supplier C- Calendar .

              The RS is mapped to Cube with B & C and we are giving Wild flag for A (Though its expensive).

              Correct me if my understanding is right : When we create Application RS ...The data that is getting loaded in RS is for the combination of B & C , it is taking only one combination of B & C for one row. Though we wanted to bring all the other values for same combination for our lookup reference in measures , IOP RS is rejecting all other data with the same combination mentioning as "Duplicate Record" .
              I used RS indices also but that also didn't work for us.

              To get complete data we created custom RS and it worked fine (We got all data in RS) but then we lost the ability to update the Inline reports based on it in IOP.

              Please Suggest if this can be handled some other way.