3 Replies Latest reply on Jun 20, 2013 5:11 PM by HPSHAH_2047

    Error while installing UPK

      I am installing UPK client developer license (admin) for a multi user environment and getting the following error: An unexpected error occured while installing Microsoft XML Core Services (MSXML) 4.0. The installation will now be cancelled. Return Code: 1603
      Has anybody come across this error while installing UPK? What is required to rectify this and continue with the installation process?
        • 1. Re: Error while installing UPK
          Marc Santosusso

          It sounds like one of two things:

          1. The installation files were not completely extracted or were not extracted to the proper folders. Solution: Extract the files from the .ZIP again to a new folder and ensure there is a folder structure (not just a single folder.)
          2. The installation was not run as an administrator on the machine. Solution: Run the setup.exe as an admin.

          If you continue to experience problems, please enter a ticket with Support: http://support.oracle.com/

          Best regards,
          • 2. Re: Error while installing UPK
            Try uninstalling any existing MSXML files from control panel. This worked for me.
            • 3. Re: Error while installing UPK

              I just solved this error . It was pretty hard to solve.


              I did uninstall the MSXML , but it did not help. The problem was , there is a installer for MSXML in third party folder and they all are run silently and this installer for MSXML was failing.


              C:\Data\p13257712_361_WINNT\UPK_v3.6.1\third party files


              Microsoft WSE 3.0 Runtime.msi


              This installer was looking for F:\ drive, on my computer. There is no F:\ drive and it failed, but untill I ran this msi , manually , i could not figure out the issue


              Once I created a Fake F:\ drive, installed this installer manually and then re-ran the UPK 3.6.1 installer , it all worked out fine.


              So my take, is that the this Microsoft WSE 3.0 Runtime.msi, installer is looking for F:\ drive which is missing and that is the root cause of this error message.