1 Reply Latest reply: May 13, 2011 5:46 AM by 650738 RSS

    TSAM manager 11G not connecting to TSAM agent 1.1

    840277
      Hi

      I am having the following setup TUXEDO version 10 rel zero with TSAM 1.1 32 bit AIX connecting to
      TSAM Master 11G on Windows 2008 , I have setup the LMS server on the UBBCONFIG

      LMS SRVGRP=TSAMGROUP SRVID=1 MINDISPATCHTHREADS=1 MAXDISPATCHTHREADS=5
      CLOPT="-A -- -l hqstivoli01:8080/tsam/dataserver"


      and also exported the TMMONITOR=app,svc,sys,tran:: ,


      tail -f ULOG.051111 | grep TMMONITOR

      165224.hqsaixTRNAP!Z2212V.66781328.1.0: LIBTUX_CAT:6617: INFO:TMMONITOR (app,svc,sys,tran::) was parsed successfully


      Now the TSAM console shows the domain as red with no data even though LMS has processed many transactions ,

      while restarting the TSAM manager , I got the following DERBY database error ;

      2011-05-13 09:26:09.226 GMT : could not listen on port 1527 on host localhost : java.net.BindException : Address already in Use : JVM_Bind


      Any idea on why TSAM is showing no data ,

      Thank you
      Praveen
        • 1. Re: TSAM manager 11G not connecting to TSAM agent 1.1
          650738
          Praveen,

          You configuration format is correct for TSAM 1.1 agent. Do you find any relevant error messages in ULOG? There should be some error messages if LMS fails to connect TSAM manager.

          You don't need to restart TSAM manager when you configure a new Tuxedo domain. I don't know if you also stop Derby database when you shutdown you TSAM manager, by default 1527 port is used by Derby.

          Regards,
          Yu Wang