11 Replies Latest reply: Sep 27, 2013 12:08 PM by Mpalski RSS

    Error uploading page template from JDeveloper to WebCenter Spaces

    786367
      Version : PS3 , JDeveloper 11.1.1.4

      I am following Chapter 49 of the Oracle Fusion Middleware Developer Guide for WebCenter (PS3) to create custom resources for WebCenter Spaces.
      I opened the DesignWebCenterSpaces.jws workspace in JDeveloper (Default Mode) and then made simple text modification to Template.jspx (a page template). I then tried "Upload Portal Resource" option and got the foll error in the log file:

      ===================
      Upload resource..
      Connecting to t3://localhost:7001 with userid weblogic ...
      Successfully connected to Admin Server 'AdminServer' that belongs to domain 'webcenter_domain'.

      Warning: An insecure protocol was used to connect to the server. To ensure on-the-wire security, the SSL port or Admin port should be used instead.

      Problem invoking WLST - Traceback (innermost last):
      File "C:\Documents and Settings\sac.kam\Application Data\JDeveloper\system11.1.1.4.37.59.23\o.webcenter.portal.11.1.1.4.0.110201.0\ResourceUpload.py", line 27, in ?
      NameError: importWebCenterResource

      ========================

      Below are the config.properties file content :

      jdeveloper.install.home.directory=C:\\Oracle\\Middleware\\jdeveloper
      wlst.executable=wlst.cmd
      extending.spaces.home.dir=C:\\JDeveloper\\mywork\\DesignWebCenterSpaces
      wls.port=7001
      wls.host=localhost
      wls.target=WC_Spaces
      wls.webcenter.app.target=WC_Spaces
      webcenter.app.name=webcenter
      wlst.executable=wlst.cmd
      extending.spaces.home.dir=C:\\JDeveloper\\mywork\\DesignWebCenterSpaces
      oracle.jdeveloper.ojdeploy.path=${jdeveloper.install.home.directory}\\jdeveloper\\jdev\\bin\\ojdeploy.exe
      wls.port=7001
      wls.host=localhost
      wls.userkey=C:\\JDeveloper\\mywork\\myuserkeyfile.secure
      wls.userconfig=C:\\JDeveloper\\mywork\\myuserconfigfile.secure
      wls.target=AdminServer,WC_Spaces
      wls.webcenter.app.target=WC_Spaces
      webcenter.app.name=webcenter
      restart.implementation.version.suffix=1


      Please can I get help on triaging the issue/error?