0 Replies Latest reply: May 19, 2011 12:44 AM by 825936 RSS

    instaclient for deploying a .NET application


      I donot know if my query is eligible for this forum; I could not find a more suitable forum though. Kindly excuse if this is not so.

      I'm deploying a .NET application on Windows XP-SP2 clients(Database: Oracle 10g). For Oracle connectivity, I've bundled the exe with instaclient.

      It has been installed it on about 15 computers so far and the app. is working fine.

      However, on a few other computers, it gave an error as:
      "System.Data.OracleClient requires Oracle client s/w version 8.1.7 or greater."

      I used the latest instaclient package avl. on oracle website( version: and it worked on 2 computers. For the other computers, the Error persists.

      To resolve this error, I tried all instaclient packages avl. on the instaclient website. The same error persists.
      (While testing, I'm setting the the environmental variables: TNS_ADMIN and PATH to the instaclient folder.)

      Could the problem be with the client computes? or is it something more that must be done after instaclient installation?
      How do I resolve this error? Will the latest instaclient version: suffice for all client computers and Oracle DBs? Are there any dependencies that must be taken care of?


      Edited by: joy on 18-May-2011 22:44