1 2 Previous Next 16 Replies Latest reply: Oct 28, 2008 7:40 PM by 667566 RSS

    emca: Failed to allocate port(s) in the specified range...

    438531
      Hi,

      this is Suse Professional 9.2 and Oracle 10.1.0.3.

      When we try to start emca to configure the enterprise manager manually, we get the error message:

      SEVERE: Failed to allocate port(s) in the specified range for the following process(es): JMS [5540-5559],RMI [5520-5539],Database Control [5500-5519],EM agent [1830-1849]

      But those ports are not in use...

      Anyone experienced the same thing?

      ./emca

      STARTED EMCA um Thu Mar 17 14:34:24 CET 2005
      Geben Sie die folgenden Informationen für die zu konfigurierende Datenbank ein
      Listener-Port-Nummer: 1521
      Datenbank-SID: fhoracle
      Service-Name: fhoracle
      E-Mail-Adresse für Benachrichtigung: ff
      E-Mail-Gateway für Benachrichtigung: ff
      Kennwort für dbsnmp:
      Kennwort für sysman:
      Kennwort für sys: :

      -----------------------------------------------------------------

      Sie haben die folgenden Einstellungen angegeben

      ORACLE_HOME von Datenbank ................ /home/fhserver/product/10.1.0/Db_2
      ORACLE_HOME von Enterprise Manager ................ /home/fhserver/product/10.1.0/Db_2

      Host-Name von Datenbank ................ linux.site
      Listener-Port-Nummer ................ 1521
      Datenbank-SID ................ fhoracle
      Service-Name ................ fhoracle
      E-Mail-Adresse für Benachrichtigung ............... ff
      E-Mail-Gateway für Benachrichtigung ............... ff

      -----------------------------------------------------------------
      Möchten Sie fortfahren? [ja/nein]: ja
      17.03.2005 14:34:50 oracle.sysman.emcp.EMConfig checkParameters
      SCHWERWIEGEND: Failed to allocate port(s) in the specified range for the following process(es): JMS [5540-5559],RMI [5520-5539],Database Control [5500-5519],EM agent [1830-1849]
      Die Konfiguration konnte nicht abgeschlossen werden. Weitere Einzelheiten finden Sie in der Log-Datei

      Thanks,
      Helmut
        • 1. Re: emca: Failed to allocate port(s) in the specified range...
          Ivan Kartik
          Helmut,

          check the /etc/sysctl.conf file and check if contains following line:
          net.ipv4.ip_local_port_range = 1024 65000

          If not, then add that line save the file and reboot the system.
          Also check the wheter some service is not running on required ports that was mentioned in the error messages.
          You can check this issuing the "netstat -an | grep tcp | grep LISTEN" command.
          • 2. Re: emca: Failed to allocate port(s) in the specified range...
            28738
            I have done this and I still get the same error after rebooting the machine? Also, any idea where the log file is for the ./emca is located?
            • 3. Re: emca: Failed to allocate port(s) in the specified range...
              Ivan Kartik
              problem si with ports listed in /etc/services file.
              So login as root, and modify this file and delete relevant entries.
              • 4. Re: emca: Failed to allocate port(s) in the specified range...
                443264
                Im trying to install Oracle Application Server 10g, when trying to configure assistants I receive the same error but on a Windows 2003 Server.

                DataBase Configuration Assistant:

                Failed to allocate port(s) in the specified range for the following process(es): JMS [5540-5559],RMI [5520-5539],Database Control [5500-5519],EM agent [1830-1849]


                I set (in windows registry) the MaxPortUser key to 65534 and TcpTimedWaitDelay key to 30 secs , but it still not working (same error).

                any help?

                thanks in advance,

                Alvaro.

                • 5. Re: emca: Failed to allocate port(s) in the specified range...
                  ex*443583*on
                  I had the same trouble when creating an Oracle 10.1.0.4 database on RedHat Enterprise Linux 4.

                  I was successfully install a database on a machine, but not to the other.
                  I found the difference between the two machine. It was the /etc/hosts file.

                  I fix that file and after, emca finished without any error.

                  On windows, the hosts file is located in system32/drivers/etc I think

                  Hope that helps.

                  Nicolas
                  • 6. Re: emca: Failed to allocate port(s) in the specified range...
                    444180
                    We are have the exact same problem.
                    SEVERE: Failed to allocate port(s) in the specified range for the following process(es): JMS [5540-5559],RMI [5520-5539],Database Control [5500-5519],EM agent [1830-1849]
                    I was wondering if you ever found out what it was?

                    Thanks.

                    Pat.
                    • 7. Re: emca: Failed to allocate port(s) in the specified range...
                      Ivan Kartik
                      Patrick,

                      my post from "Apr 20, 2005" explains how to solve that problem.
                      • 8. Re: emca: Failed to allocate port(s) in the specified range...
                        444484
                        i 've triple checked all requirements and my /etc/services file and everyhting is fine except runInstaller breaks with the same (posted by multiple people above) message.
                        FYI Ivan: your post from april 20th doesn't help at all. i mean it might help somebody who doesn't read docs, but the rest of the story is missing from there.
                        while searching online i found that a number of people ran into the same problem.
                        the proposed workaround is to run emca -h etc..
                        emca -RMI_port<port> etc

                        but what is the problem with hosts file? anybody?
                        • 9. Re: emca: Failed to allocate port(s) in the specified range...
                          14785
                          Hi,
                          I'm joining this thread late as I've just encountered the same problem.
                          None of the ports specified in the error message are in the etc/services file, and none of them are in use according to netstat either. sysctl.conf and ip_local_port_range are both correct too.

                          SEVERE: Failed to allocate port(s) in the specified range for the following process(es): JMS [5540-5559],RMI [5520-5539],Database Control [5500-5519],EM agent [1830-1849]

                          Werner Puschitz has something about this on his Suse installation page in the Troubleshooting section (http://www.puschitz.com/InstallingOracle10gOnSUSE.shtml ) , but is does not seem to have got into his Red Hat page:

                          The problem is that ports listed in /etc/services are discounted.
                          The workaround is to specify the ports manually, see emca -h.
                          Use the following options and use the port ranges as specified in the above error message:

                          emca -RMI_PORT <port> -JMS_PORT <port> -AGENT_PORT <port> -DBCONSOLE_HTTP_PORT <port>

                          so it may be worth giving that a try.
                          • 10. Re: emca: Failed to allocate port(s) in the specified range...
                            436116
                            I experienced a same failure recently during my trial installations. I didn't have the error at the first two tries. But when I tried third time, I got this error. That's why I found this thread. I checked everything suggested here and found no solution still. Later, I figured out that the error actually was an indication of network failure. It turned out my eth0 mysterously quited working prior my installation. (Do a "ifconfig" and you can see it.) And the database configuration scripts actually looked for an active card and therefore failed. Once I fixed the problem in the network card, this problem went away.

                            Just want to let you know that may hints and clues provided here are correct, but sometimes may not be "complete".
                            • 11. Re: emca: Failed to allocate port(s) in the specified range...
                              blue4real
                              I recently ran into this problem and found the response from exploitation@edt.fr on May 10, 2005 very helpful. Thanks a lot.

                              My problem had to deal with an incorrect entry in the /etc/hosts file. We had originally loaded this machine using a dynamic IP. Later we changed it to a static IP and when I went to reload Oracle I ran into this problem. Once I corrected the /etc/hosts file emca ran without any problems.

                              Mark
                              • 12. Re: emca: Failed to allocate port(s) in the specified range...
                                456585
                                I was facing the same kind of problems(ports errors) with 10g emca and resolved by check the /etc/hosts file i just made an entry
                                ip_address hostname hostname.domainname

                                Regards,
                                • 13. Re: emca: Failed to allocate port(s) in the specified range...
                                  271342
                                  I was also facing same problem during emca run for Oracle 11g on Fedora 7. In the profile I used a variable ORACLE_HOSTNAME which was not same with the value in /etc/hosts. Please make sure host name in /etc/hosts, /etc/sysconfig/network and /proc/sys/kernel/hostname are all same.

                                  Regards,
                                  Amalesh
                                  • 14. Re: emca: Failed to allocate port(s) in the specified range...
                                    567981
                                    Hi I have the same problem on Windows 2003, my problems is not related to the host file or serviec the emca just run out of port, how can i expand this range as i need to create more databases.
                                    1 2 Previous Next