1 2 Previous Next 20 Replies Latest reply: Jul 4, 2011 3:28 AM by -K- RSS

    Connection Fails

      I'm using SQL Developer 3.0.04 on Windows Vista.

      We are using TCP and port 1521. The connection works fine in SQLPLUS.

      Connection to - 64bit running on Red Hat

      It seems I can initially connect in SQL Developer, but as soon as a type a query into the worksheet or a browse database objects in the navigation pane I get the following error.


      LEVEL: severe
      SEQUENCE: 52
      ELASPED: 0
      SOURCE: o.d.db.DBUtil
      MESSAGE: Warning, unhandled exception: Closed Connection

      LEVEL: severe
      SEQUENCE: 53
      ELASPED: 0
      SOURCE: o.d.db.DBUtil
      MESSAGE: Warning, unhandled exception: Closed Connection
        • 1. Re: Connection Fails
          If you run from \sqldeveloper\bin\sqldeveloper.exe, do you get any output in the opened console when reproducing this? This could help diagnosing the problem.

          • 2. Re: Connection Fails
            I ran \sqldeveloper\bin\sqldeveloper.exe

            All it displays in the output window is Registered Times Ten - nothing else

            As soon as I run select sysdate from dual I get connection closed.
            • 3. Re: Connection Fails
              Hi all,

              Same problem here. After all I tried, I strongly assume it is a software bug.
              My PC = Windows 7 Pro X64 SP1, Java 32-bit. My environment looks like this:

              Oracle user accounts:
              U1 = user 1
              U2 = user 2, with DBA role on DBA_ROLE_PRIVS

              DB1 = Oracle Database 11g Enterprise Edition Release - Production
              DB2 = Oracle Database 10g Release - 64bit Production

              U1 and U2 can connect with Oracle SQL Developer to DB1 and DB2.
              U1 and U2 can connect with Oracle SQL Developer to DB2.
              Only U1 can connect with Oracle SQL Developer to DB1.

              Connection method in SQL Developer is the same over all tests:
              simple connection + standard role + user/pass + host (name/ip) + port + sid.

              Until now I tried:
              - resetting all SQL Developer data (including appdata\roaming) and starting from scratch.
              - disable IPv6 on my LAN adapter.
              - start with administrative privileges.
              - tried different versions of SQLDev 3.x
              - mixed SQLDev 32 bit and 64 bit (by manually adding JDK)

              Nothing worked.

              Note: In SQL-Plus everything works fine.

              Edited by: 861716 on 26.05.2011 09:33
              • 4. Re: Connection Fails
                If any of you have a DB support contract, I suggest you log a SR through Metalink/MOS, to guarantee follow-up from Oracle.

                • 5. Re: Connection Fails
                  Obviously, the SQL Developer team does not follow this forum.
                  • 6. Re: Connection Fails
                    I have found a solution for this problem.

                    It is a software bug in Oracle SQL Developer.
                    Just install the latest version of Oracle SQL Developer and goto HELP > INSTALL UPDATES.
                    There is an "Oracle Patch 11..." fixing the problem described above.

                    Edited by: 861716 on 08.06.2011 07:45
                    • 7. Re: Connection Fails
                      Hi, could you please provide the full name for the patch?

                      • 8. Re: Connection Fails
                        There's only 1 patch... not that difficult to find.

                        But nice find, no one announced it!

                        • 9. Re: Connection Fails
                          Absolutely useless post. No question, no answer... Thx for the participation
                          • 10. Re: Connection Fails
                            Jim Smith
                            And your participation constributes what exactly?

                            As K says, there is only one patch so there is nothing to add.
                            • 11. Re: Connection Fails
                              I found the patch the installed it. I still get the "closed connection" message. It only does this on one database. SQL Developer works fine on the other databases.
                              • 12. Re: Connection Fails
                                I asked question. This is enough, especially, that the post with patch info was provided not by Mr K. I searched Metalink prior to post it for patch on SQL Developer but have not find any... But take it easy.
                                • 13. Re: Connection Fails
                                  Instead of asking questions, read; goto HELP > INSTALL UPDATES.

                                  • 14. Re: Connection Fails
                                    :) Gentleman, you have to respect others and not assume that you are very special and others just a pedestrians on your way to success. I did that, unfortunately, SQL Developer returned error, saying that all update servers like oracle.com are down. I tried that once and did not bother again. Thank you very much for help, I'm laughing, how fast technical forum becomes just a social one...
                                    1 2 Previous Next