5 Replies Latest reply: Jun 12, 2011 3:47 AM by 793415 RSS

    Java Version

    user151917
      Hi,

      How to check java version in oracle EBS I know the command java –version but as per my requirement I need to know which java version is being used by Oracle application server and full oracle EBS.
      As per Oracle Service request I need to install “JDK 5.0.0.51 or higher” but after running java –version it is giving 1.5.0 for full details find below.

      $ java -version
      java version "1.5.0"
      Java(TM) 2 Runtime Environment, Standard Edition (build pap64dev-20070201 (SR4))
      IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 AIX ppc64-64 j9vmap6423-20070201 (JIT enabled)
      J9VM - 20070131_11312_BHdSMr
      JIT - 20070109_1805ifx1_r8
      GC - 200701_09)
      JCL - 20070126

      Kindly suggest

      Thanks
        • 1. Re: Java Version
          gimbal2
          Yes Java 1.5 is in fact Java 5; hurray for confusing version naming.

          However, Java 1.5.0 is very old, I would highly suggest you to upgrade it to the latest Java 5 release version. I wouldn't know how to do that for your specific OS, but I'll bet the IBM website can tell you more.
          • 2. Re: Java Version
            user151917
            Thanks for prompt response.

            I will raise ticket on IBM site too. As per my Aix admin on system there is already installed JDK 5.0.0.51 but when I run java -version it gives as I updated before. For your information find below.

            lslpp -l |grep Java
            Java5.sdk 5.0.0.125 COMMITTED Java SDK 32-bit
            Java5_64.sdk 5.0.0.150 COMMITTED Java SDK 64-bit
            And where I need to install as recommended oracle service request there is a directory jdk in oracle application server,under the jdk directory there is a file COPYRIGHT and contents of COPYRIGHT file is below, Please confirm me what is the version of this jdk.
            Licensed material - Property of IBM
            <IBM(R) 64-bit SDK for AIX(TM)>, Java(TM) 2 Technology Edition, Version 5
            <IBM(R) 64-bit Runtime Environment for AIX(TM)>, Java(TM) 2 Technology Edition, Version 5

            (c) Copyright Sun Microsystems Inc, 1992, 2004. All rights reserved.
            (c) Copyright IBM Corporation, 1998, 2005. All rights reserved.

            The Apache Software License, Version 1.1 and Version 2.0
            Copyright (c) 1999-2004 The Apache Software Foundation. All rights reserved.

            This product is based in part on the work of the Independent JPEG group.

            The Java technology is owned and exclusively licensed by Sun Microsystems Inc.
            Java and all Java-based trademarks and logos are trademarks or registered
            trademarks of Sun Microsystems Inc. in the United States and other countries.

            US Govt Users Restricted Rights - Use duplication or disclosure
            restricted by GSA ADP Schedule Contract with IBM Corp.
            • 3. Re: Java Version
              jschellSomeoneStoleMyAlias
              user11969485 wrote:
              How to check java version in oracle EBS
              That is an application. You use whatever version is appropriate for that application. No other.

              I would suspect it already comes with the application.

              And myself I would be sure that running java from the command line is going to tell you anything. Since the application probably controls what runs internally. But that is something that can only be address on a application specific forum. It should be possible to get the version at run time by using the System properties.
              • 4. Re: Java Version
                user151917
                Thanks for reply,

                I would suspect it already comes with the application.
                --Yes it comes with application but because of resolving an issue I need to upgrade jdk to JDK 5.0.0.51 or higher so I need to know first what java version is being used by application and as I attached java version with this form that is 1.5.0.

                Do 1.5.0 meets with JDK 5.0.0.51 or higher?
                • 5. Re: Java Version
                  793415
                  user11969485 wrote:
                  ..I need to know first what java version is being used ..
                  Try some of these properties (via <tt>System.getProperty(String)</tt>)

                  ||Name||Value||
                  |<tt>java.runtime.version</tt>|1.6.0-b105|
                  |<tt>java.specification.version</tt>|1.6|
                  |<tt>java.version</tt>|1.6.0|
                  |<tt>java.vm.version</tt>|1.6.0-b105|

                  Values shown are for the JRE this box uses from the command line.