5 Replies Latest reply: Oct 29, 2013 5:35 PM by LauraV RSS

    Ojdeploy - EAR issue

    Ajay G M
      Hi,
      I am using the application deployment profile to create the EAR for my application using ojdeploy.
      This application deployment profile has a Model and ViewController project.
      When I create the EAR using this deploy profile through jdevelioer, the Viewcontoller -> WEB-INF/classes are present.

      However when i use ojdeploy for the same profile these classes are not created.


      Thanks
      Ajay
        • 1. Re: Ojdeploy - EAR issue
          John Stegeman
          Ajay,

          What's the exact JDev version, and how exactly are you invoking ojdeploy (ANT task, command line, etc)?

          John
          • 2. Re: Ojdeploy - EAR issue
            Ajay G M
            John,
            I am using jdev 11.1.1.4 and I am using ant. Below is my ant script code

            <target name="deploy" description="Deploy JDeveloper profiles" depends="init">
            <taskdef name="ojdeploy"
            classname="oracle.jdeveloper.deploy.ant.OJDeployAntTask"
            uri="oraclelib:OJDeployAntTask"
            classpath="${oracle.jdeveloper.ant.library}"/>
            <ora:ojdeploy xmlns:ora="oraclelib:OJDeployAntTask"
            executable="${oracle.jdeveloper.ojdeploy.path}"
            ora:buildscript="${oracle.jdeveloper.deploy.dir}/ojdeploy-build.xml"
            ora:statuslog="${oracle.jdeveloper.deploy.dir}/ojdeploy-statuslog.xml"
            <ora:deploy>
            <ora:parameter name="workspace"
            value="${oracle.jdeveloper.workspace.path}"/>
            <ora:parameter name="profile"
            value="${oracle.jdeveloper.deploy.profile.name}"/>
            <ora:parameter name="nocompile" value="true"/>
            <ora:parameter name="outputfile"
            value="${oracle.jdeveloper.deploy.outputfile}"/>
            </ora:deploy>
            </ora:ojdeploy>
            </target>
            • 3. Re: Ojdeploy - EAR issue
              Chris Muir-Oracle
              Try leaving out the following line completely:

              <ora:parameter name="nocompile" value="true"/>

              CM.
              • 4. Re: Ojdeploy - EAR issue
                Ajay G M
                Thanks Will try
                • 5. Re: Ojdeploy - EAR issue
                  LauraV

                  I had this exact same issue, and the solution works.

                   

                  Hopefully this thread will be marked as "Answered" so it's more helpful.