6 Replies Latest reply: Jul 5, 2011 6:51 AM by 869530 RSS

    Delegation & Remediation not working in OIA


      I've installed SIM 8.1 and OIA 11g on my machine and I've also done the user integaration (also applied the Oracle Waveset patch to SIM and made it Oracle Waveset 8.1).
      Data import from Oracle Waveset 8.1 to OIA 11g works fine.

      But, I'm facing two issues:
      1. In the certification process (user delegation certification to be exact), after assigning a delegate, the request does not go to the delegate, but instead gets completed.

      2. In the Remediation process, after revoking the user's account in the certification, the user's account is not getting deleted either on SIM or OIA or the resource.
      For remediation, I tried using a a locally available MySQL and an LDAP installed elsewhere.

      Please help me with the resolution of these two issues.

      Please find below my configurations:
      Windows 7 Enterprise
      Java 1.6.0_20
      Apache Tomcat 6.0
      Oracle Waveset 8.1 (20100720 Update 1)
      OIA 11gR1

      4GB RAM
      140+GB system memory

      Thanks in advance.
        • 1. Re: Delegation & Remediation not working in OIA
          Daniel Redfern
          Regarding the delegates, you need to finalise off the certifiation to then activate the new certification for the delgate.

          There has been issues with the remediation process for 11gR1, make sure you have BP4 (can be downloaded from the Oracle support website) which should then resolve your remediation issue.

          Hope this helps

          • 2. Re: Delegation & Remediation not working in OIA
            Hi Daniel. Thanks a lot for your reply! It would really help me if you can give me the URL of BP4 download from Oracle Support site. I actually could not find it. Could you please post it here?

            Also, I did not quite get your answer to performing delegation, because I performed all the required steps for delegation and can't think of anything that I missed.
            So, can you please elaborate on this?

            • 3. Re: Delegation & Remediation not working in OIA
              Daniel Redfern

              The current patch release for OIA (Oracle Identity Analytics) 11gR1 can be obtained by following the procedure below when in My Oracle Support: (http://support.oracle.com)

              * Select the Patches & Updates tab.
              * In the Patch Search area under the Search tab select the "Product or Family (Advanced Search)" option.
              * In the Product field enter "Oracle Identity Analytics".
              * Expand the resulting entry in the Release field and select "Oracle Identity Analytics".
              * Press the Search button.
              * Choose the appropriate link from the Patch Name column in the resulting table and download as required.

              For the delegation issue, it sounds like you haven't configured it correctly,
              Got to -> Administrator -> Identity Certification -> User entitlement and make sure the 'Create new certification per reporting manager' is ticked

              • 4. Re: Delegation & Remediation not working in OIA
                Hi Daniel. Thanks a lot! Your solution for delegation worked liked a charm! :)

                As regards the BP4 patch download from the URL, it's asking me for a password - and it's throwing an error when I give my Oracle forums password. Is it expecting some other password?

                Thanks in advance.
                • 5. Re: Delegation & Remediation not working in OIA
                  Daniel Redfern

                  I have just tested and noticed that you need a password, very strange! You can however download the BP3 without using a password. For what you want that will be enough

                  • 6. Re: Delegation & Remediation not working in OIA
                    Thanks a lot Daniel! I downloaded a lesser version and now remediation too is working fine.

                    However, once I do a remediation, the 'Remediation Status' is just shown as 'Requested' (gets changed to this from 'Required') and not 'Completed' - and the Remediation task is not getting completed (not showing 100% but just showing 0%).

                    Am I missing anything?

                    Thanks in advance.