This discussion is archived
1 Reply Latest reply: Aug 23, 2012 5:33 AM by dlzp_dave RSS

Unable to install OSNConnector from PIA setup script

794959 Newbie
Currently Being Moderated
I'm trying to install the FIN/SCM PeopleSoft eProcurement application package (OSNConnector) from the PIA setup script. Per the instrucitons, I run the PIA setup (in $PS_HOME/setup/PsMpPIAInstall). When I select "Deploy additional PeopleSoft application extensions" and then check "FIN/SCM PeopleSoft eProcurement," the installation seems to complete and there are no errors generated. Per the instructions, once the install is complete, it should have deployed the following files (listed below), but none of them are present.

%PS_HOME%\webserv\PSDomain name\applications\peoplesoft\PSIGW\
WEB-INF\classes\com\peoplesoft\pt\integrationgateway\listeningconnector\fscm_epo_OSNListeningConnector.class
%PS_HOME%\webserv\PSDomain name\applications\peoplesoft\PSIGW\
WEB-INF\classes\com\peoplesoft\pt\integrationgatewaytargetconnector\fscm_epo_OSNTargetConnector.class
%PS_HOME%\webserv\PSDomain name\applications\peoplesoft\PSIGW\WEB-INF\classes\com\peoplesoft\fscm\epo\servlet\Support\fscm_epo_EproRequestException.class
%PS_HOME%\webserv\PSDomain name\applications\peoplesoft\PSIGW\WEB-INF\classes\com\peoplesoft\fscm\epo\servlet\Support\fscm_epo_ExtendXml.class
%PS_HOME%\webserv\PSDomain name\applications\peoplesoft\PSIGW\WEB-INF\classes\com\peoplesoft\fscm\epo\servlet\Support\fscm_epo_EproOsnAttacher.class
%PS_HOME%\webserv\PSDomain name\applications\peoplesoft\PSIGW\WEB-INF\classes\com\peoplesoft\fscm\epo\servlet\Support\fscm_epo_FTPClient.class

I've searched for fscm*.class and the files aren't located anywhere. The only thing I can think of is that maybe the fscm_epo_ws.ear file is in the wrong location. Per the instructions, the fscm_epo_xx.ear files are located in $PS_HOME/setup/PsMpPIAInstall/archives; but should they be in another location? I'm having the exact same problem with our WebSphere PIA and WebLogic PIA (both using the same PT and FSCM versions)

Is there a known problem with this? Does anyone have experience installing the OSN Connector on PT 8.50 / FSCM 9.1?

My environment is PeopleTools 8.50.09, FSCM 9.1r1 and I've duplicated this issue on an AIX lpar with WebSphere 7, and a RHEL server with WebLogic 10. I do have a SR open with Oracle. So far, they've suggested that the class files don't show up until after the web server is restarted. I've tried that in a few different environments with no success.

Any help and/or insight would be much appreciated. Thanks.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points