11 Replies Latest reply: Jul 11, 2012 6:09 PM by Mike Dill RSS

    WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3

    730040
      hi,

      i upgraded to R12.1.3
      R12.1.3 has SSL enabled IMAP and SMTP.
      i am trying to configure smtp.gmail.com for sending emails.

      i completed all the steps using ID 1324799.1 but when i try to send an email to override address it's failing with following error message,

      FAILURE: javax.mail.SendFailedException: Sending failed; nested exception is: class javax.mail.MessagingException: 530 5.7.0 Must issue a STARTTLS command first. k2sm4155554wfe.3 Parameters {{OUTBOUND_USER=xyz, FROM=Workflow Mailer, REPLYTO=xyz@gmail.com, OUTBOUND_SERVER=smtp.gmail.com, OUTBOUND_PASSWORD=*****, COMPONENT_ID=10006}}

      following commands as per the above metalink ID are working fine,

      a. SMTP

      $AFJVAPRG -classpath $AF_CLASSPATH -Dprotocol=smtp \
      -Ddbcfile=$FND_SECURE/TEST.dbc \
      -Dport=465 -Dssl=Y \
      -Dtruststore=/home/applmgr/.keystore \
      -Dserver=email.yourdomain.com \
      -Daccount=youremail@yourdomain.com -Dpassword=xxxxx \
      -Dconnect_timeout=120 -Ddebug=Y \
      -DdebugMailSession=Y oracle.apps.fnd.wf.mailer.Mailer

      b. IMAP

      $AFJVAPRG -classpath $AF_CLASSPATH -Dprotocol=imap \
      -Ddbcfile=$FND_SECURE/TEST.dbc \
      -Dport=993 -Dssl=Y \
      -Dtruststore=/home/applmgr/.keystore \
      -Dserver=email.yourdomain.com \
      -Daccount=youremail@yourdomain.com -Dpassword=xxxxx\
      -Dconnect_timeout=120 -Ddebug=Y \
      -DdebugMailSession=Y oracle.apps.fnd.wf.mailer.Mailer

      anyone has faced this issue? please help.

      regards,
        • 1. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
          Hussein Sawwan-Oracle
          Please see if these docs help.

          Notifications fail with "Must issue a STARTTLS command first" when using SSL Enabled SMTP Server in Grid Control [ID 788544.1]
          Does UTL_SMTP or UTL_MAIL Support TLS Connection? [ID 413099.1]

          Thanks,
          Hussein
          • 2. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
            730040
            hi Hussain,

            1. my env is R12.1.3. so not sure if that uses Enterprise Manager Grid Control - Version: 10.2.0.4.
            or does it? if yes, how to know what version it uses?


            2. ID 413099.1 is about UTL_SMTP or UTL_MAIL not supporting TLS feature.
            but in my case i am trying this with the workflow notification mailer which uses Java notification mailer. does that internally use UTL_SMTL or UTL_MAIL?

            My DB verison is 11g (11.1.0.7).

            3. as per ID 1324799, wf notification mailer should work with SSL enabled smtp servers.
            looks like when wf notification mailer is trying to connect to the smtp server, it is not issuing/using/sending the SSL cert to the smtp server for secure connection which gmail is expecting.

            is there any patch for that?

            please advice.

            thanks,
            • 3. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
              947270
              Hello Hussain,

              I am facing the same issue in 12.1.3 env.
              Need to use gmail as smpt, but mailer replies: "Must issue a STARTTLS command first."

              Did you solve your problem?

              Thanks,
              Ricardo
              • 4. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
                Hussein Sawwan-Oracle
                Have you reviewed the docs referenced above?

                Please also see:

                Notification Mails Not Working In Application Access Controls Governor. [ID 781588.1]
                OTA-SMTP-1001 Sending Email over Delivery Channel [ID 1465749.1]

                Thanks,
                Hussein
                • 5. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
                  Mike Dill
                  We are facing this same issue. We cannot get WF Mailer to work for gmail for smtp. We are trying to use smtp.gmail.com with SSL enabled. We have reviewed all the mentioned documents and they have not resovled the issue.

                  Is this supported or is there a known fix?

                  Thanks,
                  Mike
                  • 6. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
                    Hussein Sawwan-Oracle
                    user8888662 wrote:
                    We are facing this same issue. We cannot get WF Mailer to work for gmail for smtp. We are trying to use smtp.gmail.com with SSL enabled. We have reviewed all the mentioned documents and they have not resovled the issue.

                    Is this supported or is there a known fix?
                    Please log a SR or See Gmail support page (search for smtp) -- http://support.google.com/mail/?hl=en

                    Thanks,
                    Hussein
                    • 7. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
                      Mike Dill
                      Hi Hussein,

                      We do have an SR opened but not progress is being made and we have combed through the google support page and it still will not working. Has no one gotten this to work yet? Do you know of anyone who has gotten WF Mailer to work with Google mail?

                      Thanks,
                      Mike
                      • 8. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
                        Hussein Sawwan-Oracle
                        Hi Mike,

                        I did this setup before with Gmail with no issues.

                        What is the error you get?

                        Thanks,
                        Hussein
                        • 9. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
                          Mike Dill
                          Thanks Hussein. Good to hear this has been successfully configured.

                          We have gone through several MOS Notes to no avail. We are trying to setup the outbound server using gmail (smtp.gmail.com) with SSL enabled and inbound using imap.gmail.com. We followed the steps in Note 1324799.1 but now we get the following error:

                          Could not handle the control event -> oracle.apps.fnd.cp.gsc.SvcComponentContainerException: Could not start component; performing rollback -> oracle.apps.fnd.cp.gsc.SvcComponentException: Validation failed for the following parameters -> {ACCOUNT=Unable to connect to the mail account. Check the host, user name and password., OUTBOUND_SERVER=Unable to connect to the mail account. Check the host, user name and password.}

                          The DBA and Sysadmin both have stated we can successfully telent to port 465, which according to Google and Oracle docs is what should be used. When you configured it did you have to use the security certificate as well?

                          We did have WF mailer working previously on an internal homegrown mail server but now are switching to gmail, so this has worked in other configurations. For some reason, we can't seem to get WF Mailer to authenticate with Google (Gmail). We do not have 2-step verification enabled on the gmail side, so not sure what we're missing.

                          Thanks,
                          Mike
                          • 10. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
                            Hussein Sawwan-Oracle
                            Hi Mike,
                            We have gone through several MOS Notes to no avail. We are trying to setup the outbound server using gmail (smtp.gmail.com) with SSL enabled and inbound using imap.gmail.com. We followed the steps in Note 1324799.1 but now we get the following error:

                            Could not handle the control event -> oracle.apps.fnd.cp.gsc.SvcComponentContainerException: Could not start component; performing rollback -> oracle.apps.fnd.cp.gsc.SvcComponentException: Validation failed for the following parameters -> {ACCOUNT=Unable to connect to the mail account. Check the host, user name and password., OUTBOUND_SERVER=Unable to connect to the mail account. Check the host, user name and password.}
                            Have you reviewed all these docs?

                            Unable To Connect To The Mail Account. Check The Host, User Name And Password [ID 1123684.1]
                            Configurnig IMAP4 For Workflow Mailer Errors: Unable to connect to the mail account. Check the host, user name and password. [ID 1081089.1]
                            How to Troubleshoot 'Validation failed' Errors when Starting the Mailer [ID 463354.1]
                            Unable To Make A Network Connection For IMAP Username/Password In Workflow Mailer Configuration [ID 784247.1]
                            Mailer cannot Connect to IMAP Server on Oracle Applications R12.1.1 [ID 1300542.1]
                            Cannot Start Workflow Notification Mailer. 'System Deactivated' [ID 602624.1]
                            Java Mailer configuration fails on EMail Servers configuration page [ID 1239213.1]
                            IMAP Account Not Getting Connected While Configuring Workflow in OAM [ID 558798.1]
                            After Enabling SSL/TLS, Workflow Mailer does not Start due to "Unable to connect" error [ID 1456124.1]
                            How to obtain Java Error Stack when configuring Java Mailer using OAM [ID 1348284.1]
                            The DBA and Sysadmin both have stated we can successfully telent to port 465, which according to Google and Oracle docs is what should be used. When you configured it did you have to use the security certificate as well?
                            I did configure it for Inbound only and did not have to use any security certificate.

                            Thanks,
                            Hussein
                            • 11. Re: WF Notificaiton mailer not sending emails using SSL enabled SMTP in R12.1.3
                              Mike Dill
                              Thanks for the documents Hussein. We went through them all and still cannot get it to work for Outbound messages, which is our primary focus. We haven't tested Inbound yet.

                              If you find anything else or come across another customer who has this working please let me know.

                              Thanks,
                              Mike