7 Replies Latest reply: Jun 15, 2012 10:28 AM by 942960 RSS

    wlserver_10.3  does not contain a valid WebLogic Server install.

    850616
      Hi all
      i installed weblogic plugin for eclipse from : http://download.oracle.com/otn_software/oepe/galileo
      successfully.

      But when i try to create a server in my server tab appears message 'The path "C:\oracle\Middleware\wlserver_10.3" does not contain a valid WebLogic Server install.'

      I installed weblogic in that path.
      Any idea?
        • 1. Re: wlserver_10.3  does not contain a valid WebLogic Server install.
          Raj Alag
          Hi,

          Which version of WebLogic Server do you have installed in C:\oracle\Middleware\wlserver_10.3 ? and what Server Runtime version are you creating from within OEPE ?

          thanks
          Raj
          • 2. Re: wlserver_10.3  does not contain a valid WebLogic Server install.
            kosta
            OEPE looks for server/lib/weblogic.jar under the specified path. Then it reads the manifest in that jar looking for Implementation-Version matching known versions of WLS.

            If the file is there and you can open it to read the manifest, make sure there is nothing funky going on with file permissions. There could be problems if WLS was installed under one user and Eclipse is running under another as Eclipse may not be able to read these files.

            Another possible cause for problems is that you installed a version of WLS that is beyond the capabilities of the last OEPE release issued for Eclipse Galileo platform. If that's the case, you will need to move to a newer Eclipse platform, such as Helios or Indigo.

            - Konstantin
            • 3. Re: wlserver_10.3  does not contain a valid WebLogic Server install.
              850616
              i installed oracle weblogic 10.3 and i try to create an oracle weblogic 10.3 server.
              I cannot find yet the weblogic home when creating.
              • 4. Re: wlserver_10.3  does not contain a valid WebLogic Server install.
                837660
                Hi All
                I had the same problem. When I initially installed weblogic, the installer installed it in a home with a path like C:\Oracle\Middleware\wlserver_10.3. Therefore when you try to set the dynamic run time module through eclipse, it will look for C:\Oracle\Middleware\wlserver_10.3.2 (weblogic 10.3.2 in my case). So the solution that worked for me was to uninstall weblogic server and re-install it where this time I set the Weblogic server home during the install as C:\Oracle\Middleware\wlserver_10.3.2 <- notice the 2 at the end. If you cannot uninstall the current weblogic server home then install another instance of it and you should be laughing.

                Cheers
                Derek Giri
                • 5. Re: wlserver_10.3  does not contain a valid WebLogic Server install.
                  942960
                  I am getting the same error message. The path "C:\Oracle\Middleware\wlserver_10.3" does not contain a valid WebLogic Server install.
                  This is with update site: http://download.oracle.com/otn_software/oepe/ganymede for Eclipse 3.4 on Windows 7.
                  I also tried to uninstall/re-install WebLogic with the path C:\Oracle\Middleware\wlserver_10.3.6" but still no luck. Any ideas?
                  • 6. Re: wlserver_10.3  does not contain a valid WebLogic Server install.
                    kosta
                    How you name wlserver direction isn't important for the tooling. What is important is whether the version of OEPE you have supports the version of WLS you are trying to use. When you go to create a target runtime, the versions listed are the only supported versions. Development on Eclipse 3.4 Ganymede stream (http://download.oracle.com/otn_software/oepe/ganymede) stopped with support for WLS 10.3.2. You will not be able to get your Eclipse installation to work with WLS 10.3.6 no matter what you try.

                    You need to move to a newer version of Eclipse to be able to target newer versions of WLS.

                    - Konstantin
                    • 7. Re: wlserver_10.3  does not contain a valid WebLogic Server install.
                      942960
                      I've downloaded 10.3.2 and it is now working. Thx!