3 Replies Latest reply on Jul 18, 2011 2:35 PM by 876208

    Importing service description from UDDI, makes BP Architect to exit

    George Moykin-Oracle
      Hi guys,

      I have BP Architect (BPA Suite 11gR1) installed on WinXP sp3
      I want to import WSDL from UDDI (e.g. Oracle Service Registry 11.1.1)

      Create and test of the connection (BPA->View->Options->Connections),e.g. my connection name; UDDI_OSR:
      is successful.

      But when I want to import service description:
      right-click myBusinessDtata folder->SOA->import service description->service URI->browse->select type UDDI-> select connection: UDDI_OSR
      at this point (after select UDDI_OSR from the list),
      BP Architect suddenly crashes and closes!

      I tried to seek for some *.log file - nothing found.
      Looked at support sites - nothing.

      Please, help if someone has faced such a problem!

      Thank you very much!

        • 1. Re: Importing service description from UDDI, makes BP Architect to exit
          George Moykin-Oracle
          I installed BP Architect on Linux (OEL5-32) and I encountered the same problem, but under Linux I was able to see the full java exception.
          Besides the short exception trace in the log file under WinXP, which is: Failure to initialize mapper+
          under Linux the stack trace is much more complete:
          Failure to initialize mapper
          *2010-05-05T09:29:28,358 SEVERE - Exiting unable to initial JAXB context*
          javax.xml.bind.JAXBException: Provider com.sun.xml.bind.ContextFactory_1_0_1 not found
          - with linked exception:
          java.lang.ClassNotFoundException: com.sun.xml.bind.ContextFactory_1_0_1
          at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:147)
          at javax.xml.bind.ContextFinder.find(ContextFinder.java:249)
          at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:372)
          at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:337)
          at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:244)
          at com.sun.xml.registry.uddi.UDDIMapper.initJAXBObjectFactory(Unknown Source)
          at com.sun.xml.registry.uddi.UDDIMapper.<init>(Unknown Source)
          at com.sun.xml.registry.uddi.RegistryServiceImpl.<init>(Unknown Source)
          at com.sun.xml.registry.uddi.ConnectionImpl.<init>(Unknown Source)
          at com.sun.xml.registry.uddi.ConnectionFactoryImpl.createConnection(Unknown Source)
          at com.sun.xml.registry.common.ConnectionFactoryImpl.createConnection(Unknown Source)
          at com.idsscheer.aris.client.components.oracle.gui.extensions.browsing.ImportServiceBrowseDialogs.UddiRegistryAccess.createConnection(UddiRegistryAccess.java:68)
          at com.idsscheer.aris.client.components.oracle.gui.extensions.browsing.ImportServiceBrowseDialogs.UddiRegistryAccess.readRegistry(UddiRegistryAccess.java:41)
          at com.idsscheer.aris.client.components.oracle.gui.extensions.browsing.ImportServiceBrowseDialogs.AUDDIPanel$2.run(AUDDIPanel.java:112)
          at com.idsscheer.aris.client.common.gui.AProgressDialog$2.run(AProgressDialog.java:537)
          at java.lang.Thread.run(Thread.java:619)
          Caused by: java.lang.ClassNotFoundException: com.sun.xml.bind.ContextFactory_1_0_1
          at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
          at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
          at javax.xml.bind.ContextFinder.safeLoadClass(ContextFinder.java:481)
          at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:113)
          ... 15 more

          Just to say it again:
          I'm able to create new Connection (Main menu: View->Options->Connections) and to test it successfully.
          BP Architect crashes when I'm trying to import service description (SOA) by selecting the new created connection in the moment I just select it from the drop-down menu and before to be able to click the Add or Find button.

          UDDI I'm browsing are two Oracle Service Registry 11g instances (WebLogic Server 10.3.2 domains) running on Linux and Windows. (I just wanted to see if the problem is related to the OS hosting the WLS)

          Any help or suggestion is extremely appreciated.
          Thanks a lot.
          • 2. Re: Importing service description from UDDI, makes BP Architect to exit
            George Moykin-Oracle
            I found a workaround.

            I. BPA installed on Linux OEL 5 (x86-32bit)

            The class: com.sun.xml.bind.ContextFactory_1_0_1 is missing in the BPA jar: jaxb-impl.jar+
            So, I download one of the jars containiing the missing class.
            (e.g., Download jaxb1-impl-2.0.3.jar from http://mirrors.ibiblio.org/pub/mirrors/maven2/com/sun/xml/bind/jaxb1-impl/2.0.3/jaxb1-impl-2.0.3.jar )

            I put jaxb1-impl-2.0.3.jar in the *${BPASuite_Install_Folder}/JavaClient.423484/lib* folder.
            I added the new jar file in the classpath by editing the *${BPASuite_Install_Folder}/JavaClient.423484/Oracle Architect 11g.sh* file:


            Note: Although, in the Oracle Architect 11g.sh file, the ${jars} is set to ./lib and there is a java option -classpath "${jars}:${CLASSPATH}", before to edit the CLASSPATH manually, BPA wasn't be able to find the jar. Strange?!

            After doing 1 & 2, I restarted the BPA and I was able to browse the UDDI and to Find and import services.

            II. BPA installed on Windows XP sp3

            1. Do step 1. as for Linux
            2. Put the jaxb1-impl-2.0.3.jar into +%BPASuite11g_InstallDir%\JavaClient\lib+
            3. Edit the file: *%BPASuite11g_InstallDir%\JavaClient\config\launcher.cfg*

            -Xbootclasspath/a:%BPASuite11g_InstallDir%\g\JavaClient\lib\jaxb1-impl-2.0.3.jar to jvmOptions JVM parameter

            4. Restart BPA

            Please, send some comments if anyone has been found anything else solution or faced the same problem.


            Edited by: George Moykin on 2010-5-5 11:48

            Edited by: George Moykin on 2010-5-5 12:44
            • 3. Re: Importing service description from UDDI, makes BP Architect to exit

              Hi, more than 1 year after I'm having the same issue with BPA 11gR1.

              I'm trying to invoke a service located in Oracle Service Bus (OSB), but I will get the "unexpected error" when it tries to import it.
              Oddly enough, when I tried made a mock service by hand and tried to use its wsdl it got imported without any problem.

              I tried what you suggest here in this thread without any luck. Im running Windows 7. Any other ideas?