9 Replies Latest reply on Dec 19, 2011 7:31 AM by 876949

    Integrating Analytics service


      I was trying to integrate Analytics service in my webcenter portal application. I folllowed the below steps

      1. Created a webcenter portal application with Database connection associated with activities using DBA credentials.
      2. Configured the JVM properties for OpenUsage under Java options under Manage Run Configurations.
      3. Then started the WC_Utilities server on a different machine.
      4. Included the Analytics task flow for page and document metrics in a jspx.

      Now when i run the page(on my integrated server) i get "Analytics Service is not available: database schema is incomplete, please check Collector component has run successfully."
      And get the below stack trace in the console.
      Caused by: java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist

           at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:457)
           at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:405)
           at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:889)
           at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:476)
           at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:204)
           at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:540)
           at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:217)
           at oracle.jdbc.driver.T4CPreparedStatement.executeForDescribe(T4CPreparedStatement.java:924)
           at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java:1261)
           at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1419)
           at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3752)
           at oracle.jdbc.driver.OraclePreparedStatement.executeQuery(OraclePreparedStatement.java:3806)
           at oracle.jdbc.driver.OraclePreparedStatementWrapper.executeQuery(OraclePreparedStatementWrapper.java:1667)
           at weblogic.jdbc.wrapper.PreparedStatement.executeQuery(PreparedStatement.java:135)
           at com.plumtree.analytics.core.dao.jdbc.JdbcEventTypeDimensionDAO.findByName(JdbcEventTypeDimensionDAO.java:88)
           ... 138 more

      Am i doing something wrong here? Or is it that the Activities schema is not installed properly and i need to do it again?
      If so it would be helpful if i have some reference to the RCU installation procedure.

        • 1. Re: Integrating Analytics service
          Yannick Ongena
          I think this step is wrong:

          Created a webcenter portal application with Database connection associated with activities using DBA credentials

          You should login with the activities credentials and not the DBA credentials. You should use the credentials that you have configured during the running of the RCU. There you have specified the username/password for each schema. The analytics are stored in the activities schema so you should use these credentials.

          Did you run the RCU? It is also possible that you haven't run the RCU. This is required because the RCU will generate all the needed tables.
          For running the RCU, you can read following post: http://www.yonaweb.be/run_rcu_webcenter

          Edited by: Yannick Ongena on Jul 27, 2011 3:00 PM
          • 2. Re: Integrating Analytics service
            Thanks for your reply Yannick.

            Yes i did run the RCU scripts during the webcenter installation.
            And i also tried creating a DB connection with the schema owner credentials of ACTIVITIES i.e DEV_ACTIVITIES with the password specified during the repository creation, but still i get the same error.

            Am i specifying the wrong credentials this time as well. Is there something else that has to be done?
            • 3. Re: Integrating Analytics service
              Yannick Ongena
              Have you registered the analytics service with your portal and run the analytics gatherer? This could be the cause of your problem. I'm not sure but i believe the gatherer will also create some tables.

              First of all you need to register the analytics services by using the enterprise manager. Go to your application in the enterprise manager and configure the analytics services so it matches your settings. The port that you need to use for the analytics service is 31314 by default.

              Than go to the gatherer: http://localhost:8891/activitygraph-engine/ and run this.
              If this has been run, you should be able to use the analytics taskflows.
              • 4. Re: Integrating Analytics service
                Hi Yannick,

                This time i deployed my portal application on a managed server and then registered the analytics service with my portal and also accessed the http://<server-ip>:8891/activity-engine/ and clicked on start to run the gatherer.

                Now i am able to see the analytics taskflow on the page rendering some analytics template with some graph,etc.
                But the problem is, it says "No data to display" in the graph. So i tried clicking on the other pages from the Top navigation and also created some new pages at runtime to check if the data gets populated. But it still gives the same statement.

                Am i still missing on something here?

                And i had another question, previously when i tried to deploy the same application on the integrated server the taskflow was throwing up the error, but now after deploying on managed server i am able to see something come up on the page, i would like to know why? Is it that this is not supported well or doesn't work with the integrated server?

                Also, i would like to specify setup that i have.
                1. The admin server and the managed server on which i am deploying my application are running on one machine.
                2. And the WC_Utilities is running on another machine which i am making use in my application.
                3. I have created the application on Jdeveloper on my local system. And the DB that i am referrring to is also from my local machine. Now i deploy the application on to another server from the JDeveloper on my machine.

                Please let me know if this is fine, or if i have to do something different to make this work.


                Edited by: 859995 on Jul 28, 2011 9:47 PM
                • 5. Re: Integrating Analytics service
                  Waiting for reply.

                  • 6. Re: Integrating Analytics service
                    Rene Mikami
                    Hey, did you solve your problem?

                    I think that analytics only be able to gather information from Spaces. We need to, somehow, configure analytics to gather information from our custom portal.

                    I know it because when I have seem the collector.trc (you_domain/servers/WC_Utilities/logs/analytics_collector/), just have activities when I access Spaces.

                    Another way to check it is seeing your ActivitesDS data source. There is a lot of tables that saves only informations about spaces.

                    Well, i´m waiting for a solution too.
                    • 7. Re: Integrating Analytics service
                      Hi Rene

                      No, the problem is not yet solved. I tried the same approach with spaces too but i am facing the same issue there as well.
                      I am still waiting for a solution.
                      • 8. Re: Integrating Analytics service
                        Rene Mikami

                        I got some answers from oracle suport but I´ve tried it and it not solved this problem for me, at least.
                        Can you check this steps? I could be doing something wrong.

                        attach the properties "-Doracle.mds.bypassCustRestrict=true" at JAVA_OPTIONS in startManagedWeblogic.sh or startWeblogic.sh

                        then, start the server.

                        To check if it´s working, you can see the collector.trc or check the database form ActivitiesDS.
                        • 9. Re: Integrating Analytics service
                          I am glad to see it says "no data to display". I think is not a mistake, but there is no data in the database. The error i get is always Analytics Service is not available: database schema is incomplete, please check Collector component has run successfully.

                          I am not so clear about the following items:

                          1.First I should create a connection to database associated with the ACTIVITIES. Whether I need some file about the schema here. Because when I connect to the localhost with the ACTIVITIES, It does create many tables. however when connected to a remote oracle database, no table is created. By the way, how to ensure the required tables are created?

                          2. Then I also need to configure the jvm properties to set properties for the Analytics service. On the integrated server, as you said,Configured the JVM properties for OpenUsage under Java options under Manage Run Configurations. but what should i do if i deploy the portal to a standalone weblogic server?

                          4.what's rcu you mentioned here. and i could also access to the http://localhost:8891/activitygraph-engine/

                          3.Does integrated server have the WC_Utilities?

                          Edited by: Tom on 2011-12-19 下午3:31