4 Replies Latest reply on Jul 28, 2011 7:03 PM by Udo

    Oracle 11gR2 on ubuntu 64


      I'm trying to install and use Oracle XE 11gR2 on an ubuntu 10.04 amd64. Installation and configuration (/etc/init.x/oracle-xe configure) goes without errors, and the instance is running.
      However, I can't connect to the database, the following error occurs :
      $ sqlplus system/passwd@hostname/xe
      SQL*Plus: Release Beta on Fri Jul 22 10:38:05 2011
      Copyright (c) 1982, 2010, Oracle.  All rights reserved.
      ORA-01033: ORACLE initialization or shutdown in progress
      Process ID: 0
      Session ID: 0 Serial number: 0
      I connected as sysdba, and made a shutdown and startup, which says :
      SQL> startup
      ORACLE instance started.
      Total System Global Area  313159680 bytes
      Fixed Size                  2226080 bytes
      Variable Size             104859744 bytes
      Database Buffers          201326592 bytes
      Redo Buffers                4747264 bytes
      Database mounted.
      ORA-01589: must use RESETLOGS or NORESETLOGS option for database open
      So I tried to open the database with the "resetlogs" option :
      SQL> alter database open resetlogs;
      alter database open resetlogs
      ERROR at line 1:
      ORA-01194: file 1 needs more recovery to be consistent
      ORA-01110: data file 1: '/u01/app/oracle/oradata/XE/system.dbf'
      However, the "/u01/app/oracle/oradata/XE/system.dbf" file exists.

      Does someone have an idea of what problem it might be ?
      Also, I don't have any XE application server running and listening on 8080 tcp, did I miss something ?

      Thanks !
        • 1. Re: Oracle 11gR2 on ubuntu 64
          However, the "/u01/app/oracle/oradata/XE/system.dbf" file exists.
          Well, the error message doesn't say it doesn't exist, but that it's corrupted. It seems that the last part of the installation, the recovery of the instance stored in the installation package, failed on your system. You could either try to repair it, or - because you probably have nothing serious in your instance as it never was online - you could just reinstall it. I'd take a look into the installation log to see what error occured and if it's likely to come up again...
          Also, I don't have any XE application server running and listening on 8080 tcp, did I miss something ?
          Well, there is no application server, actually. The APEX instance is hosted by the so called Embedded PL/SQL Gateway, which is based on the databases internal HTTP Server (XDB HTTP Server).
          You'll have it online when your database comes up properly.

          • 2. Re: Oracle 11gR2 on ubuntu 64
            try recovering the database first (log in as sysdba, type sql>recover database; ), then open database resetlogs
            • 3. Re: Oracle 11gR2 on ubuntu 64
              Thanks all for your help,
              I tried to recover the database, but some errors happened.
              I then reinstalled again the package and the database now starts...

              • 4. Re: Oracle 11gR2 on ubuntu 64
                I'm glad to hear that.
                Could you please mark this question as answered and any helpful or correct answer accordingly, so it other users searching for the problem can spot relevant answers easily.