This discussion is archived
1 Reply Latest reply: Jul 28, 2011 12:14 PM by P.Forstmann RSS

ora-01017 when remote login using @; sqlplus sys as sysdba works fine.

BillS13087422 Newbie
Currently Being Moderated
trying to make an odbc connection to my xe 11g instance

if I logon using sqlplus xxx@localhost/xe I get the invalid password message
if I logon using sqlplus sys as sysdba works fine

tnsping returns
Used parameter files:
C:\oraclexe\app\oracle\product\11.2.0\server\network\admin\sqlnet.ora


Used TNSNAMES adapter to resolve the alias
Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = bill-lap
top)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = XE)))
OK (10 msec)


server is installed at C:\oraclexe\app\oracle\product\11.2.0\server
client is installed at C:\app\xxxxxx\product\11.2.0\client_1

Thanks in advance
  • 1. Re: ora-01017 when remote login using @; sqlplus sys as sysdba works fine.
    P.Forstmann Guru
    Currently Being Moderated
    In Oracle connection strings '/' is used to separate account and password:
    C:\>sqlplus test@localhost/xe
    
    SQL*Plus: Release 11.2.0.2.0 Beta on Jeu. Juil. 28 21:12:40 2011
    
    Copyright (c) 1982, 2010, Oracle.  All rights reserved.
    
    ERROR:
    ORA-01017: invalid username/password; logon denied
    
    
    Enter user-name: ^C
    C:\>
    C:\>sqlplus test/test@xe
    
    SQL*Plus: Release 11.2.0.2.0 Beta on Jeu. Juil. 28 21:12:51 2011
    
    Copyright (c) 1982, 2010, Oracle.  All rights reserved.
    
    
    Connected to:
    Oracle Database 11g Express Edition Release 11.2.0.2.0 - Beta
    
    SQL> exit
    Disconnected from Oracle Database 11g Express Edition Release 11.2.0.2.0 - Beta

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points