3 Replies Latest reply on Jul 29, 2011 6:14 AM by 878676

    DBX runtime checking fails ?

      Hi !

      I am trying to analyze memory usage with DBX 7.4 in SunStudio 10 ( we still using it ... ) in my 5.10 Generic_125100-05 sun4u sparc SUNW,A70 machine but have some difficulties ( hello.c is just the manual example and debugging my application produces same result ):

      raivola@pmrcddh04:: ~/dbx_test$ dbx -C hello
      Reading hello
      Reading ld.so.1
      Reading rtcapihook.so
      Reading libc.so.1
      Reading libdl.so.1
      Reading rtcaudit.so
      Reading libmapmalloc.so.1
      Reading libgen.so.1
      Reading libm.so.2
      Reading libc_psr.so.1
      Reading rtcboot.so
      Reading librtc.so
      (dbx) check -memuse
      memuse checking - ON
      (dbx) run
      Running: hello
      (process id 12301)
      RTC: Enabling Error Checking...
      signal SEGV (no mapping at the fault address) in evfind at 0xf21148f4
      0xf21148f4: evfind+0x001c: ld [%i1], %i5
      dbx: Stopped within call to '__rtc_init'. Starting new command interpreter
      (dbx) exit

      I have also tried by my opinion sensible combinations of the LD_PRELOAD (and/or LD_AUDIT/_32/_64 although this should work only with newer version of dbx) pointing to rtcaudit.so or v9/rtcaudit.so but as expected, it did not help.

      Could anyone give a hint how this could be made to work ?

      Thanks, Martti