7 Replies Latest reply on May 10, 2012 2:08 PM by gvermaat

    First test of Forms 10.1.2.3.0 and JRE 7

    Charon
      I know that this might be highly unsupported, but I was just curious if it would work (well, both Forms and Java are now from the same company, so they might have tested this, jk).

      I am trying this on Windows 7 32bit, Forms doesn't have the latest patch yet though (works fine when you run it once with admin-privileges, no other problems encountered yet).

      When I start the Forms Applet, I get an "FRM-92095: The version of JInitiator being used is too low to support the requested functionality (e.g. to run against the Listener Servlet). User should install the specified version (or greater)." which rather astonished me.
      On my system JInitiator was never installed, and the AS is configured in a way that it should only work with the JRE. The Forms Applet runs with the new browser-plugin, but the java-console shows me that it picked up the JRE 1.6.0_26 just fine (I had the Forms Applet running with this JRE version just fine before installing JRE 7).

      So, any ideas? :-)


      PS.: this is just out of curiosity, no need to get this working.
        • 1. Re: First test of Forms 10.1.2.3.0 and JRE 7
          Charon
          This is interesting, after a reboot the Java Console tells me its the version "10.0.0.147" of the Java-Plug-in, the JRE has version "1.7.0-b147" now, I am sure it was 1.6.0_25 before. I still get the same FRM-92095 though.

          In my frmweb.cfg I use the following lines:
          jpi_classid=clsid:8AD9C840-044E-11D1-B3E9-00805F499D93
          jpi_download_page=http://www.oracle.com/technetwork/java/javase/downloads/index.html
          jpi_mimetype=application/x-java-applet;jpi-version=1.6.0_24
          jpi_codebase=http://java.sun.com/update/1.6.0/jinstall-6-windows-i586.cab#Version=1,6,0,24

          If I understood the documentation right, this should give me dynamic versioning, but requires a JRE with alteast version 1.6.0_24, but it has to be a version 6 JRE, not 7.

          Regards
          Markus
          • 2. Re: First test of Forms 10.1.2.3.0 and JRE 7
            Grant Ronald-Oracle
            You are right this is not supported ;o) - its currently logged as a bug (11782681) and will be fixed as part of our certification tests for Forms - our next certification will be announced in due course.
            regards
            Grant
            • 3. Re: First test of Forms 10.1.2.3.0 and JRE 7
              Andreas Leidner
              I also tested JRE 1.7.0 with Forms 10.1.2.3.1 + Forms bundle patch 12433970 and found something similar:

              - Forms is configured to use JRE 1.6.0 (1.6.0_26 installed here)

              Running this with Java Plugin 1.7.0 / 10.0.0.147 and the next-gen Java plugin (plugin2) activated - which is the default - executes the Forms applet (with JRE 1.6.0_26) fine without any obvious errors. The only thing I found: On the Java console the Java system property deployment.jpi.mode.new is reported with value "true" but the applet's call to System.getProperty("deployment.jpi.mode.new") returns null.
              (we test our system requirements which state the next-gen plugin as of 1.6.0_10 must be used. However, the test now reports an incorrect result)

              Running the applet with Java Plugin 1.7.0 / 10.0.0.147 and the next-gen Java plugin disabled executes the Forms applet with JRE 1.6.0_26 but System.getProperty("deployment.jpi.mode.new") incorrectly reports "true". And the Java console doesn't react to a key press "s" (to print the system and deployment properties).

              I filed Java bug 7072674 for this today (not published yet).

              - When Forms is configured to use JRE 1.7.0 I get the same FRM-92095 as you.

              Grant, thanks for the Forms bug id. Can you make it visible in Metalink so we can follow this? Regarding the next certification: are there any plans to support IE9 with Forms 10.1.2.3?

              Best regards
              Andreas
              • 4. Re: First test of Forms 10.1.2.3.0 and JRE 7
                lake
                thanks for testing this.

                Note: Java 6 goes eol in less than 12 months from today!
                Now does that mean that we who have standardized on jre6 to deploy forms can continue get updates from
                oracle support, if we have accounts? I just got this stuff working and it took a huge amount of effort. I was really hoping for a stable working experience for longer than 11 months into the future.

                http://www.oracle.com/technetwork/java/javase/eol-135779.html?ssSourceSiteId=ocomen
                • 5. Re: First test of Forms 10.1.2.3.0 and JRE 7
                  kv*655685*mb
                  Problem is explained here as well as possible solutions while waiting for official patch :
                  http://www.ora600.be/FRM-92095%3A+Oracle+Jnitiator+version+too+low+-pleaseinstall+version+1.1.8.2+or+higher
                  • 6. Re: First test of Forms 10.1.2.3.0 and JRE 7
                    ttrentham
                    I'm transitioning to a new laptop that had JRE 7 factory installed and ran into the Jinitiator too low problem. I just installed jre 6 update 31 side by side with jre 7 and it works just fine now. This is on Windows 7 64 bit (though running 32 bit JRE) with IE 9.
                    • 7. Re: First test of Forms 10.1.2.3.0 and JRE 7
                      gvermaat
                      For IE there is a way to keep using the JRE 6 while having JRE 7 installed. You can use the jpi versioning parameter. (THIS WILL NOT WORK IN FIREFOX NOR CHROME)

                      scenario.) User has JRE 6 installed and installed JRE 7. (native install will cause both versions to coexist on the system)

                      In the formsweb.cfg we allow users to use dynamic jpi versioning. As a result the highest available JRE version will be used. (JRE 7)
                      Dynamic CLSID formsweb entry:
                      jpi_classid=clsid:8AD9C840-044E-11D1-B3E9-00805F499D93

                      Workaround/Solution:
                      Use "Family" CLSID.
                      This setting will require a valid JRE version belonging to the same major release. (Family) The following value will require JRE6 plugin to be used.
                      jpi_classid=clsid:CAFEEFAC-0016-0000-FFFF-ABCDEFFEDCBA

                      Regards,
                      Gérard

                      More information:
                      [How Do The Jinitiator And JPI Parameters Work In A Forms Configuration [ID 444105.1]|https://support.oracle.com/CSP/main/article?cmd=show&type=NOT&id=444105.1]
                      https://support.oracle.com/CSP/main/article?cmd=show&type=NOT&id=444105.1

                      [Deploying Java Applets With Family JRE Versions in Java Plug-in for Internet Explorer|http://www.oracle.com/technetwork/java/javase/family-clsid-140615.html]
                      http://www.oracle.com/technetwork/java/javase/family-clsid-140615.html