1 Reply Latest reply on Aug 16, 2011 2:01 PM by 843228

    Blank screen after cloning database

      EDIT: Please see our reply - Things have changed


      we cloned a working and fully functional database with apex 4 installed on the same host (Note 228257.1).
      The cloned database seems to work normally but apex/the browser shows only a blank/white screen and "redirects" to /pls/clone*/apex* instead of showing the apex pages on /pls/clone (without /apex) like in the normal environment.
      We use the Oracle 10GR2 http server (on a different machine).

      When we shutdown the clone-instance and call /pls/clone we get an 503 (Temporarily Unavailable)
      When we call /pls/clone/apex_admin and we get an "Object not found" error.

      Here is the part of the dads.conf on the http server:
      <Location /pls/clone>
      Order deny,allow
      PlsqlDocumentPath docs
      AllowOverride None
      PlsqlDocumentProcedure wwv_flow_file_manager.process_download
      PlsqlDatabaseConnectString XXX.yyy.de:1521:DBCLONE
      PlsqlNLSLanguage GERMAN_GERMANY.AL32UTF8
      PlsqlAuthenticationMode Basic
      SetHandler pls_handler
      PlsqlDocumentTablename wwv_flow_file_objects$
      PlsqlDatabaseUsername APEX_PUBLIC_USER
      PlsqlDefaultPage apex
      PlsqlDatabasePassword htmldb
      PlsqlCGIEnvironmentList AUTHORIZATION
      Allow from all
      And here the listener / tnsnames.ora part (same on http server and database host)
      DBCLONE =
      (ADDRESS = (PROTOCOL = TCP)(HOST = = 1521))
      A connection via sqlplus user/pass@DBCLONE works (from both servers).

      What is the problem? We also tried to connect in the dads.conf via
      PlsqlDatabaseConnectString DBCLONE
      instead of
      PlsqlDatabaseConnectString XXX.yyy.de:1521:DBCLONE
      but it did not help either.

      Daniel and Michael

      Edited by: MJosten on 16.08.2011 01:35

      Edited by: MJosten on 16.08.2011 06:57
        • 1. Re: Blank screen after cloning database
          We discovered that the database cloning did not succeed completely because the tempfile was not set correctly.

          So we dropped the database clone and cloned again - This time without errors.

          Still APEX does not work correctly but the error has changed:
          1) We get a "Object not found error" (http 404) instead of the white screen
          2) When we type "/pls/clone" a page and sessionid is appended to the url automatically (/pls/clone/f?p=4500:1:3433434343)
          3) We tried to call a public procedure via http (like f is included in APEX_040000 our test procedure was in another scheme) and it works

          But why does apex seem to work but you only see "Object not found"!?