12 Replies Latest reply: Sep 2, 2011 8:30 PM by user491422 - oracle RSS

    Encountered error starting orchestration

    ace303389
      Hi,

      I'm new with OSM 7 and I have many issues not been resolve one of this is
      - after I created an order using "New Order" (Manual) and then Update (with status Submit) in CreateCommunicationsSalesOrderTask.
      I received a message "encountered error starting orchestration". I used the CommunicationsSalesOrderFulfillmentPIP cartridge
      and that cartridge where not modified except to correct the error which is "Add un implemented method"
      and "removing the @overide in one of the method". And also this cartridge has "Warning" Health in the Weblogic.

      Do you have any idea regarding this issue?
      Do I need first to configure the cartridge or create an orchestration?

      And also the order from CRM is always failed same with using SAOPUI
      but when I correct the validation I get an error "Variable $inputDoc has not been declared".

      I hope you can help me with this.

      Thanks,
      Ace
        • 1. Re: Encountered error starting orchestration
          deepdey
          Hi Ace,

          Just curious, is there any specific reason why you started with Order-to-Activate (O2A) cartridges? I am asking you this question as O2A cartridges are pretty complex and if you are new to OSM 7 you should start with creating a simple COM cartridge with Orchestration and test it, then play with the O2A cartridges.

          Just a thought!

          Thanks,
          Deepankar (Deep) Dey
          OSM - Product Management
          • 2. Re: Encountered error starting orchestration
            ace303389
            Hi Deep,

            That is the cartridge we're going to use in our organization, most of us are new with OSM so we take the Oracle OSM training (LVC) but it is v6.3.
            With the knowledge I gained I'm still having difficulty to apply it using OSM v7. For now our focus is to use the cartridge to process the order. But
            we're encounted problem processing the orders. I suspect that the deployment of the cartridge have problem and there's some setup I need to do.
            To support my conclusion I deploy the demo version in the design studio (bb_ocm_demo.osmCartridge), with the demo version I successfully process the
            orders. Do you think that there's some config/setup I miss with cartridge?

            Thanks,
            Ace
            • 3. Re: Encountered error starting orchestration
              Daniel Ho
              Hi Ace,

              Which cartridge is having a health warning in WLS? An emulator, or oms itself? I think I will start looking into that first -- what is the warning about?

              Cheers
              Daniel Ho
              Product Management -- OSM
              • 4. Re: Encountered error starting orchestration
                ace303389
                Hi Daniel,

                Here are the cartridges that have a warning osm_CommunicationsSalesOrderFulfillmentPIP_1_0_0 and osm_OracleCgbuSIFalloutPIP_1_0_0.ear.
                Before the cartridge was deployed it have an error.

                The error was fixed by following the Design Studio(Eclipse) suggestions.
                The two cartridges have the similar errors
                1) The type OrderStateChangeHandlerAutomator.DynamicJMSTransport must implement the inherited abstract method TransportSubSystem.sendRequest (AbstractScriptPluginImplementation, String, AutomationContext, String)
                2) The method getJavaBindings() of type OrderStateChangeHandlerAutomator.DynamicJMSTransport must override or implement a supertype method

                - Also most of the cartridges have a warning, in CommunicationsSalesOrderFulfillmentPIP/model/RECOGNITIONRULE/SalesOrderForOrchestration.orderRecognitionRule the warning says that “Warning 1 of 1: The Order Recognition Rule "BroadbandServicesProvisioningOrderRecognitionRule" also has the relevancy”.

                This is the error description from SOAPUI:
                Failed to create and start the order due to java.lang.RuntimeException: com.mslv.oms.OMSException: encountered error starting orchestration caused by:Cannot find entity in orchestration model: oracle.communications.ordermanagement.orchestration.generation.e@1cd5dba[name=Service.Unknown,namespace=CommunicationsSalesOrderFulfillmentPIP,type=T=ProductSpec@http://xmlns.oracle.com/communications/ordermanagement/model]

                And for the "encountered error starting orchestration"
                <Error> <oms> <cht1003vm04> <OSM_Admin> <ExecuteThread: '12' for queue: 'oms.web'> <osmuser> <BEA1-63FB39D01BAC81281F99> <> <1311850752266> <BEA-000000> <completeorder.CompleteOrderHandlerEJB: encountered error
                oracle.communications.ordermanagement.orchestration.execution.OrchestrationExecutionException: Error creating orchestration plan at oracle.communications.ordermanagement.orchestration.execution.impl.c.a(Unknown Source)....and so on....
                That error logs is same with SOAPUI error logs.

                I hope you can help me with this.

                Thanks,
                Ace
                • 5. Re: Encountered error starting orchestration
                  Carlos.Manjarres-Oracle
                  Ace:

                  Please describe the versions of both the OSM server and also the AIA Order to Activate (O2A) Cartridges you are trying to test.

                  Carlos
                  • 6. Re: Encountered error starting orchestration
                    ace303389
                    Hi Carlos,

                    The OSM is version 7.0.1 and the cartridge is 7.0.1.
                    Actually we're checking on this, we're going to re-deploy the cartridge and also the OSM patch.
                    We will follow the updated documentation of the cartridge guide.
                    I guess the procedure of the deployment causing the problem, because there's one cartridge that
                    not included in the documentation that we've followed but it is need to deploy according to the updated documentation.
                    We're hoping that the problem will resolve after the re-deployment.
                    Thanks for you reply.

                    Regards,
                    Ace
                    • 7. Re: Encountered error starting orchestration
                      869235
                      Hi Ace,

                      I am also facing the same problem after deploying these cartriges. Could you please post the resolution you found for the given issue.

                      Thanks,
                      RS
                      • 8. Re: Encountered error starting orchestration
                        ace303389
                        Hi RS,

                        Unfortunately my problem still not resolve. Currently we are updating all the possible patch needed.
                        You may do the following.
                        1. Make sure that O2A cartridge is supported by the OSM version (There are no errors in the cartridge after following this).
                        2. Check the OSM logs and other logs associated with OSM.
                        3. Test the cartridge using the design studio as instructed in the latest guide (also not able to create order using this).
                        4. The osm and cartridge must not have any error upon deployment.
                        5. Veryfiy if you follow all the setup needed to run OSM and other applications that connected to it.
                        6. Raise an SRs to oracle support (though we have same problem but the root cause could be different, its better to ask these guys
                        who have more experienced.).

                        Regards,
                        Ace
                        • 9. Re: Encountered error starting orchestration
                          882807
                          Hi Ace,

                          Am able to create Order from design studio. Are you still not able to create ? Have you copied the salesorder examples that came along with PIP(ie., SalesOrderSubmission folder)

                          Thanks
                          Naveen Jabade
                          • 10. Re: Encountered error starting orchestration
                            ace303389
                            Hi Naveen,

                            Yes, I'm still unable to process the order.
                            I also used the examples from SalesOrderSubmission and test it using Design Studio, SOAPUI and from Siebel.
                            But all of them was failed in creating an orders.
                            As a work around we already install all posible patches needed, redeploy all cartridge, re-install OSM, create new schema.
                            Also create another WebLogic and from that create new Schema, install OSM and deploy cartridge and other stuff.
                            But still getting the same error.
                            Do you think there is some security blocking?
                            We have followed all the instruction on how to install OSM along with other things needed to install.
                            May I know the procedure you follow from start to end?

                            Thanks,
                            Ace
                            • 11. Re: Encountered error starting orchestration
                              ace303389
                              This is an environment issue, after installing again all the system requirements based on the pre-requisite's its now working.
                              • 12. Re: Encountered error starting orchestration
                                user491422 - oracle
                                Thanks for the update Ace. Glad to hear you were able to sort this out.

                                Regards,

                                Brian.