This discussion is archived
2 Replies Latest reply: Sep 2, 2011 2:22 PM by user406494 RSS

11GR2.0.1 Install failed: [INS-20802] Oracle Net Configuration Assistant fa

user406494 Newbie
Currently Being Moderated
I am trying to install Oracle 11gR2 on Windows 7. My latest attempt after removing some files is:
[INS-20802] Oracle Net Configuration Assistant failed.

I chose the "Personal Database" option. The only other info from the error is
"Cause - The plug-in failed in its perform method Action - Refer to the logs or contact Oracle Support Services. "

I looked at the trace file and saw this one error:
Ignoring exception in isHASConfigured: PRCT-1400 : getcrshome execution failed. Detailed error:

localnode
[main] [ 2011-09-01 16:20:20.720 PDT ] [HAUtils.isHASConfigured:365] oracle.cluster.deployment.ClusterwareInfo.getConfiguredCRSHome(ClusterwareInfo.java:425)
oracle.sysman.assistants.util.hasi.HAUtils.getCRSHome(HAUtils.java:592)
oracle.sysman.assistants.util.hasi.HAUtils.getHASHome(HAUtils.java:652)
oracle.sysman.assistants.util.hasi.HAUtils.isHASConfigured(HAUtils.java:360)
oracle.net.ca.InitialSetup.checkHAConfiguration(NetCA.java:4668)
oracle.net.ca.InitialSetup.<init>(NetCA.java:4085)
oracle.net.ca.NetCA.main(NetCA.java:409)
[main] [ 2011-09-01 16:20:20.720 PDT ] [InitialSetup.checkHAConfiguration:4706] HA Server is NOT configured.
[main] [ 2011-09-01 16:20:20.727 PDT ] [NetCAResponseFile.<init>:68] Response file initialized: C:\app\klitwak\product\11.2.0\dbhome_1\network\install\netca_typ.rsp
[main] [ 2011-09-01 16:20:20.731 PDT ] [NetCAResponseFile.getInstalledComponents:107] Installed components from response file: server, net8, javavm
[main] [ 2011-09-01 16:20:20.732 PDT ] [NetCAResponseFile.getVirtualHost:164] Virtual Host from response file: null
[main] [ 2011-09-01 16:20:20.732 PDT ] [SilentConfigure.performSilentConfigure:174] Typical profile configuration.
[main] [ 2011-09-01 16:20:20.764 PDT ] [ConfigureProfile.setProfileParam:136] Setting NAMES.DIRECTORY_PATH: (TNSNAMES, EZCONNECT)
[main] [ 2011-09-01 16:20:20.764 PDT ] [ConfigureProfile.setProfileParam:136] Setting SQLNET.AUTHENTICATION_SERVICES: (NTS)
[main] [ 2011-09-01 16:20:20.765 PDT ] [ConfigureProfile.setDefaultProfileParams:109] Not setting ADR_BASE: sqlnet.ora already exist!
[main] [ 2011-09-01 16:20:20.786 PDT ] [SilentConfigure.performSilentConfigure:182] Typical listener configuration.
[main] [ 2011-09-01 16:20:20.789 PDT ] [ConfigureListener.isHASConfigured:1435] Calling SRVM api to check if Oracle Restart is configured ...
[main] [ 2011-09-01 16:20:20.790 PDT ] [HAUtils.getHASHome:631] Oracle home from system properties: C:\app\klitwak\product\11.2.0\dbhome_1
[main] [ 2011-09-01 16:20:20.790 PDT ] [HAUtils.getCRSHome:588] Getting configured CRS/HAS home for Oracle home ( C:\app\klitwak\product\11.2.0\dbhome_1 ) ...
[main] [ 2011-09-01 16:20:20.790 PDT ] [GETCRSHOMEUtil.<init>:88] Toolname: getcrshome.exe --- Tool location: C:\app\klitwak\product\11.2.0\dbhome_1\binTool dependencies: [Ljava.lang.String;@21b64e6a
[main] [ 2011-09-01 16:20:20.790 PDT ] [CmdToolUtil.doexecute:360] starting remote exec server on local node src=C:\app\klitwak\product\11.2.0\dbhome_1\bin dest=C:\Users\KLitwak\AppData\Local\Temp\
[main] [ 2011-09-01 16:20:20.791 PDT ] [Utils.getLocalHost:356] Hostname retrieved: klitwak, returned: klitwak
[main] [ 2011-09-01 16:20:20.791 PDT ] [WindowsSystem.startRemoteExecServer:1728] WS: Checking if service is started

[main] [ 2011-09-01 16:20:20.792 PDT ] [Utils.getLocalHost:356] Hostname retrieved: klitwak, returned: klitwak
[main] [ 2011-09-01 16:20:20.792 PDT ] [WindowsSystem.dorunRemoteExecCmd:2061] WS: Calling windowsNative with cmd: C:\app\klitwak\product\11.2.0\dbhome_1\bin\getcrshome.exe
[main] [ 2011-09-01 16:20:21.798 PDT ] [WindowsSystem.dorunRemoteExecCmd:2064] WS: WinNative returned: true
[main] [ 2011-09-01 16:20:21.799 PDT ] [WindowsSystem.dorunRemoteExecCmd:2078] WS: remote command executed, but didn't return zero.
[main] [ 2011-09-01 16:20:21.800 PDT ] [GETCRSHOMEUtil.getCRS_HOME:147] cmdTool.execute() failed.
[main] [ 2011-09-01 16:20:21.801 PDT ] [HAUtils.isHASConfigured:364] Ignoring exception in isHASConfigured: PRCT-1400 : getcrshome execution failed. Detailed error:
localnode
[main] [ 2011-09-01 16:20:21.802 PDT ] [HAUtils.isHASConfigured:365] oracle.cluster.deployment.ClusterwareInfo.getConfiguredCRSHome(ClusterwareInfo.java:425)
oracle.sysman.assistants.util.hasi.HAUtils.getCRSHome(HAUtils.java:592)
oracle.sysman.assistants.util.hasi.HAUtils.getHASHome(HAUtils.java:652)
oracle.sysman.assistants.util.hasi.HAUtils.isHASConfigured(HAUtils.java:360)
oracle.net.ca.ConfigureListener.isHASConfigured(ConfigureListener.java:1438)
oracle.net.ca.ConfigureListener.isHASRunning(ConfigureListener.java:1460)
oracle.net.ca.ConfigureListener.validateListenerName(ConfigureListener.java:1707)
oracle.net.ca.ConfigureListener.typicalConfigure(ConfigureListener.java:172)
oracle.net.ca.SilentConfigure.performSilentConfigure(SilentConfigure.java:185)
oracle.net.ca.InitialSetup.<init>(NetCA.java:4169)
oracle.net.ca.NetCA.main(NetCA.java:409)
[main] [ 2011-09-01 16:20:21.802 PDT ] [ConfigureListener.isHASConfigured:1446] Is Oracle Restart configured: false
[main] [ 2011-09-01 16:20:21.803 PDT ] [ConfigureListener.isHASRunning:1475] Is Oracle Restart running: false
[main] [ 2011-09-01 16:20:21.804 PDT ] [ConfigureListener.typicalConfigure:204] Checking for free port in range: 1521-1540
[main] [ 2011-09-01 16:20:21.804 PDT ] [ConfigureListener.isPortFree:1013] Checking if port 1521 is free on local machine...
[main] [ 2011-09-01 16:20:21.831 PDT ] [ConfigureListener.isPortFree:1028] InetAddress.getByName(127.0.0.1): /127.0.0.1
[main] [ 2011-09-01 16:20:21.834 PDT ] [ConfigureListener.isPortFree:1030] Local host IP address: klitwak/169.254.45.65
[main] [ 2011-09-01 16:20:21.834 PDT ] [ConfigureListener.isPortFree:1032] Local host name: klitwak
[main] [ 2011-09-01 16:20:21.836 PDT ] [ConfigureListener.isPortFree:1054] wildcard InetAddress i.e InetAddress.getByName(::) : /0:0:0:0:0:0:0:0
[main] [ 2011-09-01 16:20:21.837 PDT ] [ConfigureListener.isPortFree:1057] Creating ServerSocket on Port:1521, wildcald InetAddress: /0:0:0:0:0:0:0:0
[main] [ 2011-09-01 16:20:21.849 PDT ] [ConfigureListener.isPortFree:1060] Created ServerSocket successfully.
[main] [ 2011-09-01 16:20:21.850 PDT ] [ConfigureListener.isPortFree:1065] Creating ServerSocket on Port:1521, IP Address: klitwak/10.10.128.155
[main] [ 2011-09-01 16:20:21.853 PDT ] [ConfigureListener.isPortFree:1068] Created ServerSocket successfully.
[main] [ 2011-09-01 16:20:21.854 PDT ] [ConfigureListener.isPortFree:1080] Creating ServerSocket on Port:1521, Local IP Address: /127.0.0.1
[main] [ 2011-09-01 16:20:21.856 PDT ] [ConfigureListener.isPortFree:1084] Created ServerSocket successfully.
[main] [ 2011-09-01 16:20:21.858 PDT ] [ConfigureListener.isPortFree:1090] Creating ServerSocket on Port:1521
[main] [ 2011-09-01 16:20:21.863 PDT ] [ConfigureListener.isPortFree:1093] Created ServerSocket successfully.
[main] [ 2011-09-01 16:20:21.867 PDT ] [ConfigureListener.isPortFree:1113] Returning is Port 1521 free: true
[main] [ 2011-09-01 16:20:21.867 PDT ] [ConfigureListener.typicalConfigure:211] Using port: 1521
[main] [ 2011-09-01 16:20:21.873 PDT ] [ConfigureListener.setListenerParam:1789] Setting ADR_BASE_LISTENER: C:\app\klitwak
[main] [ 2011-09-01 16:20:21.884 PDT ] [ConfigureListener.isPortFree:1013] Checking if port 1521 is free on local machine...
[main] [ 2011-09-01 16:20:21.885 PDT ] [ConfigureListener.isPortFree:1028] InetAddress.getByName(127.0.0.1): /127.0.0.1
[main] [ 2011-09-01 16:20:21.885 PDT ] [ConfigureListener.isPortFree:1030] Local host IP address: klitwak/169.254.45.65
[main] [ 2011-09-01 16:20:21.929 PDT ] [ConfigureListener.isPortFree:1032] Local host name: klitwak
[main] [ 2011-09-01 16:20:21.930 PDT ] [ConfigureListener.isPortFree:1054] wildcard InetAddress i.e InetAddress.getByName(::) : /0:0:0:0:0:0:0:0
[main] [ 2011-09-01 16:20:21.930 PDT ] [ConfigureListener.isPortFree:1057] Creating ServerSocket on Port:1521, wildcald InetAddress: /0:0:0:0:0:0:0:0
[main] [ 2011-09-01 16:20:21.931 PDT ] [ConfigureListener.isPortFree:1060] Created ServerSocket successfully.
[main] [ 2011-09-01 16:20:21.932 PDT ] [ConfigureListener.isPortFree:1065] Creating ServerSocket on Port:1521, IP Address: klitwak/10.10.128.155
[main] [ 2011-09-01 16:20:21.933 PDT ] [ConfigureListener.isPortFree:1068] Created ServerSocket successfully.
[main] [ 2011-09-01 16:20:21.933 PDT ] [ConfigureListener.isPortFree:1080] Creating ServerSocket on Port:1521, Local IP Address: /127.0.0.1
[main] [ 2011-09-01 16:20:21.934 PDT ] [ConfigureListener.isPortFree:1084] Created ServerSocket successfully.
[main] [ 2011-09-01 16:20:21.934 PDT ] [ConfigureListener.isPortFree:1090] Creating ServerSocket on Port:1521
[main] [ 2011-09-01 16:20:21.935 PDT ] [ConfigureListener.isPortFree:1093] Created ServerSocket successfully.
[main] [ 2011-09-01 16:20:21.935 PDT ] [ConfigureListener.isPortFree:1113] Returning is Port 1521 free: true

I have looked in the log file and see nothing of interest. Any suggestions as to what I might do to fix this? Thanks.

Ken

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points